PIA VPN App - Linux Beta

11315171819

Comments

  • edited September 2015 Posts: 45
    Anyone got this thing to run on Debian 8.2?  I have installed it with no problems on Ubuntu and Mint, but have all kinds of problems on Debian.
    QUOTES :

    Not sure what's going on but this doesn't do anything anymore except for delete pretty much everything from my install. It was working just a few days ago. I'm trying to get it running on Debian Jessie but it keeps wiping my system. Have to reinstall all DEs and fix dependencies, etc., etc.. Can't recommend trying this on the latest Debian release.
    Anyone experience this and figure out what's going on?
    EDIT: OK. Just reinstalling Jessie at this point.

    I am running Debian Jessie 8.1. Every time I run linux_install.sh, it first ask for the sudo password, then proceed to remove all sorts of KDE services that I am no longer able to log in to the machine.  Why are you scripting to remove KDE related services and programs?  This is the third time I tried and it happened all three times.
    When Debian Wheezy was running I could download the installer for ubuntu and everything went fine without destroying my  OS
    What is up PIA? I really like the convenience and extra encryption and reliability provied by PIA program. It works like charm on Linux Mint KDE ed. Why not on Debian Jessie?


    I have experienced the same problems with a lot of deletions making my system unusable.
    From the release notes :

    The installer will attempt to apt-get install 4 dependencies: libjpeg62, libxss1, libappindicator1, libgail18
    The problem seems to be with libjpeg62  .
    If I simulate apt install :

    apt-get install -s libjpeg62
    this is the result  :

    The following NEW packages will be installed:
      esound-common foomatic-filters libaudiofile1 libesd0 libjpeg62
    0 upgraded, 5 newly installed, 281 to remove and 19 not upgraded.

    libjpeg62 has been replaced by libjpeg62-turbo so the script needs attention and updating.

    read my previous comments

    still waiting for any update from support and Kat

    we still seem to be neglected us poor linux users 
    :)
    Post edited by pjnsmb on

  • The previous entry  is from a previous comment of mine .I am still waiting for an update from support and Kat about an update to Beta V.47
  • edited October 2015 Posts: 4
    In case it's of use, I managed to get the PIA Linux beta client running on Arch. So this should also work for Antergos, Manjaro and other Arch-based distros.

    I managed to get the beta Linux app working on two different Arch installations, but it's not particularly straightforward.  These are my rough notes, in case they're useful to anyone else. There may be some package dependencies I don't know about, because I already had them installed for something else (I ran into this issue when installing on the 2nd machine).

    * pacman -S lib32-libjpeg ; cd /usr/lib32 ; ln -s libjpeg.so libjpeg.so.62
    * pacman -S openvpn libxss net-tools (the latter for ifconfig)

    Other packages from AUR:

    * also needed is some gstreamer package (not sure - I have 1.6 & 0.10 & 0.10-base 0.10-base-plugins and the lib32 versions of the last 3 packages)
    * libappindicator-{gtk2,gtk3,sharp} (probably all of them aren't need, but at least one of them is, and I'm not sure which)
    * libgnutls26
    * libgcrypt15

    In theory one could edit the installer script, which expects apt-get, but it'll run, with complaints, and install `pia.sh` in the user home once all of the package dependencies are met. In fact, it'll install `pia.sh` whether or not the dependencies are met, which is useful, in that one can edit `pia.sh` so that errors *aren't* directed to /dev/null, which can be useful in figuring out which packages may be missing.

    In the end, the "active ingredient" ends up being `openvpn` anyway. I can see the following process running:

    openvpn --client --persist-key --persist-tun --comp-lzo yes --dev tun --script-security 2 --remote 26.142.110.139 8080 --auth-user-pass /home/emacsomancer/.pia_manager/data/user_pass.txt --writepid /home/emacsomancer/.pia_manager/log/openvpn.pid --proto udp --nobind --management 127.0.0.1 31749 --log-append /home/emacsomancer/.pia_manager/log/openvpn.log --remote-cert-tls server --cipher aes-256-cbc --auth sha256 --ca /home/emacsomancer/.pia_manager/data/ca.crt --pia-signal-settings --daemon


    Post edited by emacsomancer on
  • hi i really hope some one can help a beginner out,im using ubuntu 15.10 and only been learning a week and not up to speed with commands,ive been told by online chat that i need to install this app which im quite happy about as it would be easier than typing commands out.
    so question is and i hope you can do it in simple form but how do i install this linux app please i see the commands and i have download it ready in downloads libarary.

    many thanks in advance.
  • i finally worked out how to install it got all the way to the end and being very happy with myself and i get this

    Couldn't load file:/home/rick/.pia_manager/pia_tray.64/runtime/1.3.2-beta/libtide.so, error: libgcrypt.so.11: cannot open shared object file: No such file or directory

    i even went into search and typed in private and the little grean man is there
    and then this happens again
  • Posts: 186
    @rick75fowler

    On page 14 of this thread, there is an exchange of posts between @Maxfli and @Broken666 that appear to solve your issue.  Good luck! 
  • Posts: 167
    Update Sat November 28, 2015
  • Posts: 45
    It might solve the IP leak vulnerability but while the installer still tries to install libjpeg62 instead of it's replacement libjpeg62-turbo it wants to delete 301 packages on my system !

    My comments on September 9th highlighted this problem and it still applies
  • Posts: 167
    @pjnsmb
    When we release v.53 installer (which should be later today) you will be able to pass --skip-deps to installer_linux.sh to skip the apt-get install stuff.
  • Any chance PIA could support a PPA for the installer?
  • Posts: 167
    @pjnsmb
    Now with version v.53 you can do:

    ./installer_linux.sh --skip-deps

    Please let us know if this fixes your issue.
  • Posts: 45
    I have tried using ./installer_linux.sh --skip-deps without success -

    from the first page release notes :

    I have manually installed libxss1 libappindicator1 libgail18 ok

    I still cannot install libjpeg62 without wiping my system ................

    I do get - Installation complete! I have :


     - The installer will create an application launcher entry in  ~/.local/share/applications -YES it does

    - The installer will create an entry in ~/.config/autostart for automatic start on login
      - But this can be controlled through the app as usual -YES it does

    - The installer will create a ~/pia.sh script for starting the app from a terminal -YES it does 

    Unfortunately the app does not start at all 



    thanks
  • Posts: 167
    @pjnsmb
    You simply need to get libjpeg.so.62 onto your system somehow.  You could use a different .deb package or you could probably compile it yourself from source.  Or you could extract the libjpeg62 package yourself and place the file in /usr/lib.
  • Posts: 186
    Installed right over the older version with no troubles in Linux Mint 17.2 w/ cinnamon.  Still have the blank space next to the PIA icon in the tray (I suspect the PIA robot is a pixel or two too wide?) 
    8-|
  • Posts: 45
    Support said:
    @pjnsmb
    You simply need to get libjpeg.so.62 onto your system somehow.  You could use a different .deb package or you could probably compile it yourself from source.  Or you could extract the libjpeg62 package yourself and place the file in /usr/lib.
    I have extracted libjpeg.so.62 to /usr/lib . it is shown as a link to libjpeg.so.62.0.0 which I have extracted there too. It still will not launch the app !
  • Does anyone have the linux client working with Ubuntu using an encrypted home directory? Is it possible?

    While I can install the app on Ubuntu 15.10, I can't get it to connect and I suspect it has something to do with the fact that my home directory is encrypted.
  • Posts: 186
    @deathhilarious

    https://www.privateinternetaccess.com/forum/discussion/comment/21575/#Comment_21575

    You are correct about the encrypted home directory causing problems.  The above link should point you in the right direction.
  • pyro12 said:
    @deathhilarious

    https://www.privateinternetaccess.com/forum/discussion/comment/21575/#Comment_21575

    You are correct about the encrypted home directory causing problems.  The above link should point you in the right direction.
    pyro12! That worked perfectly.
    :-bd
  • Can someone please post the Official SHA and MD5sum for the installer please.
  • Apologies if this is in the wrong place... I've continually had the same problem with PIA that I cannot resolve any local hostnames. I've just installed the linux app (I previously used the OpenVPN script) and I was hoping that it would solve that problem. What am I doing wrong?

    I'm able to connect to my server using the local ip eg 192.168.1.60 but its easier for my girlfriend to be able to connect directly using the hostname eg server1

    Any help is much appreciated
  • edited December 2015 Posts: 186
    @stefan Are you running the app on a computer that acts as a gateway for you LAN or are you running it on a single machine within your LAN?

    As a last resort, don't forget you can manually edit your hosts file in /etc/hosts

    I'm interested to learn what is happening here.

    Maybe you need to manually enter your LAN server as an alternate DNS server?  I doubt the PIA DNS server can resolve your local hostnames and perhaps your setup is prohibiting DNS lookups anywhere else?
    Post edited by pyro12 on
  • edited December 2015 Posts: 4
    I'm running the app on a single machine, as my router doesn't support OpenVPN (it's a BT HomeHub 5), and the computer isn't a gateway for anything else on the network.

    If I need to edit the hosts file, what changes do I need to make? Also, if I set the DNS to be something else, what should it be to reflect the local network?

    I was under the impression from reading around that this should work out-of-the-box, but it just doesn't seem to at all.

    EDIT: I found what to add to the hosts file. Thanks for that suggestion! If I wasn't to change the hosts file how would I get around this problem?
    Post edited by stefan on
  • @stefan

    You don't mention what flavor of Linux you et al on your LAN are using but in my experience which goes back to the PIA linux client v.3x, DNS resolution of other machines on the LAN has always been an issue.  Mostly the reason for this is that when the PIA linux client is running/making a connection, it (the PIA linux client) modifies your '/etc/resolv.conf' file thusly:

    nameserver 209.222.18.222
    nameserver 209.222.18.218

    This prevents DNS server leaking, but also drops your router which is, mostly likely, also your DHCP server AND local DNS Server from the loop.  Thus your Linux machine(s) on the LAN no longer can resolve other machine on the LAN via name.

    Thus the need on Linux machines (using the PIA linux client) to add:

    IP-number-address   hostname

    into your '/etc/hosts' in order for name resolution between machines to work on the LAN.  I've never been able to figure a workaround for this issue so I do above mentioned edits to my '/etc/hosts/ file whenever I rebuild one of my Linux machines.

    BTW, you could try hard coding your router's IP address into your client machine's DNS server network config.  But then this would most likely cause DNS server leaking?  That should be avoided...

    https://www.dnsleaktest.com/
    .



    .

  • Posts: 186
    @stefan

    Please take heed of @martywd 's cautions, but the IP of your local nameserver is almost certainly the same as the IP of your DHCP server, which is most likely your router, and usually confgured as xxx.xxx.xxx.1 so, to follow your "eg," 192.168.1.1

    It sounds like whatever DNS changes you make are re-edited by the app, anyhow, though.

    You're right about this not working 'out of the box' but I've had so much fun and learned so much fiddling with it that I can't complain - the truth is that it requires configuring because of how flexible it is.  You really do have a plethora of configuration options to sort through to find the one that suits your needs...


  • Thank you both very much for the pointers. It seems that the easiest is editing the hosts file which I've now done. Would maybe be useful for other users if PIA included it in their FAQ or with their Tier 1 service agents. Thanks again.
  • Installed on xubuntu 15.10  works after searching for and installing outdated libgcrypt and a couple other dependencies.  wanted libgcrpypt 11  ubuntu has libgcrypt 20 an 11 is not in the repos    the software also makes xubuntu 15.10 hang on shutdown for 2 to 3 minutes unless you disconnect the tunnel and exit the pia software
  • geez   i just noticed this thread is from 2013  sorry
  • broken666 said:
    Maxfli:

    You need to install libcrypt11 from an older linux release... go here:


    download that .deb and install it, that will fix your libtide/libcrypt error
    Thank you so much, I was getting gray hairs trying to make this work on Ubuntu 15.10 and downloading libgcrypt11 from you link aswell as libgnutls26 from http://packages.ubuntu.com/trusty/libgnutls26 made this work! I downloaded them and opened them with Ubuntu Software Center and installed them. The app works now :D.

    I feel pretty dumb after having spent days trying to figure it out and I just wanted to give some help to anyone trying to install this on 15.10 ubuntu.
    If that version of libgnutls26 doesn't work for you, try the 12.04 one http://packages.ubuntu.com/search?keywords=libgnutls26 This may or may not work with other Ubuntu versions, I suggest you give it a try though.
  • Hi guys

    If you are having an issue with PIA not connecting and have encrypted home folder enabled. The fix is as follows.

    I didnt come up with the idea but the post i found was very vauge for a new user.

    Please change what i have highlighted BOLD in the code to your username for the pc

    Step 1. Create a folder outside of the home directory that your user account can write to.

    In Terminal

    cd /

    sudo mkdir pia

    sudo chown yourusername:yourusername pia

    Step 2. Move the PIA files to new directory

    sudo mv /home/yourusername/.pia_manager /pia/.pia_manager

    Step 3. Create symbolic link between the new and old folder.

    ln -s /pia/.pia_manager /home/yourusername/.pia_manager

    Now reboot and pia should connect :)

    Hope this helped.





  • Posts: 14
    Just installed the application on Kubuntu 15.10, the installation process went fine however when launching pia i get this error:
    Couldn't load file:/home/MYNAME/.pia_manager/pia_tray.64/runtime/1.3.2-beta/libtide.so, error: libgcrypt.so.11: cannot open shared object file: No such file or directory

    So I followed what has already been suggested here to install libcrypt11 and libgnutls.so.26. For me the second link didn't work and I downloaded it from http://security.ubuntu.com/ubuntu/pool/main/g/gnutls26/libgnutls26_2.12.23-12ubuntu2.3_amd64.deb

    Anyway I'd recommend to include these files in the installar. Or at least make the installer check for these libraries and ask to install them.

    After the PIA app properly launched I'm unable to connect. The Icon turns green for a brief moment and then red. This is my DEBUG ID [ 9 9 6 ] do I need to open a ticket? I saw a lot of other people having this issue.
Sign In or Register to comment.