[Android] Private Internet Access APP Major Update - v1.2.4

edited July 2016 in Software and System Updates Posts: 167
To our beloved users,

We have updated our Android application and it's already live in the Google Play Application Store:

 image 
image

In addition to our usual settings, we've also included Per App settings so you can determine which application will use Private Internet Access and which won't!

Give it a try and if you like it, please give us a "high 5" by giving us a 5-star review!

CHANGE LOG for v1.2.4 [July 7]

- Introducing PIA MACE™, an option to block ads, trackers and malware when connected

- Certificate security improvements

- Added an alert when a setting change requires a VPN connection restart

- Fixed an auto connect issue on login page

- Fixed toggle button for per app settings

- Improved port forwarding reliability

- Improved server ping reliability

- Added a support contact link on the about page

- Added Android N support


CHANGE LOG for v1.2.2 [June 29]

- New app design

- Adds option to allow/disallow local LAN usage

- Adds ability to specify what apps can use the VPN (Android 5.0+ only)

- Adds option to use small packets for problematic networks (e.g. T-mobile US)

- Displays current/VPN IP

- Update to current OpenSSL version (1.0.2g)

- Makes a one-time configuration change to set encryption cipher from BF-CFC to AES-128-CBC (for improved perfomance). This change will only be done once, you may change it to your preferred setting after install



Post edited by menopia on
«1

Comments

  • I am very new to PIA and VPN in general... as in about 4 days into using a VPN and trying to learn as I go.  So, please keep that in mind with any responses loaded with jargon I won't understand.  

    With this new updated app, does this mean that this tutorial is now obsolete?

    Or am I supposed to be able to do both? Because I can't.  If I do the setup through Android Settings then the App disconnects and when I reconnect through the PIA App, vice versa.

    Also, is there anywhere that explains what these settings are for people that aren't networking/IT savvy people?  I can't find anything that explains these settings outside of "Internet Kill Switch" which I think I understand.  

    **Example... "Block Local Network" - I don't understand the pros and cons of either having it on or off.   If I keep it checked, is it hurting my data, text, web browsing performance?  If I un-check it, is my phone now left unprotected from people using the same public Wi-Fi?  No idea.  And it's not explained anywhere, which doesn't make sense if you're going to advertise your VPN service to people who aren't IT persons.  So, if someone can explain what each of those settings options does, in simple enough terms, it would be appreciated.

    Also, why can't I send texts out while PIA App is connected?  I have to manually disconnect from the VPN to send text messages from my phone.

     I apologize if these questions are answered already.  I've been searching on the forums for an hour and have found nothing.  Maybe a "VPN for Beginners" sticky would be a nice idea for the forums.


  • Posts: 167
    Hi reggie!  Thanks for using PIA and we really appreciate your business!

    You absolutely do not need to follow any manual guides.  We are going to update the site so it is more clear.  Sorry about the confusion.  Simply use the PIA App and you will be all set!

    As for the texts, that's weird.  That said, you can set your SMS application to send text messages outside of the VPN using the Per App settings!



  • I am not connecting at all outside my home. regardless of what settings that I use. I will try the UDP without the kill switch. The old app connected without fail.
  • Posts: 6
    Hi, since updating the app to the new version it has been disconnecting often. Maybe it will last about 15-30 minutes and then it will just stop receiving data. I have to then disconnect the app and then reconnect it before data will start again.

    This wasn't happening with the previous version
  • edited May 2016 Posts: 2
    fonik said:

    Hi, since updating the app to the new version it has been disconnecting often. Maybe it will last about 15-30 minutes and then it will just stop receiving data.

    I don't even get that much time. I don't connect at all. I've had to resort to using L2TP/Ipsec or nothing at all. The old version was fine just the way it was. In the future, I will hold off before updating.

    Post edited by mebiquitous on
  • edited June 2016 Posts: 6
    Hi, since updating the app to the new version it has been disconnecting often. Maybe it will last about 15-30 minutes and then it will just stop receiving data.
    I don't even get that much time. I don't connect at all. I've had to resort to using L2TP/Ipsec or nothing at all. The old version was fine just the way it was. In the future, I will hold off before updating.
    Well, I must say the new version looks prettier. But that doesn't mean anything if the functionality is now gone.
    No updates on this issue either? Surely support must be aware of this issue by now...
    Post edited by fonik on
  • I updated mine just now, I had previously changed my password via my Desktop PC so when I updated the android app it wouldn't connect (obviously), but lo and behold it won't let me change the password on the app itself. I can change the email address but the username and password field will only copy to clipboard and that's it.
     
    Don't update your app, its pointless anyway.
  • Just to pass on something I discovered elsewhere...
    I've recently updated my Galaxy Tab A to Marshmallow and the PIA app stopped working. After spending some time googling I eventually found the problem ... Power Saving was kicking in and closing the connection as soon as I switched away from the App! As soon as I disabled Power Saving it fixed the problem. Of course it would be better if it worked with Power Saving turned on, perhaps the app developers can look into this?
  • Posts: 1
    Updating to v1.2.4 today and all apps were disabled. The only reason why I noticed was I happened to go to PIA's website to read up on the update. Seems like the default should be enabled for all. 
  • Posts: 3
    It seems my app hast updated automatically since yesterday. Now it does not work anymore. It claims to work, I claims to connect and I see that I get a new IP but it does not use the VPN.
    This version is buggy - at least on my LG G4. Now I need to find a way to get the old version back
  • edited July 2016 Posts: 31
    What filters are applied to the PIA MACE ad-blocking? (and what is the full form of MACE)

    This technology still lets ads through..you can go on the following site and test it.

    Post edited by macclad on
  • My system was running dead slow this morning and I thought  I had a virus. PIA was using 85% CPU resources with over a dozen instances of the app and tray app running. If I shut them down, they restarted. I had to completely uninstall and download the new file.

    Win 10 system
  • Posts: 4
    tommyent said:
    Updating to v1.2.4 today and all apps were disabled. The only reason why I noticed was I happened to go to PIA's website to read up on the update. Seems like the default should be enabled for all. 
    I second this. Very weird to set the default to be off. You should be able to selectively disable it for some apps, instead of having to toggle it on for some apps.
  • Posts: 15
    How does PIA MACE™ work? What block lists is it using? What kind of trackers does it stop? How is it implemented?
  • edited July 2016 Posts: 1
    ropo said:
    It seems my app hast updated automatically since yesterday. Now it does not work anymore. It claims to work, I claims to connect and I see that I get a new IP but it does not use the VPN.
    This version is buggy - at least on my LG G4. Now I need to find a way to get the old version back
    I also have a LG G4 and I have the exact same problem. It does say it is connected and all, but my IP remain unchanged and unsecure.

    UPDATE! Opted into the beta program for this application on Google Play. Got a new beta version installed and it works again. So might be a solution for them with this problem!
    Post edited by Celestin on
  • Posts: 136
    After the update, it is not working really. 

    It shows connected, but the ip doesn't change to PIA IP
  • Posts: 283
    Hi.
    Can you kindly make the download available on your website, as I do not trust or use Google Play!
    Thanks!
  • Posts: 2
    Install newest version on a minix u1 does not work logon comes up for 1 sec then disappears then after that the screen just flashes. Went back to 1.17 and works fine.
  • Posts: 1
    It wasn't a slam dunk but I didn't have any of the problems I see here. It works fine on both the PC and Droid. My one issue is battery drain. Overnight, 8 hours or so, running the PIA app only I lost 37%. With out it running I would lose 2 or 3% This is perhaps since it doesn't pause when the screen is off? Maybe that can be added in a future release. I'm still satisfied with the product overall.

    Thanks, Geno
  • Posts: 5
    Hi, downloaded the latest version of VPN PIA from googleplay for my android box. 

    Seems to download it, and the green icon/logo appears on my homepage like a regular app.   But when I click on it to open it up, it just acts like a broken link and doesn't ask for the username or password. 

    Version of PIA I tried to download to the android box was ver 1.2.4

    Box is running android 4.4.2

    Model number MXQ
  • Hi

    I also have an issue.  As soon as PIA starts, it drops out again.  Connection doesn't stay on. 

    I've un-installed it and reinstalled.  Even did a factory reset on my android device - nothing seems to solve it.

    It was all working fine until the most recent PIA update.  PIA does seem fine on my desktop and laptop, just not on this android device - which is where I use it most.

    PIA Version 1.2.4 (50)

    Android box: Mbox MXIII
    Android version 4.4.2
    Build: MXIII v3.0
    Kernal 3.10.33

    Any suggestions or help would be appreciated!
    Thanks

  • For any one else with this issue - I've solved it by following the below article and rolling back to an older version - but I still would like to know why the latest version (1.2.4) is broken for android apps - it was working fine before update.....

    https://www.privateinternetaccess.com/forum/discussion/21696/pia-vpn-android-client-not-working-crashing

  • Posts: 283
    Maybe slightly off-topic but using my phone as a hotspot with PIA active, my laptop traffic does not go through the VPN. I opened a browser in my phone and went to https://www.privateinternetaccess.com/pages/whats-my-ip/ and my IP is shown as protected. Any thoughts?

    Piavipper
  • Posts: 1
    Hello,

    The PIA Android app icon no longer appears in the app drawer. Its shortcut icon disappeared from my desktop.

    This makes it harder to change servers and start/stop service. After I turn service off I have to go into Play Store to access PIA.

    Please ask the app developers to restore the app icon.

    Thanks
  • This doen't working anymore, Can't connect to any server using the app.
  • edited September 2016 Posts: 4
    turbogeno said:
    It wasn't a slam dunk but I didn't have any of the problems I see here. It works fine on both the PC and Droid. My one issue is battery drain. Overnight, 8 hours or so, running the PIA app only I lost 37%. With out it running I would lose 2 or 3% This is perhaps since it doesn't pause when the screen is off? Maybe that can be added in a future release. I'm still satisfied with the product overall.

    Thanks, Geno
    All is well except the battery drain. Since the 1.3 PIA update the battery drain is wicked bad. I checked the native android Doze as well as the android play Doze but nothing seems to curtail the drain. 

    Oddly I am at the same exact 37% as Geno.

    Thanks -netnet


    Post edited by netnet on
  • Hi.
    I had problems with the app disconnectiing but fixed it thus (Android 6, Marshmallow):

    Settings>Apps>PIA VPN>Battery>
    and turning on "keep running afterscreen off"

    Hope this helps.

    Vipper

    Note. this process may vary depending on what phone you have.
  • I could not connect with my Nexus 5x phone and finally figured out that PIA VPN doesn't work if you have Google WIFI Assistant enabled.  After I turned it off PIA started working.  Settings/Google/Networking/Wi-Fi Assistant

    Hope that helps someone.
  • edited September 2016 Posts: 32
    i have v 1.3 (66) on android 4.4.4, when i want to scroll in per app setting the app crash and stop. please fix this issue.
    Post edited by leodo on
  • The daily nag notifications about subscription renewal are really annoying. There should be a way to manage notifications in the app instead of having to block them via the OS.
Sign In or Register to comment.