PIA VPN android client not working - crashing

edited June 2016 in Android VPN Setup Posts: 2
I have the PIA VPN for Android installed on a MATRICOM G-Box Q TV Box, it was working perfectly.
yesterday it stopped working,it actually crashes right after launching.

- Same PIA VPN Client is still working perfectly on Android Samsung Note 4
- Client for windows is working perfectly
- Tried clearing data and cash for the client, uninstalling, reinstalling, problem not solved
- Tried clearing Androing device cash partition from Recovery, problem not solved
- Other client "OpenVpn" is working, but i still want to find how to configure it, but i do prefer the PIA VPN client

Any one experienced such issue lately?
Post edited by khaeid on
Tagged:
«1

Comments

  • Posts: 11
    Hi:

    I'm in the same boat. I tried another VPN for a while and, being that I paid for a 1 year subscription with PIA I attempted to go back to PIA. The Windows app works great. When I install the PIA Android App on my Minix Box and go to open it to enter my credentials the app window opens for a split second and closes. My Minix box ends up frozen and I have to reboot it. Prior to me trying another VPN service that PIA Android app worked fine. I do hope that this glitch doesn't have anything to do with some major changes that I've observed with PIA customer service i.e. the end of the live chat feature. P.S. Open VPN works ok on my Minix box.
  • Exact same deal on my M8 Android TTV Box. The PIA client crashes moments after it launches and it's only started happening in the last week or so. It had been working for 6 months without incident.

    Their support tell me they do not support rooted devices (which it is) but I think this is a bug in the latest version of the Android client and nothing to do with my box as I've not changed anything on it. 

    I've been happy with the speeds and service on the whole so far so it seems a shame that I have to cancel my subscription and find another decent VPN provider. Adios PIA.
  • edited July 2016 Posts: 1
    I have the same problem. Everything was working fo the last few months. Today when I was trying to connect on my Android mbox app window opens for a split second and closes. It started to crash even before the latest update. They changed something for sure.
    Post edited by Bogumil on
  • Posts: 1
    i have the exact same issue - keeps crashing right after it starts and whenever i try to connect to a server, it goes into a loop of starting then crashing then starting again.  i tried un-installing and then installing again but that hasn't helped. it was fine before the latest update. support don't seem to care. i wish there was a previous android version available.
  • Posts: 1
    I had the same issue yesterday after the app updated. I'm using a rooted M8 box and was also advised by PIA that they did not give support for rooted devices. I tried downloading the previous apk file but had the same problem then tried version 1.1.7 which worked. Not sure what problems it might cause using the older version (I know it was update following the issues with Russia) but will use it for the minute and am requesting a refund from PIA.
  • Posts: 1
    It's exactly the same for me it just crashes after flickering up on screen.

    I contacted support but they say they don't support Android TV boxes.

    I'm pretty sure their sales would be halved if it doesn't work on them, I have also asked for a refund for the balance of my subscription.
  • Posts: 2
    Same problem here on a minix u1 put version 1.17 back in and is working fine. hope they fix this problem been with them for a year and a half now but might have to leave.
  • @chopper - how do you revert to a previous version? Is there a download link for 1.17 that you are using (as long as its the Android version)? Thanks.

    @PIA tech support - clearly not an isolated case. Please try and sort this soon.


  • Posts: 8
    Exactly same problem here. Was working perfectly up to this morning and suddenly now it crashes trying to open it. How is everyone else on such low versions? My version is 1.2.4? I had a backup of 1.2.3 but same problem there too. Any word from tech?
  • Posts: 8
    Well, after wasting an afternoon on that, I tracked down version 1.17 and it does seem to be the last version that works reliably now.

    Here is the link on APKMirror (Good site for finding older versions of most apps)

  • Posts: 1
    Also having this issue and had to roll back to 1.1.7
  • Posts: 8
    Getting very frustrated now. Sure 1.17 works but I can't for the life of me connect to the device on my lan now so my Kodi remote or anything else won't work on it. Another 3 hours so far and nothing.

    It would be nice if Tech would at least admit this is a bug of some kind. The app doesn't suddenly stop working for this many people by chance. Especially when it worked perfectly before.
  • Posts: 1
    I had the same problem today after updating the app via Google play store.
    I discovered that version 1.2.4 and  1.2.1 crashed on my Matricom Box G Q2 with android 5.1.1.
    But if you use an old version 1.1.7 you gain functionality back again and works perfectly.

    By the way customer support from PIA sucks!
  • Hi

    I also have an issue.  As soon as PIA starts, it drops out again.  Connection doesn't stay on. 

    I've un-installed it and reinstalled.  Even did a factory reset on my android device - nothing seems to solve it.

    It was all working fine until the most recent PIA update.  PIA does seem fine on my desktop and laptop, just not on this android device - which is where I use it most.

    PIA Version 1.2.4 (50)

    Android box: Mbox MXIII
    Android version 4.4.2
    Build: MXIII v3.0
    Kernal 3.10.33

    Any suggestions or help would be appreciated!
    Thanks
  • edited July 2016 Posts: 7
    OK I confirm the rollback version does indeed fix this issue.  Clearly something is up with the latest version. 

    Is there a tutorial on rolling back APK ? 

    No - just un-install your current PIA version, then install the version 1.1.7 APK from here:    http://www.apkmirror.com/apk/private-internet-access/vpn-by-private-internet-access/vpn-by-private-internet-access-1-1-7-release/vpn-private-internet-access-1-1-7-android-apk-download/

    I have not tried version 1.2.1 yet - I think that may also work, as the problems I experienced are only with the current version (1.2.4)
    Post edited by android1980 on
  • Posts: 2
    version 1.1.7 APK working had to turn off auto update in Google account
  • edited July 2016 Posts: 2
    I had exactly the same error on a Matricom gbox q and also had to roll back to v1.1.7. Thanks for the link to the apk.
    Post edited by newbz on
  • Posts: 8

    I have not tried version 1.2.1 yet - I think that may also work, as the problems I experienced are only with the current version (1.2.4)
    I can confirm that 1.21 won't work either. You have to go all the way back to 1.17 which makes me think it's more than just the PIA app. I have a feeling it's a combination of the PIA app and another Google app (probably Google Play) that got updated and are no longer compatible together. Otherwise, 1.21 should work but it no longer does..

    PIA devs must've missed a notice from Google about a change and didn't make the appropriate changes to make it compatible.

    It would be nice if they could look at this as 1.17 doesn't work well with Kodi. (ie:
  • Same problem here. Not working on my MINIX X8-H plus or my mini m8s box. These boxes use different chipset S812 & S905, and different versions of Android, 4.4.2 and 5.1. This is new to the last update. It appears to effect Amlogic powered devices as it still works fine on my Qualcom Snapdragon powered phone. PLEASE FIX ASAP OR PROVIDE A SAFE LINK TO PREVIOUS PIA VERSIONS UNTIL YOU FIX THIS! I suspect a large percentage of your paying customers are using this chipset. BTW I use an Ethernet connection if that helps. I have been a paying customer for 8 months and have been very happy until now. I tried the basic clear cache, uninstall, reboot and reinstall that tech support suggested..... It did not help, app still immediately crashes.
    Please help.
  • Does anyone know if this APK mirror site is safe? I have seen a bunch of malware on these sites in the past. I would much prefer if PIA provided a safe link.
  • Posts: 1
    im using an android box as well what works for me after signing in is to simply hit the back button instead of home dont know why but works for me on latest version using mxq pro box
  • Posts: 5
    Thanks to all of you that did the work finding a temporary fix for this problem!  my M8S, KI Plus and MX III-G boxes all had the same behaviors as mentioned in prior posts.  Problems only started today after updating to version 1.2.4 four days ago. 1.1.7 works well for now.

    I'll be waiting for the permanent fix too.  Other than this, PIA has been top shape for me for the last several years without any problems.
  • edited July 2016 Posts: 2
    Same problem here Android box Minix U1 put Ver 1.17 back working fine again. But I would like to have latest version working!!!!!

    Please note: This is a Non-Rooted Device!
    Post edited by seachaser on
  • Posts: 2
    Does anyone know if this APK mirror site is safe? I have seen a bunch of malware on these sites in the past. I would much prefer if PIA provided a safe link.
    You don't like "willysnax" link?
  • Seriously, thanks for this thread. 

    Been dealing with this for the past couple of days & finally had time to dig into it. Gbox Q2 here. Reverted back to 1.1.7, REALLY thinking this has to do with the UI switch. Would be nice if they made a classic UI version...
  • I noticed using OOKLA speedtest I am only getting about half my Mbps speed versus what I was.
  • On very 1.17
  • Posts: 2
    Ive got a stock non rooted  M8S+ and have the same problem.  All was working fine till about 5 days ago. I've had to revert to using NordVPN which has been much more reliable of late.  
  • Posts: 1
    Same problems as above, tries loading for 1/2 second then crashes.  has worked fine for 6 months.  started crashing after last update.  uninstalled, reinstalled, all to no avail.  going back to 1.17
  • Same problem here - this is a total PIA!
    Will definitely not renew my annual subscription if the app will no longer support my Minix settop box.
Sign In or Register to comment.