VPN Not working with MAC OS sierra, it is a little more complicated then that.

Hey girls and guys,

 

I just updated to the beta OS that mac put out. I am running the new macbook pro 13 inch with retina and the I5 Haswell, 8 gb of ram. I think that is all of the useless tech specs. Before updating my vpn worked great using the interface giving to us by pia. However after updating to the beta nothing will load on Firefox or saferia.  The odd thing is that it works fine in chrome (I really hate google in terms of privacy). I tried all of the normal trouble shooting idea like uninstalling and reinstalling using the terminal command to remove extra things as pia says to do. I also notice that my 1800 $ mac was lacking way too much to justify that price tag as there was  a tone of stuff running in the back ground after the update. I decided to wipe the mac and just start over with the old OS. Well after reinstalling the operating system which is still the beta as there was no option to not install the beta, pia is still only working with google chrome. I am also not able to download anything from the internet with pia on. What is happening and how do I fix it?

 

Best regards,

 the college student who use public wifi a lot.

Comments

  • Posts: 124

    Hi danob50,

    The issue you've described is normally caused by the DNS or Port being restricted (In most cases it would be a DNS issue).

    To resolve this issue please contact our support team at helpdesk@privateinternetaccess.com . There, they will be able to assist you in assigning your DNS servers and/or changing the port your VPN connects through.

    Thanks,
    PIA

  • I'm having EXACTLY the same issue -- works with Chrome but not Safari or any OS-level networking request (such as verifying an Apple ID). 


    but it did not change anything. They don't support beta products.  Anybody else found a solution?
  • I just updated to beta 5. The new v62 VPN PIA. Connected and still didn't work. 

    I disconnected and changed from UDP to TCP and changed the port. Before I connected. I manually added in the PIA DNS into the NETWORK settings, I connected and I have access through Safari. I tried this in Beta 1 and 2 and it didn't work. Not sure why it does now.. Maybe because I switched to TCP? 
  • Any plans on getting the DNS issue fixed?
  • hi there,

    I disagree with Blue23. No support can help.
    Used 120mn with chat support without solving the issue (changed DNS, changed server, changed port...).
    The only solution is to require your registration freeze til they update.
    that's what purevpn offered me.

  • Posts: 122
    Hi everyone,

    I'm very sorry for the issues here. We'll be having a release very soon that addresses this. However, for now if you set the DNS servers on your machine, the app should start working successfully (as it has in natewsmith's case).

    We've got some instructions on setting the DNS servers on your machine on our knowledge base here. The best thing to do would be to try those instructions and whether they resolve this issue.
  • Hi,

    I guess you are lucky it's working on something. For me, the VPN is just not working, with it, I can't connect anywhere. 

    Rgds,

    Phil
  • The above temporary fix does work for me, but now I'm seeing PIA frequently show up as the top "Apps Using Significant Energy".

    See below screenshot.


    PIA team, you had months to get this ready. 
  • Well Dang, 
    No matter what setting I use, PIA won't connect at all !! Really?? This isn't ready for Sierra?? I " payed" for this app, I shouldn't have to adjust nothing let alone go thru all this to get on the internet. Please PIA, get your act together and get this fixed. Post Haste !!


    Dave

  • Well finally it worked. I followed the dns re-install at this link.


    Make sure to re-apply the settings, then hopefully that works for most people.

    I still make the point, this should never happen. Great app, so it should work no matter which OS I use. This is why I pay for the app/service. 

    Cheers
  • Shades of El Capitan. PIA V64 will not install on my Sierra partition.
    As usual support try to tell me it's my machine/software/setup.
    V64 installed perfectly fine under El Capitan, even though the speed has, over time, degenerated from 150 mbps to 70 mbps (if I am lucky)
    It really is getting a bit old that PIA cannot keep up with updating OS's they have been told about for months.
    Having recently renewed my subscription does not help the frustration.
    I have contacted NordVPN for a free trial, maybe they can do better.
  • All the "fixes" suggested above are like going to a fine dining restaurant and being told here is your meal but you will have to supply your own plate and peel the potatoes.
    Oh! by the way here's the bill!
    Enjoy
  • klp51d said:
    All the "fixes" suggested above are like going to a fine dining restaurant and being told here is your meal but you will have to supply your own plate and peel the potatoes.
    Oh! by the way here's the bill!
    Enjoy
    Nailed it.
  • I have managed to get PIA to install on my Sierra partition.
    It's the fine dining example but it worked, only took 2.5 hours!
    I went into the Sierra partition /Applications/Utilities  and opened "Migration Assistant.app
    It transferred, with everything else, the working PIA on El Capitan partition to the Sierra Partition. 
    Then I upgraded to V65, even though V65 was on the El Capitan partition it transferred V64...go figure.
    Still not happy with PIA attitude but what the hell

Sign In or Register to comment.