No tray icon with i3

edited September 2016 in Linux VPN Setup Posts: 1
Hello, I'm having a problem with the PIA app on a debian machine. I'm using i3 as my window manager, and when running ./pia.sh the tray icon doesn't appear, which means I can't connect at all. Is there any library/package it relies on that I should install? I never had this problem with either Gnome or Cinnamon, so I guess there's something missing that prevents the tray icon from being displayed.

Edit: I noticed that the installation script ran the following command:

apt-get install -y libxss1 libappindicator1

Could a dev maybe tell me if this is related to the tray icon?

Edit 2: Well, I fixed it after discovering that pia.sh was in fact not working because of missing shared objects, so I had to install libnss3 and libgconf-2-4. I'd still like to know why they weren't automatically installed at first if the programs depends on them...

At least that explains why it worked when I installed the gnome package since both are installed as dependencies.
Post edited by RealityCheck on

Comments

  • I am also using i3wm.  The only way I can solve this is by running the install script again.  The only version for me is pia-v73-installer-linux.  Later versions did not work with i3 for me at least.

    I can't figure out how to start via command line without running the installer again.
Sign In or Register to comment.