Enabling PIA VPN disconnects wifi

Products used:
iOS 10
PIA VPN app 2.0 for iOS
iPhone 7
iPad Air


Title pretty much says it all. I turn on The PIA app and it kicks wifi off. The device will not connect to the internet as long as the app says "connecting". When kicked off, the device will say it is now connected to cellular data (LTE), the PIA app will continue to attempt to connect, but internet is still inaccessible as long as the PIA app is doing so. Turning the app selector to "off", the wifi will reconnect and the device will have internet access.

Both devices are VPN capable. I have OpenVPN on the same devices set to use my personal VPN and it connects correctly, no connection issues. Downloading specific PIA OpenVPN configurations files from /pages/openvpn-ios into OpenVPN and connecting to PIA servers through OpenVPN works fine.

The problem is the PIA app. OpenVPN works fine on both devices. PIA app works on neither.

Any suggestions?

Comments

  • KatKat
    Posts: 43

    Hello, 

    For this issue we would encourage you to please send us an email ticket directly to helpdesk@privateinternetaccess.com so our technical team can help you as soon as possible.

    Cheers,
    PIA

  • I have the same problem. It's been driving me crazy and I just figured out it was PIA.
  • Same problem... 


    Issue is with the PIA VPN app on my iPhone 6s on a public WiFi network in Florida with current region settings on automatic.

    Connecting to PIA VPN with my MacBook Pro Retina laptop works fine on this public WiFi network.



    Scenario 1 - PIA VPN app: 


    1. I'm connected to a public WiFi network with PIA VPN disabled.

    2. I open PIA VPN and hit the soft switch to the "ON" position to attempt to enable my PIA VPN connection (current region settings are on automatic). 

    3. I am immediately disconnected from WiFi and switched over to cellular LTE data while PIA VPN attempts to connect "connecting..." 

    4. PIA VPN never connects.

    5. I hit the soft switch back to "OFF" and I am successfully reconnected to the WiFi network again but without PIA VPN enabled. 


    Scenario 2 iPhone Settings - Connect On Demand enabled:


    1. I'm connected to a public WiFi network with PIA VPN disabled.

    2. I open iPhone Settings > VPN > PERSONAL VPN > Private Internet Access PIA VPN Info icon > hit the "Connect on Demand" soft switch to attempt to enable my PIA VPN connection (current region settings are on automatic). 

    3. I am immediately disconnected from WiFi and switched over to cellular LTE data while PIA VPN attempts to connect "connecting..." 

    4. PIA VPN never connects.

    5. I hit the "Connect on Demand" soft switch back to "OFF" and I am successfully reconnected to the WiFi network again but without PIA VPN enabled.


    Scenario 3 - iPhone Settings - Connect On Demand disabled:


    1. I'm connected to a public WiFi network with PIA VPN disabled.

    2. I open iPhone Settings > VPN > PERSONAL VPN > and hit the soft switch next to Status Not Connected to attempt to enable my PIA VPN connection (current region settings are on automatic). 

    3. The "loading" animated icon appears next to my "connected to WiFi" icon in the upper left of my iPhone screen. It spins for about 30 seconds. I am NOT disconnected from WiFi.

    4. Error dialogue box pops up that reads "VPN Connection The VPN server did not respond"

    5. I hit the OK button on the dialogue box and I am successfully reconnected to the WiFi network again but without PIA VPN enabled.



    I have written an email to PIA for support.


  • Posts: 1
    I have the same problem - there is a particular WiFi network I am unable to use iPhone PIA VPN App with. My MacBook PIA VPN app works Ok while connected to this WiFi network. Is there anything I can check there?
  • Posts: 1
    I am also having the same problem, purchased pia 3 days ago, and the first day it worked fine. Then it constantly disconnects my wifi en won't connect over 4G. What is the solution to this problem? I have reset network connections, removed and reinstalled the app, ...
  • Anyone find a fix for this? Seems it’s still happening a year later
  • Hello, issues like this can be cause by the DNS servers being blocked or restricted here is a guide on how to change the DNS server settings on your devices: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219460357-How-to-change-DNS-settings-in-iOS-Wifi-only-

    If you are still having this issue then I would suggest that you use Openvpn as this should address your wifi from not connecting: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/218985608-Installing-OpenVPN-PIA-on-iOS 
Sign In or Register to comment.