Slow (1 MB/s) download speeds with PIA Socks5 proxy on all torrents

I'm using the PIA Socks5 proxy to torrent. Even on torrents with tons of peers, like the Ubuntu 15.10 torrent, I only get about 1 MB/s download speeds in Deluge. When I disable the proxy I get great speeds (10 MB/s, my full internet speed.)

I've tried changing the encryption settings, using direct proxy IPs from nslookup instead of the hostname, and messing with bandwidth settings, all with no luck. Then I reset my Deluge config to make sure I hadn't broken something, still no luck.

What can I do to speed up my torrents on the Socks5 proxy? Is the Socks5 proxy just very slow, and there's nothing I can do about it?

Comments

  • This may solve your issue depending on who your ISP is.

    I'm a long time networking professional. I'm retired now. My ISP is Comcast. Problem: Torrent software stalls when using VPN. Testing: Tested every possible related setting from the VPN client to the router settings, including using a second router behind the Comcast router. It appears Comcast has third party organizations blocking torrent traffic to their routers (plausible deniability). I've traced this back to several different companies. SOLUTION: Purchase an inexpensive third party router, make sure it has at least 5G WiFi, plug it into port 1 of the Comcast router, and set the Comcast router to Bridge Mode. This takes the Comcast router out of the loop and everything works fine. Make sure to set the second router to the PIA DNS servers.
  • I am using Comcast as well @rockcop7. I have managed to increase my speeds to about 3-3.5 MB/s by using the VPN over TCP. With UDP, I only managed to get 1 MB/s on a good day, which is strange because everything I read says UDP is faster than TCP.

    Still, works for me and I'm happier with 3-3.5 MB/s, although I wish PIA would add more proxy servers, ideally some US ones.
  • I found a solution to my issues. Disabling uTP (or Bandwidth Management) completely resolved my speed issues and I'm getting 10 MB/s now. 

    To do this in Deluge, you can install the ltConfig plugin and disable the settings for uTP.
  • Downloaded and installed ItConfig ...cannot find the option to disable uTP however????
  • Posts: 1
    Downloaded and installed ItConfig ...cannot find the option to disable uTP however????
    While the ltConfig plugin says it works via web and GTK interfaces I found that only to be true if connecting to localhost and not outside the machine.

    Once you see the options though I would suggest scoping this page out for all your config needs: http://www.rasterbar.com/products/libtorrent/manual.html#session-customization

    However the options you're specifically looking for are 

    enable_outgoing_utp
    enable_incoming_utp
    
    Turn those off and you'll be good to go!
Sign In or Register to comment.