ANYONE HAVING TORRENT SLOWDOWNS PLEASE READ THIS!!

Hi guys,

so for months and months ive been experiencing HUGE torrent slowdowns while using PIA VPN.

I have virgin media 100mb fibre at home and usually without PIA VPN i get download speeds of between 9.0MB/s and 11.5MB/s which is what I would expect.

HOWEVER

with PIA VPN enabled i usually struggle to reach 1.5MB/s. After ripping my hair out for months and a lot of communication with PIA customer support (who to be fair to them have done the best they could),,,

SUCCESS, IM NOW DOWNLOADING TORRENTS AT 10MB/s through PIA VPN!!!

I came across the solution randomly today while reading a forum post about how to get a torguard socks5 proxy working...

SOLUTION:

1) make sure you are disconnected from the PIA VPN
2) go into utorrent and go to: Options ---> Preferences
3) click on "Bandwidth" on the left hand side and find a checkbox that says " Apply rate limit to uTP connections" and UNCHECK IT
4) now click on "Bittorrent" on the left hand side and find another checkbox that says "Enable bandwidth mangemnet (uTP)" and UNCHECK THAT TOO
5) reconnect to a port forwarding server and sort out port forwarding in utorrent.
6) start downloading a torrent and hopefully it will go to your full line speed

I dont know if this will work for anyone else but it was the ONLY thing after months of investigation that worked for me so please let me know in a comment if it works

Comments

  • Oh my God I have no idea why but it worked perfectly !

    I was unable to download anything with utorrent since I started using PIA VPN a week ago, and I had been trying for hours to solve the issue, but since I did what you wrote it works like it's supposed to !

    I wasn't using a proxy, I just started PIA Manager then utorrent (with the port forwarding rightly configured), and nothing would download.

    But now I am downloading just fine, thanks to those two checkboxes I have unchecked.

    I am so happy to have finally found a solution that I created an user account just to confirm to anyone needing it that your solution does indeed work !

    I don't get the technicality, but it works :)
  • Thank you so much for posting this!
    I had the same problem that frustrated me, and eventually moved on to another BitTorrent client.

    The solution you posted make sense. uTorrent is erroneously treating PIA as a metered Internet connection, hence slows your entire connection down.
  • So that is why I had almost no internet connection when I was running both PIA and utorrent.
  • Legend.  This should be linked on the PIA home page, been having issues since the last update and this fixed all the problems. Thanks for the post mate.
  • Posts: 3
    To do this in qBittorrent go to Tools > Options > Speed > Uncheck "Enable uTP protocol".

    Thanks for the great post!
  • Thanks for sharing, i will definitely check it out.
  • What does step 5 mean?
    I was able to get uTorrent to work without using the PIA client.
    After I renewed a couple of months ago uTorrent just sits on DHT waiting to log in.
  • edited December 2016 Posts: 102
    What does step 5 mean?
    I was able to get uTorrent to work without using the PIA client.
    After I renewed a couple of months ago uTorrent just sits on DHT waiting to log in.

    Follow the link and it will explain to you step 5 and how to set it up with the pia client.




    Post edited by itsmefloraluca on
  • Posts: 1
    cheers for this, top man!
  • Posts: 5
    Thanks for sharing p0123409!

    For anyone using Deluge, get the ItConfig plugin and enable it. Then in Preferences > ItConfig:
    - check Apply settings on startup
    - check enable_incoming_utp and remove the checkmark from the Setting column
    - check enable_outgoing_utp and remove the checkmark from the Setting column

    Click OK. Restart Deluge (and the daemon if you're using it).

    Restarting might not be necessary, but in my case the download speed didn't seem to change without restarting.

    There's also a setting called rate_limit_utp, but only disabling this didn't have any effect when I tested it. Also, I couldn't find any setting related to bandwidth management and utp. So just disabling utp as described above seems the only way to go. Works like a charm though!
  • Posts: 1
    p0123409 said:


    SOLUTION:

    1) make sure you are disconnected from the PIA VPN
    2) go into utorrent and go to: Options ---> Preferences
    3) click on "Bandwidth" on the left hand side and find a checkbox that says " Apply rate limit to uTP connections" and UNCHECK IT
    4) now click on "Bittorrent" on the left hand side and find another checkbox that says "Enable bandwidth mangemnet (uTP)" and UNCHECK THAT TOO
    5) reconnect to a port forwarding server and sort out port forwarding in utorrent.
    6) start downloading a torrent and hopefully it will go to your full line speed

    I dont know if this will work for anyone else but it was the ONLY thing after months of investigation that worked for me so please let me know in a comment if it works
    Much appreciate the info, I started having the same problem but it just started happening one day with no settings changed and before was downloading fine. I even downloaded an older version of utorrent from suggestions. 

    **Just a note - You don't have to disconnect from PIA to change these settings in utorrent, It will also leave you vulnerable if you are currently downloading and uploading. I was able to make changes without disconnecting and it fixed the problem. I was searching for this problem on google for about 3 days. The check box under Bandwidth on "apply rate limit to uTP was already "unchecked" but when I unchecked "enable bandwidth management" it worked. 

    Thanks again!
  • Im Having the same dramas and just worried that if I turn the vpn off. Won't that keep me visible or do you turn it back on before the download?
  • Posts: 15
    Mushroom said:
    Thanks for sharing p0123409!

    For anyone using Deluge, get the ItConfig plugin and enable it. Then in Preferences > ItConfig:
    - check Apply settings on startup
    - check enable_incoming_utp and remove the checkmark from the Setting column
    - check enable_outgoing_utp and remove the checkmark from the Setting column

    Click OK. Restart Deluge (and the daemon if you're using it).

    Restarting might not be necessary, but in my case the download speed didn't seem to change without restarting.

    There's also a setting called rate_limit_utp, but only disabling this didn't have any effect when I tested it. Also, I couldn't find any setting related to bandwidth management and utp. So just disabling utp as described above seems the only way to go. Works like a charm though!
    You are awesome. I was wondering why my connection was so poor. To anyone that needs to download ltconfig go here: http://forum.deluge-torrent.org/viewtopic.php?f=9&t=42887
  • Thank You so much!!!! I signed up to the forums just to tell you thank you!!! also, this advice/forum worked with Bit Torrent!!! THANK YOU SO MUCH!!!!

  • Posts: 157
    itconfig doesnt work with Deluge on LinuxMint 17.3 (with updates). Guessing that pyhon versions dont match.
  • Posts: 1
    Thank you so f...ing much !!!
  • Glad to know it worked for everyone!

    makes me feel like the couple of months research i did to find this out was worth it!
  • p1349392 said:
    Thank You so much!!!! I signed up to the forums just to tell you thank you!!! also, this advice/forum worked with Bit Torrent!!! THANK YOU SO MUCH!!!!

    You seem happy? haha glad it worked for you
  • Im Having the same dramas and just worried that if I turn the vpn off. Won't that keep me visible or do you turn it back on before the download?
    Hi, sorry for the delay in getting back to you, 

    follow all the steps i listed but yes then reconnect to the PIA VPN before you download a torrent
  • Posts: 522
    Mushroom said:
    Thanks for sharing p0123409!

    For anyone using Deluge, get the ItConfig plugin and enable it. Then in Preferences > ItConfig:
    - check Apply settings on startup
    - check enable_incoming_utp and remove the checkmark from the Setting column
    - check enable_outgoing_utp and remove the checkmark from the Setting column

    Click OK. Restart Deluge (and the daemon if you're using it).

    Restarting might not be necessary, but in my case the download speed didn't seem to change without restarting.

    There's also a setting called rate_limit_utp, but only disabling this didn't have any effect when I tested it. Also, I couldn't find any setting related to bandwidth management and utp. So just disabling utp as described above seems the only way to go. Works like a charm though!
    Thanks Mushroom for the recommendation. Unfortunately it not only doesn't help speed up downloads with Deluge 1.3.13 on Mac OSX Sierra, enabling ltconfig at all will prevent Deluge from seeing any peers at all. It also makes it very unstable (had to force quit twice). It's very possible, however, that ltconfig will work fine with previous OSX versions and turn Deluge into a speedy beast over VPN.

    One valuable thing I learned from this exercise is that uTP doesn't play well with PIA, at least in its current iteration (I don't recall having these incredibly slow downloads in the past). The slowdown has nothing to do with the PIA app either, since I avoid it whenever possible. Much experience has taught me that the PIA app is garbage and over time has only gotten worse. So I use Viscosity instead (OpenVPN app).

    Using a bittorrent app that permits disabling uTP is absolutely essential to speedy downloads with PIA. Because of a lack of configurability I've had to cross several bittorrent apps off my list including Transmission, XTorrent and Deluge. Having great success however with QTorrent (Options / Speed / uncheck "Enable uTP protocol").
  • Posts: 6
    po123409  You are bloody brilliant!  I got a virus end of December and when it was fixed the version of utorrent I always use was gone.  Totally continuously kicked me off the net after I set it back up.  Windows 7 kept leading me to believe it was router so exchanged that.  Then found teeth marks from cat on coaxial cable so fixed that.  Windows kept telling me next was wireless adapter which it would fix, lasting about 2 minutes. Then found out wireless adapter in Aspire laptops are horribly cheap and many quit working so got an external wifi adapter that you plug into usb port. Still 10 kb speed and disconnecting from net.  PIA had worked fine since April 2016 but finally suspected that and sure enough when I turned it off, uTorrent worked great with speeds up to 5MB.  So then PIA advice was play musical change udp or tcp and try all the different numbers.  It would literally take me 4 days to dl a 342 MB show. Got another complaint from Spectrum.  I have left out most of ordeal, believe it or not.  I cannot thank you enough.  Had mini stroke a month ago and you have probably saved me from having another.  Many blessings on you and your family.
  • Posts: 1
    Simply unchecking those two boxes quadrupled my speeds on Utorrent. Cheers for the tip :]
  • Posts: 157
    Using qbittorrent - followed advice and disabled uTP in OPTIONS - the Connections icon went from Green to Orange. Dload speed went from around 200 to over 700 KiB/s this am Best speeds since Nov 2016 when everything slowed down dramatically.
  • Posts: 3
    Hi,

    After tearing my hair out for weeks I finally found this post in the forum and it looks like you have solved all my problems. My computer had slowed to a crawl using PIA and I was close to ditching it altogether as I couldn't cope with the slow speeds on my VM bb and with my computer becoming unresponsive. Changed the settings you mentioned and everything is back to normal and I have good speeds. Thank you :D

  • Posts: 1
    avow said:
    To do this in qBittorrent go to Tools > Options > Speed > Uncheck "Enable uTP protocol".

    Thanks for the great post!
    THIS!!!

    I created an account just to post this.Oh man, I have been struggling w/ qBittorrent + PIA VPN + PIA SOCKS5 proxy for months. As soon as I read this little statement of yours and made the setting change, qBT maxed out my connection within seconds! Almost all of my downloads ended within 5 minutes, where before I was looking at another 5-10 hours. I immediately created an account on this board to post this.

    Thank you so much!



  • I dont know if this will work for anyone else but it was the ONLY thing after months of investigation that worked for me so please let me know in a comment if it works
    Thanks, This is helpful.


Sign In or Register to comment.