PIA on Ubuntu 17.04

I've been using the native PIA software for a while on Ubuntu. Yesterday I did a clean install of Ubuntu 17.04 and PIA was installed without any problem, but it doesn't connect. It keeps on "connecting". Let's see if someone knows which the problem is.

Comments

  • Posts: 269
    How can anyone help you?
    1. tried to connect to more than one server or not?
    2. include log information without which there is no reading your mind nor divining what your system is doing.
  • Posts: 2
    martouf said:
    How can anyone help you?
    1. tried to connect to more than one server or not?
    2. include log information without which there is no reading your mind nor divining what your system is doing.
    1. Yes, I tried more than one server.

    2. Where can I find the log information?

    My first thought was that since Ubuntu 17.04 was release just some days ago, maybe the software is not compatible with it.
  • Posts: 269
    okay, then. you've tried more than one server. good. OpenVPN software is an add-on that has been working with whatever Ubuntu release is available to the public for years. Your issue is very very unlikely to be due to 'incompatibility'.

    if you haven't already, get the collection of PIA-prepared configuration files. Unzip them in a convenient directory.

    quick way to test and generate some log information is to be sure you have normal (no VPN) network connectivity, then open a terminal and issue the command:
       sudo openvpn --config /path/to/convenient/directory/LocationNameOfServer.ovpn --verb 3
    (you will need to choose one of the ovpn files from the unzipped collection)

    you will be prompted for your PIA username and password. Log information will be generated. You can paste it at pastebin.com and then post the link here.

  • Posts: 2
    I had success using this:
    https://www.privateinternetaccess.com/pages/client-support/ubuntu-openvpn
    Actually, that was after trying following this:
    https://askubuntu.com/questions/534717/installing-privateinternetaccess-on-ubuntu-14-04-lts
    (my normal install routine)
    and then this:
    https://www.privateinternetaccess.com/installer/download_installer_linux
    so I'm not sure exactly what combo of everything works.  Next time I'd try the 1st link and then follow up with the rest.
    Sorry for not having an exact solution but with a little fiddling you can probably get it to work...
  • Posts: 170
    This is not the only problem with 17.04 ( Xubuntu, Ubuntu Mate,AntiX 16.04 etc) - seeems to be some sort of Networking problem. While I can get FreeNX remote desktop to work fine, Gigolo remote file access and Pia have problems, so its not my network/modem-Router at fault.
  • Posts: 269
    Ubuntu 17.04 users who want to manually test/troubleshoot using PIA-prepared ovpn files must use the command
        sudo openvpn --config /path/to/convenient/directory/LocationNameOfServer.ovpn --script-security 2 --up /etc/openvpn/update-resolv-conf --down /etc/openvpn/update-resolv-conf --verb 3

    Without the additional parameters, the resolv.conf file won't be updated when the VPN is brought up or taken down.
  • edited April 22 Posts: 2
    [04/21/17 22:01:29] status: stopped
    [04/21/17 22:01:29] connection_status: down
    [04/21/17 22:01:29] flushed_dns
    [04/21/17 22:01:29] error loading ipv6leak state: No such file or directory - /home/test/.pia_manager/data/ipv6leak.json

    [04/21/17 22:01:29] #<Errno::ENOENT: No such file or directory - /home/test/.pia_manager/log/pia_nw.log>
    /home/test/.pia_manager/pia_manager/pia_manager.rb:521:in `initialize'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:521:in `open'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:521:in `block (2 levels) in resize_logs'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:520:in `each'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:520:in `block in resize_logs'
    <internal:prelude>:10:in `synchronize'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:513:in `resize_logs'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:154:in `run'
    /home/test/.pia_manager/pia_manager/run.rb:70:in `<encoded>'
    /home/test/.pia_manager/pia_manager/run.rb:2:in `RGLoader_load'
    /home/test/.pia_manager/pia_manager/run.rb:2:in `<main>'
    [04/21/17 22:01:29] starting pia_manager
    [04/21/17 22:01:29] #<Errno::ECONNREFUSED: Connection refused - connect(2)>
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `initialize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `open'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `block (2 levels) in cmd'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1213:in `block in cmd'
    <internal:prelude>:10:in `synchronize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1210:in `cmd'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1174:in `block (2 levels) in wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `loop'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `block in wait_management'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1171:in `wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:42:in `block (3 levels) in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:190:in `ipv6leak_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:41:in `block (2 levels) in resume_from_old_state'
    [04/21/17 22:01:30] #<Errno::ECONNREFUSED: Connection refused - connect(2)>
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `initialize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `open'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `block (2 levels) in cmd'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1213:in `block in cmd'
    <internal:prelude>:10:in `synchronize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1210:in `cmd'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1174:in `block (2 levels) in wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `loop'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `block in wait_management'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1171:in `wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:42:in `block (3 levels) in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:190:in `ipv6leak_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:41:in `block (2 levels) in resume_from_old_state'
    [04/21/17 22:01:30] #<Errno::ECONNREFUSED: Connection refused - connect(2)>
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `initialize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `open'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `block (2 levels) in cmd'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1213:in `block in cmd'
    <internal:prelude>:10:in `synchronize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1210:in `cmd'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1174:in `block (2 levels) in wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `loop'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `block in wait_management'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1171:in `wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:42:in `block (3 levels) in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:190:in `ipv6leak_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:41:in `block (2 levels) in resume_from_old_state'
    [04/21/17 22:01:30] #<Errno::ECONNREFUSED: Connection refused - connect(2)>
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `initialize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `open'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1214:in `block (2 levels) in cmd'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1213:in `block in cmd'
    <internal:prelude>:10:in `synchronize'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1210:in `cmd'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1174:in `block (2 levels) in wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `loop'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1172:in `block in wait_management'
    /home/test/.pia_manager/pia_manager/pia_common.rb:291:in `timeout'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:1171:in `wait_management'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:42:in `block (3 levels) in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:190:in `ipv6leak_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:41:in `block (2 levels) in resume_from_old_state'
    [04/21/17 22:01:30] hardkill
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:42:in `block (3 levels) in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:190:in `ipv6leak_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:41:in `block (2 levels) in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:251:in `dnsleak_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:40:in `block in resume_from_old_state'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:412:in `killswitch_ignore_disconnect'
    /home/test/.pia_manager/pia_manager/openvpn_manager.rb:39:in `resume_from_old_state'
    /home/test/.pia_manager/pia_manager/pia_manager.rb:160:in `run'
    /home/test/.pia_manager/pia_manager/run.rb:70:in `<encoded>'
    /home/test/.pia_manager/pia_manager/run.rb:2:in `RGLoader_load'
    /home/test/.pia_manager/pia_manager/run.rb:2:in `<main>'
    [04/21/17 22:01:30] [down] Going down
    [04/21/17 22:01:30] status: stopped
    [04/21/17 22:01:30] [down] updated status
    [04/21/17 22:01:30] [down] stopped polling
    [04/21/17 22:01:30] [down] port forward loop down (if enabled)
    [04/21/17 22:01:30] [down] cleared pid
    [04/21/17 22:01:30] [down] dns restored (if enabled)
    [04/21/17 22:01:30] [down] killswitch down (if enabled)
    [04/21/17 22:01:30] [down] dnsleak down (if enabled)
    [04/21/17 22:01:30] [down] DOWN finished successfully
    [04/21/17 22:01:30] cleaning up dnsleak
    [04/21/17 22:01:30] getting region data
    [04/21/17 22:01:31] Starting pia tray
    [04/21/17 22:01:31] The tray path is 
    [04/21/17 22:01:31] Starting command server thread
    [04/21/17 22:01:31] Server started
    [04/21/17 22:01:31] /home/test/.pia_manager/pia_tray_bin/nw-linux-64/pia_nw
    [04/21/17 22:01:31] Starting pia tray
    [04/21/17 22:01:31] "/home/test/.pia_manager/pia_tray_bin/nw-linux-64/pia_nw" "/home/test/.pia_manager/pia_tray_files/" 
    [04/21/17 22:01:31] started pia_manager
    [04/21/17 22:01:31] checking latency
    [04/21/17 22:01:32] Starting status server thread
    [04/21/17 22:01:32] status server started
    [04/21/17 22:02:01] [ERROR] Did not get heartbeat
    [04/21/17 22:02:32] checking latency

    Post edited by aghorler on
  • Posts: 9
    joangg said:
    I've been using the native PIA software for a while on Ubuntu. Yesterday I did a clean install of Ubuntu 17.04 and PIA was installed without any problem, but it doesn't connect. It keeps on "connecting". Let's see if someone knows which the problem is.
    I have the same issue as the OP (above, quoted).   I also see 'connecting' and the red app/icon is there but the icon just turns grey.   I can select servers in the network (manager) settings under 'Wired' - is this a new configuration procedure now?   I also have Ubuntu 16.04 and it's not like this at all.   It works with the PIA app and the red app/icon turns green when it connects.   There's nothing listed under 'Wired' too but I noticed someone posted instructions for installing/configuring in Fedora and they showed the servers under 'Wired' and didn't mention anything about the PIA app.   Thus, I am confused. 

    I guess it will work for me in 17.04 but I have to go to the Network settings and I don't think PIA meant for the app to do what it does in my case.  To clarify, it only happens with my 17.04 install - and I am unsure why.   I followed the most recent instructions I could find - on PIA site and followed as many posts that confirmed this procedure.   VPN works for me, in general, also, in Ubuntu 17.04.   I'm using the Gnome edition.    
  • edited April 23 Posts: 1
    Here is your answer. I encountered the same thing on Linux Mint 17.3 and found this solution. MUCH THANKS to the original poster.

    NOTE: You only have to follow the first section to get it working, ie move the directory. Here is how... From a Terminal type the following, changing "your_username" to your username, obviously enough.

    cd /
    sudo mkdir pia
    sudo chown root:root pia
    sudo mv /home/your_username/.pia_manager /pia/.pia_manager
    ln -s /pia/.pia_manager /home/your_username/.pia_manager

    https://www.privateinternetaccess.com/forum/discussion/22098/guide-pia-client-installation-on-ubuntu-system-with-encrypted-home-folder-ecryptfs#latest

    JoeyK

    Post edited by JoeyK on
  • Posts: 9
    Whatever you do, don't use this:

    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/227831828-Installing-the-PIA-app-on-Linux-with-encrypted-home-directories

    It doesn't work.   The /opt/ is a regular directory (?) and not in the root partition / directory.   Not sure what I'm talking about, I guess.   Anyway, all messed up now.   I would try Joey's solution - I think I understand it sufficiently but don't know how to try it now...since I don't comprehend 100% - I understand that you need the root privileges and because of the encryption...

    Nevermind... :-(

  • Posts: 9
    JoeyK said:
    Here is your answer. I encountered the same thing on Linux Mint 17.3 and found this solution. MUCH THANKS to the original poster.

    NOTE: You only have to follow the first section to get it working, ie move the directory. Here is how... From a Terminal type the following, changing "your_username" to your username, obviously enough.

    cd /
    sudo mkdir pia
    sudo chown root:root pia
    sudo mv /home/your_username/.pia_manager /pia/.pia_manager
    ln -s /pia/.pia_manager /home/your_username/.pia_manager

    https://www.privateinternetaccess.com/forum/discussion/22098/guide-pia-client-installation-on-ubuntu-system-with-encrypted-home-folder-ecryptfs#latest

    JoeyK

    I tried the above.   Didn't work... I read of similar steps and I tried another one prior and it didn't work either.   I guess you might have visited these pages?:
    https://askubuntu.com/questions/818694/pia-client-installation-on-ubuntu-system-with-encrypted-home-folder-ecryptfs

    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/227831828-Installing-the-PIA-app-on-Linux-with-encrypted-home-directories

    I tried the 2nd one down but nothing worked.   I then removed all the PIA config files.... using these commands here:
    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/232054147-How-can-I-uninstall-reinstall-your-application-on-Linux-

    and tried from scratch (i.e. again).   To no avail... I want to know what changed from the app working in Ubuntu 16.04 when I first tried (the procedure) to it not working at all in Ubuntu 17.04 and the changes I mentioned above.

    I just don't know enough to recognize what is going on and what the difference is (i.e. the change in the way the app gets configured).  



  • Posts: 170
    I have problems with Xubuntu 17.04 and Ubuntu Mate 17.04, Mint etc. network-manager-gnome wont allow entry of static ip. installed WICD and uninstalled network-manage-gnome - then static ip entry ok. Still wont allow access over network to other PCs using Gigolo or any other method, though I can ping other PC's ok. because of this, am still using Mint Mate 17.3 and MX Linux. seems to be a network/samba problem in latest Ubuntu and derivative distros.
  • Posts: 170
    PIA V69 installed fine over V66 on XUbuntu DEsktop 17.04 - followed instructions as per my post https://www.privateinternetaccess.com/forum/discussion/23792/linux-pia-v68-and-v69-plus-setup-howto-links-should-be-forum-sticky#latest
  • Posts: 2
    I'm on a clean install of Ubuntu Gnome 17.04 this morning. Installed the latest version of the PIA client (v69) but still running into this issue of the client failing to connect. I can run the pia-nm.sh script but running into the usual dns leak issue when initiating the vpn from Network Manager.
  • Posts: 269
    compare your network-manager configuration for the server you are using against the setup shown in
    https://www.privateinternetaccess.com/forum/discussion/comment/46741/#Comment_46741

  • Posts: 1
    Ubuntu no longer ships with ipconfig installed by default. The PIA connection software requires this to run.

    sudo apt-get install net-tools

    That installs ifconfig. Now try to connect.
  • Posts: 269
    oh, that's interesting. ifconfig was one of the first things I added to my Ubuntu 17.04 install. how else does one check on interface status and configuration in Terminal?  :-P  ifconfig or bust. ;-)

  • Posts: 3
    Ubuntu no longer ships with ipconfig installed by default. The PIA connection software requires this to run.

    sudo apt-get install net-tools

    That installs ifconfig. Now try to connect.
    Thanks!
    This works perfectly.

    Ubuntu 17.04 - Gnome
  • Posts: 9
    Good tip Zepalesque but my kill switch doesn't work, disconnected from the network and my connection reverts to my ISP it should shutdown all access to the internet, otherwise am able to get the VPN working after adding net-tools
  • Posts: 9
    Update to my previous post, found this on another discussion about the same problem we are having, they say to add this in a terminal window the following "nohup env XDG_CURRENT_DESKTOP=Unity ~/.pia_manager/pia_manager/run.sh &" and leave the terminal open don't close it.  Now the pia icon shows up and am able to connect/ disconnect as usual edit setting and the killswitch works.
  • Posts: 269
    just adding XDG_CURRENT_DESKTOP=Unity to run.sh will do the trick and without the extra shell process hanging around.

    can someone confirm what value the envar XDG_CURRENT_DESKTOP has before messing around with it?
    (in Terminal, type echo $XDG_CURRENT_DESKTOP and report what you see)
  • edited May 2 Posts: 1
    Edit : never mind
    Post edited by meeekael on
  • Posts: 1
    martouf, thank you for the excellent solution!!!  My variable was set to "Unity7" without quotes.  I have a 17.04 Desktop image that was upgraded from 16.10 Desktop installl.  Much appreciated!

    Andrew
  • edited June 17 Posts: 2
    I'm just summarising this thread for anyone experiencing issues with 17.04, and is just searching for the solution.

    1. Move pia_manager to /opt/. This is required if you have encrypted your home directory. It might not be required in other scenarios.

    sudo mv ~/.pia_manager /opt/pia_manager
    ln -s /opt/pia_manager ~/.pia_manager

    2. Install net-tools.

    sudo apt-get install net-tools

    3. Add XDG_CURRENT_DESKTOP=Unity to run.sh.

    gedit ~/.pia_manager/pia_manager/run.sh

    Your run.sh should look like this:

    #!/bin/sh

    XDG_CURRENT_DESKTOP=Unity

    if [ "$(uname -m)" = "x86_64" ]; then
      ARCH=64
    else
      ARCH=32
    fi
    DIR="$(dirname $0)"
    ARCHDIR="$DIR/$ARCH"
    LD_LIBRARY_PATH="$ARCHDIR" "$ARCHDIR/ruby" -I "$DIR" -I "$ARCHDIR" "$DIR/run.rb" "$@"

    4. Done! Maybe reboot.

    Post edited by aghorler on
  • Posts: 1
    martouf & aghorler,
      
    Thank you!
    I had upgraded Ubuntu 1610 to 17.04 and while the pia (v7.1) process worked, I had no menu icon to start/stop - and had to killl the related processes manually to stop the PIA service. By simply adding:
    XDG_CURRENT_DESKTOP=Unity to the run.sh script, it now works as it did. Thanks!

  • Posts: 269
    technically, the statement to put as the second line of run.sh is
      XDG_CURRENT_DESKTOP=${XDG_CURRENT_DESKTOP/:*/}

    this statement should continue to function on the day when the envar XDG_CURRENT_DESKTOP changes (again).
  • PhMPhM
    Posts: 2
    Hello
    Thank you for these indications.
    But for me, that is not enough. I still missed the library libgconf-2-4 as indicated by the post:

    With the steps mentioned above and this library it works!
  • Posts: 8
    I have noticed PIA updated their installer.
    The solution above worked for me with installer v. 72.
    With installer v.74, the workaround is no longer necessary for me, and PIA installs out of the box.
  • Posts: 269
    that's very good news
Sign In or Register to comment.