Ubuntu 17.04 tray icon missing after clean install

Clean install of Ubuntu Desktop 17.04 from iso. Red tray icon appeared in 16.10 and earlier but not now. Very annoying that I cannot control PIA. Very very annoying.

Followed these instructions
https://www.privateinternetaccess.com/installer/download_installer_linux
which worked in the past.

Did I mention that this is very, very very annoying?
Tagged:

Comments

  • edited April 25 Posts: 5
    Here's a temporary  solution:

    nohup env XDG_CURRENT_DESKTOP=Unity ~/.pia_manager/pia_manager/run.sh &

    (gotta keep the terminal session running)
    Post edited by grfiv on
  • Posts: 2
    Brilliant, I am hoping that being able to turn PIA on and off means I can now run Netflix in Firefox.  I will check back.  Thanks.
  • Posts: 10
    grfiv said:
    Here's a temporary  solution:

    nohup env XDG_CURRENT_DESKTOP=Unity ~/.pia_manager/pia_manager/run.sh &

    (gotta keep the terminal session running)
    This works for me, thank you.
  • Posts: 1
    grfiv said:
    Here's a temporary  solution:

    nohup env XDG_CURRENT_DESKTOP=Unity ~/.pia_manager/pia_manager/run.sh &

    (gotta keep the terminal session running)

    Thanks, this worked fine, I've just extended your solution and modified my ~/.pia_manager/pia_manager/run.sh 

    #!/bin/sh

    XDG_CURRENT_DESKTOP=Unity

    if [ "$(uname -m)" = "x86_64" ]; then
      ARCH=64
    else
      ARCH=32
    fi
    DIR="$(dirname $0)"
    ARCHDIR="$DIR/$ARCH"
    LD_LIBRARY_PATH="$ARCHDIR" "$ARCHDIR/ruby" -I "$DIR" -I "$ARCHDIR" "$DIR/run.rb" "$@"



  • Posts: 3
    htunlogic said:
    grfiv said:
    Here's a temporary  solution:

    nohup env XDG_CURRENT_DESKTOP=Unity ~/.pia_manager/pia_manager/run.sh &

    (gotta keep the terminal session running)

    Thanks, this worked fine, I've just extended your solution and modified my ~/.pia_manager/pia_manager/run.sh 

    #!/bin/sh

    XDG_CURRENT_DESKTOP=Unity

    if [ "$(uname -m)" = "x86_64" ]; then
      ARCH=64
    else
      ARCH=32
    fi
    DIR="$(dirname $0)"
    ARCHDIR="$DIR/$ARCH"
    LD_LIBRARY_PATH="$ARCHDIR" "$ARCHDIR/ruby" -I "$DIR" -I "$ARCHDIR" "$DIR/run.rb" "$@"



    This worked great adding "XDG_CURRENT_DESKTOP=Unity" to the run.sh. Now mine even shows where connected.
    Thanks
  • Posts: 2
    Again, brilliant.  Changing run.sh makes PIA work just as it did before 17.04 update. Thanks!
  • edited April 28 Posts: 295
    interesting.. the default envar in 17.04 is XDG_CURRENT_DESKTOP=Unity:Unity7

    perhaps what run.sh needs is to pick off the first element in the list so there would be no need to re-edit later if/when the desktop manager is changed. as in: XDG_CURRENT_DESKTOP=${XDG_CURRENT_DESKTOP/:*/}

    can anyone with 16.04 confirm the envar was not a list?


    Post edited by martouf on
  • Posts: 1
    Had the same problem on 17.04, the fix above works for me too.
    Can confirm that XDG_CURRENT_DESKTOP is defined as "Unity" on 16.04 too.
  • Posts: 1
    Finally!   A solution to the missing little green man.  

    Thanks.
  • Posts: 20
    I am on Ubuntu 16.04.
    I installed the client as described and, after installation it showed as expected in the tray.
    After reboot, it didn't show any more.
    If I try from a shell to launch the command which is supposed to be triggered at login, the I get:

    [Mon 03 Jul 11:47:58 ~]$ ./.pia_manager/pia_manager/run.sh --startup
    pia_nw: no process found

    BTW, I also have

    [Mon 03 Jul 11:47:41 ~]$ echo $XDG_CURRENT_DESKTOP
    Unity

    What is wrong with my system?


  • gk3gk3
    edited October 1 Posts: 1
    Can confirm that adding the line [ XDG_CURRENT_DESKTOP=Unity ] to the "~/.pia_manager/pia_manager/run.sh" file worked like a charm for me.  Now PIA is working great.  Thanks VERY much!

    BTW: Ubuntu 17.04 here 
    Post edited by gk3 on
  • Posts: 7
    Adding "XDG_CURRENT_DESKTOP=Unity" as described above to "~/.pia_manager/pia_manager/run.sh" also works in Ubuntu 17.10 with version 73 of the PIA application (I didn't test it with v72).

    (Even though Ubuntu is switching back to GNOME shell in 17.10, indicator applets are still enabled.)
Sign In or Register to comment.