iOS App Intermittently Stuck on "VPN IP Resolving..."

I've searched the forums and can't find this iOS issue.

I'm on iPhone 7 Plus 10.3.1 running the standard PIA iOS app. When it's working, it works just fine (testing via IPLeak at least). However, several times a day I lose internet connection. Upon investigating, I find the PIA app indicating "VPN IP Resolving...".

If I disconnect and reconnect, it's typically fine—cycles through to resolve an IP. But this "VPN IP Resolving..." issues happens over and over throughout the day. And it means I miss emails and notifications because I don't realize PIA has broken my connection.

I suppose I could manually set up the VPN profile, but I'd prefer to put my faith in PIA devs to fix their client (and so I can maintain MACE protection without a manual DNS adblocker configured).

Comments

  • Posts: 18
    @bobclampet  I'm experiencing the same issue. I'm not sure if it started happening since the latest update or when the IP issue has changed.. I started using OpenVPN app it too starts to auto-disconnect. I'm wondering if it's all because of the IP changes PIA's end..
  • Posts: 22
    Anyone else? It's possible it's related to PIA's IP work they're doing behind the scenes, but it's been a few weeks now of my phone getting stuck on "VPN IP resolving...". Even worse, sometimes I'm not able to disconnect—as in, it gets stuck on Disconnecting—and need to delete PIA's app along with the VPN configuration and restart my phone in order to get ANY internet connection again.

    I got stranded on the side of the road for half an hour yesterday because PIA effectively bricked my phone.
  • Posts: 1
    I am also having this issue. IPhone 7 Plus with latest iOS of 10.3.2 with latest PIA app. The internet connection FREQUENTLY will disconnect and say resolving. Only after I disconnect and reconnect manually does my connection resume. This is very annoying and happening much more frequently. Are the servers getting overburdened or is it an app problem? Is this being worked on or do we need to look at switching providers?
  • edited June 27 Posts: 22
    Update: heard back from PIA support after 2 weeks, finally. They're recommending just fresh installing the app, along with resetting network settings on the phone. If that doesn't work, they're pushing me to use an OpenVPN config separate from the official PIA app.
    Post edited by bobclampet on
  • Posts: 1
    Add me to the list of users experiencing this issue: several times a day, my Internet connection freezes and PIA app shows "VPN IP Resolving".  If I manually disconnect and reconnect, everything works fine again.  On other less common occasions, the app will show that I still have a valid IP address, but incoming traffic drops to 0 and stays there.  Again, if I disconnect and reconnect everything goes back to normal.  

    I have tried resetting my iPhone network settings, deleting and re-installing the PIA app, and connecting manually to different servers, but the issue persists. I'm using the latest version of the PIA iOS app on an iPhone 6.  Have submitted a trouble ticket and will update if I get any useful info or a solution.
  • edited July 26 Posts: 22
    Update:

    I heard back from PIA reps, who ultimately recommended that I go the OpenVPN route. I have it set up now, and the disconnections have noticeably decreased. Whereas on the iOS app I was having disconnections multiple times an hour, via OpenVPN connected to the same PIA servers (primarily Switzerland) I'm only having disconnections maybe once or twice a day.

    For now, it's an okay workaround. But it's imperfect in that there's no option via OpenVPN for either a) automatically reconnecting or b) PIA's MACE filter.

    PIA let me know they're working on a new version of the iOS app which should be out shortly. Hopefully that'll fix these ongoing problems
    Post edited by bobclampet on
  • I've had this issue since day one on both my iPhone 6 Plus & iPhone 7 Plus.  When it's connected it works great.  Then I open up ye old Facebook app and notice that every video in my news feed will autoplay for two seconds and then crap out.  If I tap on a post to view comments, it just sits there trying to load.  This is a sure sign that PIA VPN has disconnected and it trying to reconnect.  I open up the PIA app and there it sits, reconnecting.  My only option is to tap it to cancel the reconnect and then close the Facebook app so it can reconnect as well.  I'm just using Facebook as an example.  I gave up and just stopped using the PIA App.
  • edited September 20 Posts: 12
    I too have this problem and have had it for some time now, but ... only at work where we have a linksys router. At home (Asus router over which I have full control) no such issues affect my phone. My wife tells me she has the same issue at work, but only for the last few weeks, whereas I have had it since we installed the new router. Oh, we use an iPhone 6 and 6 plus.

    FYI: My MacBook Pro has no such problems at work. It connects to WiFi without a hitch and also runs PIA fine.
    Post edited by chadrick on
Sign In or Register to comment.