Can't get PIA VPN to turn on automatically on my android

I use a Huwaei Mate 8 phone. I can't get my PIA VPN to turn on automatically at boot, or when I turn on wifi. I have to manually select it to start running it. And if I exit all apps, it stops running and my wifi still runs fine (even though I've selected checkmark on kill switch).

Can someone help me here?

Comments

  • Posts: 2
    hey mate, try this..
    Go into android settings, connections, more, vpn
    click the cog wheel and enable always on.

    go back to your pia vpn and unclick connect on boot.

    seems to work for me.

    I am having issues with the kill switch though.
Sign In or Register to comment.