How to chat with other devices in your network

edited June 2017 in Off-topic Discussion Posts: 552
This might be a non issue to some, but like me, I had trouble being able to contact another device in my network while using VPN on my local machine. I though that the main reason was the encrypted channel. I later found out I was wrong and will explain.

My local machine is a HP-R136WM running Windows 8.1. I use the OpenVPN application to connect to PIA's servers. My laptop is connected Wifi to a Linksys WRT-160N with DD-WRT firmware build 14929. Connected to the router is a Cisco DPC3010 cable modem. From there it is off to the ISP and beyond.

While I am running the VPN on my laptop I could not talk to the modem to get current status. In order to do so I had to disconnect the VPN. Looking at my route table somewhat explained why.

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
        10.33.x.y        10.33.x.y    259

Looking the route table tells me that if the VPN is not active then route all IP traffic to the gateway through interface (my laptop) (Note - this interface address is assigned through the routers DHCP assignment and could change based on when I login and who esle is on the network). This interface address is dynamic, until I make it static.

When I decide to run my machine using VPN, the routes change because when I connect to the PIA server, that server assigns me an address of 10.33.x.y. I no long have a local machine address as I am now "hanging" off of PIA's server. (Side note - I still have that interface address of .140, but because of the tunnel and using TAP, I really belong to the PIA network and not my routers network). So that makes me part of their network and not the ISP's network. So now if I try and ping a device in my network the packet is sent via the 10.33.x.y network.

This is the reason I could not ping or connect to my modem or other devices on my network. So how to fix this? We have to setup a route table for the device you want to connect to.

Using the CMD as Administrator prompt
route add mask

So look at what I have done here. You will see that I have told my local machine that if I want to talk to the modem ( I must use the interface of But what about the 'mask'? The subnetmask of is saying that I can only use the address, not .2 or .3 or any address in the 192.168.100.x network.

Now suppose I want to access another computer (share files or drives?). I would first ping the device without VPN to make sure I can talk to the it. Then try with VPN. If I cannot talk to it via VPN I will have to setup a route via the route table.

If you are having issues trying to connect to devices in your network and you are using VPN on your local machine, try setting up a route to that device.

If you need to remove a route, just use the same command except change "add" to "delete". However, you should never delete the route unless you desire never to communication again.
Post edited by Omnibus_IV on
Sign In or Register to comment.