Port forwarding - Am I missing something ?

I just joined PIA, mostly because it supports port forwarding. I was under the impression that it was pretty straightforward : toggle "request port forwarding", connect to a gateway that supports it (I chose Netherlands) and read the assigned port number.

I did all that, then i tested the port number on yougetsignal.com and it tells me the port is closed.
I tried it on both Windows 7 and Linux Mint, and it still gives me the same result, even with the firewall deactivated. I didn't try to forward the port through my own router but I don't see how that's necessary since I'm using a VPN.

I guess either something's wrong or I'm being really stupid. Could someone please shed a light on this ?
Tagged:

Comments

  • Posts: 5
    What is the service that you're trying to connect to, you're swapping OS, but are you moving the service that is listening?

    In other words, your port will appear closed if there isn't anything listening on your machine behind the VPN.
  • Posts: 38
    Check that the port is open on the router and your firewall. Data over the vpn tunnel is still addressed to different ports as necessary for different applications to function, if a port is firewalled the vpn shall not pass.
    As JKVStang suggested, make sure the application you intend to use is running and also that the port is selected to match.
  • Posts: 2
    Yes, eMule was the service I was trying to connect to, and I guess I forgot to reconnect it after I deactivated the firewall. It was indeed the firewall blocking the port. Anyway, thanks, I added a firewall rule and it's working fine now.
Sign In or Register to comment.