Fedora 25 PIA via Network Manager - Can't connect

So i followed the instructions on the PIA website to install all the gateway information and it worked flawlessly! However, whenever i click the switch to turn on the VPN it just bounces immediately back and VPN doesn't connect. If i do it via the command line (sudo openvpn gateway_name.ovpn and punch in the login details) it works fine but doing this every time is time consuming. Is there a way to force the network manager to do it for me as it used to? It worked via network manager around Fedora 23 but then stopped after upgrades. I have everything installed (meaning networkmanager-ovpn is installed and such) but nothing seems to work. Any ideas Linux users?

Comments

  • Posts: 219
    there probably is a log file you can monitor in real-time while you try to bring up the VPN with NetworkManager. it is likely you missed one of the fine details of entering in the configuration in NetworkManager.
  • Posts: 3
    so i ran command     journalctl -b -u NetworkManager    to pick out just the network manager related entries. Below is the error i get when i attempt to connect:

    <error> [1500486107.3046] vpn-connection [XXX] "PIA - AU Melbourne",0]: Failed to request VPN secrets #3: No agents were available for this request.
  • edited July 19 Posts: 219
    you've got networkmanager-ovpn installed, right?  and you were sure to select the OpenVPN type of VPN when you set up the network connection?

    have you found the step-by-step guide to configuring networkmanager in this forum category ? (just because a different distro is mentioned, it does not mean the instructions are not valid)

    also, there are instructions here on how to use openvpn directly on the command line to prove you have all the parts you need and can configure them correctly.
    Post edited by martouf on
  • Posts: 181
    Cyrus said:
    So i followed the instructions on the PIA website to install all the gateway information and it worked flawlessly! However, whenever i click the switch to turn on the VPN it just bounces immediately back and VPN doesn't connect. If i do it via the command line (sudo openvpn gateway_name.ovpn and punch in the login details) it works fine but doing this every time is time consuming. Is there a way to force the network manager to do it for me as it used to? It worked via network manager around Fedora 23 but then stopped after upgrades. I have everything installed (meaning networkmanager-ovpn is installed and such) but nothing seems to work. Any ideas Linux users?
    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219498247-Changing-Ports-on-

    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/229676488-I-can-t-connect-to-PIA-when-using-a-very-recent-version-of-OpenVPN

    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/226851548-I-have-trouble-connecting-or-the-connection-drops-frequently-changing-ports

    ~ Private Internet Access VPN Customer
  • Posts: 3
    @martouf - i definitely have networkmanager-ovpn on board. I was sure of it initially (you don't get OpenVPN option in the networkmanager without it) but i checked again anyway an it is definitely installed. As for selecting OpenVPN as an Option, i imported the setting using the commands on PIA website and i also separately imported the config file manually. I thought if i follow the official Fedora set up instructions then i should have no trouble whatsoever. As for command line, i can make it work like that, but entering username/password every time is rather tedious. That is why i like using network manager.

    @OpenVPN i toyed around with the ports but that had no effect :/
  • Posts: 181
    Cyrus said:
    @martouf - i definitely have networkmanager-ovpn on board. I was sure of it initially (you don't get OpenVPN option in the networkmanager without it) but i checked again anyway an it is definitely installed. As for selecting OpenVPN as an Option, i imported the setting using the commands on PIA website and i also separately imported the config file manually. I thought if i follow the official Fedora set up instructions then i should have no trouble whatsoever. As for command line, i can make it work like that, but entering username/password every time is rather tedious. That is why i like using network manager.

    @OpenVPN i toyed around with the ports but that had no effect :/
    You might want to submit a ticket to the technical support department so they can help you through your issues.
  • Posts: 219
    great @Cyrus , I use NetworkManager as well. And I wrote a lengthy and detailed post here on how to properly configure a OpenVPN connection. Just because you imported a file, it doesn't mean that NetworkManager got all the settings correct. The only way to know is to navigate the entire configuration space in the GUI and check every configurable item.
  • Rerunning the pia-nm.sh fixed my issue for me:

    sudo pia-nm.sh
Sign In or Register to comment.