Why is PIA trying to connect to TimeCapsule?

Hello all, 

I have not found this particular problem listed in the threads, and I've tried calling the PIA help desk as well as the Genius Bar without answers. I installed PIA about a year ago, and any time I'm not on my home network and I try to connect, I immediately start getting a pop-up error "There was a problem connecting to the server 'name hereTC'." that significantly interferes with anything I try to type. The pop-up with occur up to several times a second, and I cannot type until I clear the pop-up. I usually get the "PIC Disconnected" pop-up shortly after. 

I have tried shutting off automatic back-up to the TC, assuming it was related, but that didn't help. The PIA help desk couldn't help, and Genius was completely useless (it's not Apple software, so that's expected). If I were trying to connect to the TC it may make sense, but I'm not trying to connect; I simply want secure browsing. Why is PIA trying to connect to my home server when I did not request it? And how do I get it to stop so PIA functions properly?

If PIA won't play nicely, I'll have to try a different one. 

Cheers.
Tagged:
Sign In or Register to comment.