Issue with PIA when restarting computer.

in Feedback Posts: 1
I restarted my computer, and when it had finished restarting I logged on, then opened my browser. I went to log into reddit and launched Spotify, then wondered if PIA was connected. When I checked the notification drawer, PIA wasn't there. I then went and launched PIA and waited for it to pop up, then I lost internet connection right before the PIA window appeared. 

I then checked my internet connection. I was connected, but it said my home network was now an "Unidentified Network". I tried using the windows troubleshooter, but it found no problem. I tried loading spotify and another website, didn't load, no internet connection. My phone was still working, and is also connected to PIA, so I was confused on what to do.

I looked up the steps of reinstalling PIA for windows, and started following the guide found here. https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219498647-How-do-I-uninstall-reinstall-the-PIA-app-on-Windows-  

When I got to the step to where it said to delete the folder, I proceeded to delete it, but was prompted with an error, saying I could not delete the folder due to it being in use. 

I then started task manager and began looking for any files running connected to PIA. I found one, so I closed it. I then tried again to delete the PIA folder, but was prompted with the same error. I then started seeing which files it would let me delete, and which it wouldn't. It let me delete everything but the folder "log". I opened the "log" folder and tried deleting files, it then said the files were in use by rubyw.exe! So there it is! rubyw.exe was the issue. I googled and found out it was a program used by PIA. Which before I figured out it was the problem, I wondered what it was doing there, because I had never seen it before.

I thought I could provide the nice people at privateinternetaccess the issue I had, and how I fixed it, in case this is a common issue. So you could now make a guide if you needed to!

Hope it helps, and thanks for the great program you guys provide!


Comments

  • Posts: 233
    Hello @JacobMH,

    It sounds like you had some trouble with the kill switch. In the future, you can fix these issues by using the following steps: 

    • In the Search bar at the bottom of your screen, type in "Network and Sharing Center", and choose the option that comes up
    • Click on "Change adapter settings" on the left side
    • Locate your primary internet connection
    • Right click it and hit properties,
    • In the Networking tab, click on "Internet Protocol Version 4 (TCP/IPv4)" — leave it checked and click on "Properties"
    • Select "Obtain an IP address automatically"
    • Change "Obtain DNS server address automatically" to "Use the following DNS server address"
    • Enter 209.222.18.222 for the Preferred DNS server
    • Enter 209.222.18.218 for the Alternate DNS server
    • Click "OK"

    Your internet should work properly again!


  • Did you solve your problem? 
Sign In or Register to comment.