How to set up VPN on VU+ or other Enigma2 Satellite boxes

I thought I'd post this because the info isn't easily available, and actually it's pretty easy if you follow the instructions (thanks Cory Thompson).

1. go to the client support pages of private internet access site and download the OpenVPN Configuration Files (Default)

2. from the zip file we need ca.crt  crl.pem and any of the ovpn files

3. rename the ovpn file to client.conf.

4. open the client.conf in a text editor and modify the line "auth-user-pass" so it reads "auth-user-pass password.conf" (without the quotes)

5. create a password.conf file (create a text file then rename to password.conf)

6. go to Private Internet Access site and log into your control panel. Click to generate a PPTP/L2TP/SOCKS Username and Password using the button within the control panel and add the info to the password.conf file so the username and password are by themselves on separate lines, eg:
x598723
as89a9b90a

7. create a new folder in your VU/Enigma box in the etc folder and name it openvpn. Then place all 4 files (ca.crt, crl.pem, client.conf, password.conf) into etc/openvpn.

8. reboot your vu+

9. Go to settings>network>services>openvpn and install it then start the OPENVPN service. Choose to autorun if you want.

DONE.


Comments

  • Made the folder but openvpn won't run just says feeds down for maintenance. Anybody help??
  • Posts: 308
    What image are you running? Anyhow, the message means your internet is down or the server is down.
  • All sorted now thanks folks
  • it keeps telling me my device is not connected to the internet but it is i have internet access and i have tested connection. Any ideas? 
  • "it" = what?
  • Hi there,
    where do i find this? OpenVPN Configuration Files (Default)
  • I have already set up one enigma 2 device with PIA, can I use the same PPTP/L2TP/SOCKS Username and Password for a second device in another household or do I need to generate a new username and password?
  • Posts: 978
    thomsork said:
    I have already set up one enigma 2 device with PIA, can I use the same PPTP/L2TP/SOCKS Username and Password for a second device in another household or do I need to generate a new username and password?
    You can use the same, in fact generating a new password will replace the other one.

    PIA allows up to 5 connections at the same time, so there's no problem at all connecting more than one device to your PIA account!
  • And they can be different ip's?
  • Posts: 978
    thomsork said:
    And they can be different ip's?
    Yes, absolutely, as long as it's no more than 5 different ones. Otherwise the abuse protection system might kick in if you do that too often. It can also only count public IPs, so all devices in the same house counts as one.
  • Hi, I've followed all the instructions at the beginning of the forum , but still have no joy getting the open vpn to work. No. 9
    What might have I done wrong as I can't see the openvpn folder to down load. I have tried running OpenVPN but it just stays red?
    Please advise
  • Hi I thought I had mine working but I am now concerned that maybe it isn't connected.  I used the Username and Password that were sent to me on sign up, is this not correct? 
    Should I be doing as in 6 above and creating one in "Click to generate a PPTP/L2TP/SOCKS Username and Password using the button within the control panel"
    Or does either work?
    Thanks
  • thomsork said:
    I have already set up one enigma 2 device with PIA, can I use the same PPTP/L2TP/SOCKS Username and Password for a second device in another household or do I need to generate a new username and password?

    How did you get it to work ive followed the instructions posted by p5303503 but still not working any help would be great
  • alex1888 said:
    thomsork said:
    I have already set up one enigma 2 device with PIA, can I use the same PPTP/L2TP/SOCKS Username and Password for a second device in another household or do I need to generate a new username and password?

    How did you get it to work ive followed the instructions posted by p5303503 but still not working any help would be great
    You have to make sure you are using the latest image for your device. I had problems using an old image, didn't have the correct modules installed and files called 'tun'. The openvpn would not start or stay running. And make sure you follow his instructions exactly. Download Notepad++, it's free and easier to use than ordinary notepad
  • Posts: 978
    thomsork said:
     And make sure you follow his instructions exactly. Download Notepad++, it's free and easier to use than ordinary notepad
    Actually I think it will also work with WordPad as long as you make sure to save it as a plain text file still. The problem with notepad is that the config files PIA ships uses the Linux newline convention (single \n), while Windows uses \r\n to mark new lines so opening them in standard notepad makes the whole config be on a single line, and I think it also strips the \n in the process as invalid new lines.
  • Hi, I've followed all the instructions at the beginning of the forum , but still have no joy getting the open vpn to work. No. 9
    What might have I done wrong as I can't see the openvpn folder to down load. I have tried running OpenVPN but it just stays red?
    Please advise

    Maybe you dont have openvpn installed, you can search for the addon using your remote
  • Max-P said:
    thomsork said:
     And make sure you follow his instructions exactly. Download Notepad++, it's free and easier to use than ordinary notepad
    Actually I think it will also work with WordPad as long as you make sure to save it as a plain text file still. The problem with notepad is that the config files PIA ships uses the Linux newline convention (single \n), while Windows uses \r\n to mark new lines so opening them in standard notepad makes the whole config be on a single line, and I think it also strips the \n in the process as invalid new lines.
    notepad++ is a fantastic tool. Download it, you won't regret it.
  • edited January 29 Posts: 1
    just to add - open this conf file with notepad++   Notepad wont separate the lines correctly so instructions in the initial post wont make any sense (as i discovered the hard way!!!!)
    Post edited by bowlhox on
  • Posts: 1
    This may be a stupiid question as I'm new to this. I'm running a Meelo box with ipab and openATV. I've followed the instructions (in this post)but when I go to my boc and click on connect vpn it stays unconnected. I think maybe this is because I used windows to copy the files onto my box over my network? OR I got the wrong files from the PIA site as there are a lot of options to download. I am sure I ddid everything else correctly such as editing and renaming the conf files.

    If its because I moved my files onto my box using my windows laptop I have installed filezilla but after a quick look cannot work out hoow to use it to browse my network to my box so any pointers to help files on this would be appreciated.

    Thanks for any advice you folks can give. A newb to vpns and PIAVPN
  • Posts: 978
    @tabath Does your Meelo box have any log output? Without the exact reason it doesn't connect, it will be hard to know what is wrong. For all we know, there might not be any problem with the configuration file but rather that the device fails to connect for a different unrelated reason.
Sign In or Register to comment.