Cox blockingoutbound email on Thunderbird

I have Windows 10 / and Thunderbird 56b2 and PIA v72.  Cox is my ISP.  I have PIA DNS defined in my router.  My options are: 

Start application at logon is set to Y

auto-connect on launch is set to Y

show desktop notifications is set to Y

DNS leak protection is ON

IPV6 leak protection is ON

Data encryption is AES-256

Data Authentication is SHA-256

Handshake is RSA-2048 

I am not blocking anything with my firewall. 

No issues setting it up and using it for browsing.  No issues with receiving email.  The issue is when I attempt to send email from TB I receive a message - "An error occurred while sending mail: The mail server sent an incorrect greeting:  eastrmimpo305.cox.net cox connection refused from 173.239.232.74."

I have to disconnect from PIA in order to send email and then reconnect. 

I've tried messing around with the settings but nothing seems to help.

Is there a way around this?

Or is Cox simply blocking VPNs?


Thank you.


Thanks

Comments

  • Posts: 348
    No, Cox is not blocking VPN, or for that matter, email. But if your email is @cox.net, then there might be an issue. Have you tried from a Gmail or Yahoo account? I have Cox but use MS Outlook as my email client. I also have Gmail and Yahoo mail and neither have issues.
  • Posts: 49
    I do have a @cox address. Both on my phone and laptop. This inability to send started about a week or so ago. I cannot send to a @cox or a @gmail address from a @cox account. When I disconnect from my VPN my email is sent.
  • Posts: 348
    I suspect your Cox email server is expecting to see a Cox IP address. I can't think of anything else.
Sign In or Register to comment.