Still using privateinternetaccess server assigned ip after stopping openvpn

Hi

First time posting here ... so be gentle!

So, I'm running opensuse 42.3 (64-bit) and using openvpn with a 'client config' file to connect through one of PIA's servers, I've had my PIA account for some years now and have used this method on linux with no issues in the past

I manually start and stop openvpn using systemctl, the command I use looks a bit like this:  sudo systemctl start openvpn@myclientconfig to start it

To stop it I use: sudo systemctl stop openvpn@myclientconfig.service

The Problem

I've been wrestling with this for days now btw

About 3-4 days ago I connected to the us-west server using this method, but when I disconnected/stopped openvpn my public ip did not revert to the ip assigned to me by my isp, still using the us-west one

I've tried:

Connecting to and disconnecting from several other PIA servers

Rebooting the opensuse machine (my openvpn connection is NOT configured to run on startup)

Turning my isp provided broadband router off and shutting the machine down completely for several hours

Completely deleting opensuse's network configuration and adapters then reconfiguring everything after a reboot

Numerous tweaks to my config file

I've checked my public ip after every thing I tried using both dig and a few websites


I don't understand how I can still be showing the us-west address as my public ip after trying all the above, how I can still be showing the us-west ip when openvpn is not even running I have no idea nor how it can still be assigned to me after shutting down and reconfiguring everything


Here is the result when I issue a dig command:

dig +short myip.opendns.com @resolver1.opendns.com
146.199.102.150

Geoiplookup result:

 geoiplookup 146.199.102.150                 
GeoIP Country Edition: US, United States

I'm in the uk and my isp is plausnet in case that helps

Does anyone have any ideas on what else I can try?

Comments

  • Posts: 3
    After a few days of trying things people on the opensuse forum have suggested I'm starting to think I'm gonna have to wipe the system and do a reinstall

    Might seem a bit of a bit of a drastic step to fix one issue on an otherwise working system that I put  a lot of time and effort into setting up exactly how I wanted it but it seems not only am I out of ideas but so are the people who've tried to help so far

    I'll probably do that as the last and only option left open to me, but I figure I'll give it another day to see if anyone here comes up with any suggestions
  • Posts: 3
    I've done a bit more research and discovered it's an issue with my isp that a number of their other customers are experiencing and the consensus seems to be that requesting a static ip from them fixes it

    If only I'd found that information some days ago!
  • Posts: 219
    what you describe sounds more like a DHCP problem to me
    or something messed up with NetworkManager.

    I've been running SuSE since about v11 and now Leap 42.3 and I've not seen anything like what you describe. I started off using ifup/ifdown and openvpn directly. Lately it's via NetworkManager.  No systemd involved.
Sign In or Register to comment.