V72, icon turns red, right-click shows "Loading...", "Help" and "Exit"

Windows 10 Pro x64, Creators Update, running V72.
I often get two PIA tray icons, and when I mouse over one of them dissapears. Sometimes the one that stays is green and when I right-click it, I get the usual list of servers, "Settings", etc. Other times, the icon is red and the only 3 options I get on a right-click are "Loading..." in gray, "Help" and "Exit".
It is weird for me that the changelog for v72 says "Improved detection of whether the application was already running when opening the application more than once", because I didn't have that problem before.
The PIA website says I'm protected, and I'm not leaking DNS or IPv6. My qBittorent app successfully routes all traffic through the PIA adapter. So I guess it is a minor bug, but it is a bit unsettling because I won't be able to tell if I got disconnected.

Comments

  • Posts: 1
    I'm having exactly the same problem on 2 different Windows 10 machines. I completely uninstalled/reinstalled on both, yet it keeps happening. It didn't happen on V71, although I did get more disconnect/reconnects.
  • edited August 27 Posts: 9
    I'm having this issue as well, it's super annoying. Just added a support ticket for this. Apparently the latest windows patch causes issues with PIA.
    Post edited by Godlessss on
  • Posts: 31
    Having the same issue. With a screenshot:

  • Posts: 22
    I'm having the same issue with v72, but on macOS. Last week I fixed it by uninstalling PIA and reinstalling. But the issue is back now.
  • edited September 1 Posts: 1
    I'm having the same problem.  Is there any way to follow/subscribe to a post?

    Also have you found a way to access the PIA settings?  I have to restart my computer if I want to disconnect, change to a different country server and reconnect!

    Post edited by p5616240 on
  • Agreed - have had the same issue: reinstallation and update of Qbittorent, Kaspersky update result in no change. Using killswitch completely shuts off internet connection.

    This is a known problem (PIA manager advises about killswitch known issue) - is there any solution PIA?!
  • Same issue here. I'm too afraid to use it until it gets fixed. The program randomly closes about once every two hours or so and boots me off the VPN. My subscription is up in a month or two and I have no plans to renew if this isn't fixed by then. 
  • Posts: 195
    Usually this issue is caused by Antivirus software interfering with the connection between the app's manager and display tray. You should be able to resolve it by adding exclusions to your AV software. We have directions on how to do that for Windows and MacOS available here.
  • I had several issues with v72 and Windows 10, I went back to v71 and haven't had a problem. I tried all the possible solutions and none of them resolved the problem. I did all the testing and I'm still protected by PIA, so I'm not worried.  B)
  • I'm having the exact same problem on Windows 8.1 Pro x64. Unfortunately I can't pinpoint whether it's from upgrading my antivirus to the newest version or installing windows updates because I did both at the same time. And the updates numbered in the dozens so I can't just go through them one by one easily either (it's a long story). Originally I only had to exit and restart the service. I tried uninstalling and reinstalling PIA, but it kept happening and then PIA wouldn't restart at all unless I reinstalled the TAP driver. I just tried doing what Colleen suggested by whitelisting files in my antivirus. So far I've gotten all the .exes but I'm still trying to figure out how to whitelist tap0901.sys and pia-openvpn.dll in this antivirus. The issue is still happening in the meantime, but I'll see if it happens again once I figure out how to whitelist those sys and dll files. I did put in a ticket when this first started and included log messages from when it happened. This was before I decided to do a reinstall. It's been a little over a week with no response, but that seems to be a common occurrence. The thing is, the messages in the log I was getting then are different from the ones I get since the reinstall. I can't remember exactly (it's in the ticket), but it was an error message that would repeat every second until I manually quit PIA. If I could see my support ticket I could tell you exactly what I was seeing. But since I did the reinstall, there's no repeat messages every second in the logs when the issue turns up.
  • I've contacted PIA about this before and got a less than satisfactory response. Essentially something about the PIA client is broken and/or does not work well with antivirus software because of how it generates a temporary ruby executable every time the software is run or some other unknown bug. The only fix for me has been to uninstall the PIA client, install OpenVPN and use the OpenVPN configuration files. I've had a stable connection ever since. I hope they fix this soon.
Sign In or Register to comment.