uTorrent not downloading (and not exiting)

New user of PIA and I thought I'd just try uTorrent over VPN (without using a proxy, at least for now). A couple days ago it worked fine. Today there is zero bandwidth on torrents (up or down). Exited uTorrent and it didn't exit. Normally it takes less than 30 seconds before it disappears from Task Manager (closing down connections properly I suppose). Now it doesn't close at all. I left it for more than 20 minutes and it's still showing in Resource Manager at about 15% CPU usage and a bunch of network connections, but strangely zero disk activity.

If I end the process and restart it a few torrents (less than six) will fire up and work fine until they complete. But no other torrents start even though they're queued. Also, once the torrent stops downloading it doesn't seed (nothing is seeding at all once the few started ones complete). Kill uTorrent in task manager and restart it and the same thing happens - a few torrents start then once they're finished there it zero activity.

I tried using a couple different PIA connections (one closest to me then just a random one) and doesn't seem to make a difference.

So, should it work just using VPN without the proxy? If so is there something I need to tweak setting wise? I read this post and tried the UTP settings it suggests but didn't make a difference.

https://www.privateinternetaccess.com/forum/discussion/23112/anyone-having-torrent-slowdowns-please-read-this#latest

Bear in mind utorrent worked perfectly before PIA and even for the first couple days of using PIA. It's just randomly stopped working properly 0_o

Comments

  • Posts: 4
    Just wanted to update this, it may be a uTorrent problem rather than a VPN problem (though it's weird it hasn't happened before). I tested by running Tixati portable and adding a torrent to it. It runs like a charm getting over 1mbit/sec for the test file. All without any tweaking or changing settings adding proxies etc.

    I'll do some more testing and see if I can figure out what's going on and post results in case anyone else is having similar problems.
  • edited September 2 Posts: 9
    FYI uTorrent golden era is long gone. For some years now it has been acting as a channel to spy users, install malware and - this is great - mine bitcoins on users' computers! This isn't FUD, search the net and you'll find a sea of information on the issue.
    There are plenty of great BitTorrent clients: rtorrent, Transmission, Deluge, KTorrent... just to name a few.
    Post edited by the14eyesarewatching on
  • Posts: 4
    Funny you say that, I was actually coming back to post saying I've given up on uTorrent and switched to Tixati (64bit version and it appears to work fine). Pretty sure uTorrent wasn't mining bitcoin on my machine and hadn't installed any malware but the reality is it's become too much of a pain to keep working properly (crashing, failing to load, failing to exit, not downloading...). Which is pretty bad considering it's from the people who wrote bittorrent :(

    Maybe there is some weird conflict with something PIA does, but frankly I'm tired of wasting my time working to solve it.
Sign In or Register to comment.