[RESOLVED] Remotely disable kill switch Ubuntu 14

edited September 2 in Linux VPN Setup Posts: 3
I do not have local physical access, but I do have remote power/reboot.
I signed into my remote computer and saw that the VPN was no longer connected. (Red PIA icon).
I've successfully used the kill switch in the past but thought I no longer needed it.  It has been a looooong time since PIA had crashed on me.

With the kill switch now active I have no remote access once I log into the machine, the kill switch is killing connection/keeping me out.
If I force reboot the machine, I can ping and ssh to the computer before logging in.

Is there a way I can remove the kill switch prior to logging in?
To disable it.
Post edited by samport88 on
Tagged:

Comments

  • edited September 2 Posts: 3
    What are your thoughts on editing this file?
    Will it turn off kill switch and get me working again?

    sftp://REMOTE//home/local/.pia_manager/data/killswitch_state.json
    {"killswitch":true,"killswitch_iptables_on":true}
    change to:
    {"killswitch":false,"killswitch_iptables_on":false}
    or??
    Post edited by samport88 on
  • edited September 2 Posts: 3
    Update:
    {"killswitch":false,"killswitch_iptables_on":false}
    Does NOT work, I had full access for a little while longer (extra 15 seconds) after making those changes, but the kill switch is still active it seems.

    [RESOLVED]
    Just uninstalled PIA completely
    rm -rf ~/.pia_manager/

    Reboot, able to log in fine.
    Reinstall, forget about kill switch.
    Post edited by samport88 on
Sign In or Register to comment.