Unidentified Network No Internet Access

I'm on Win10 Home v1703 (Creator's Update). Lately when PIA autostarts it connects to a random server as specified, but when I hover over the network icon it says "Unidentified Network No Internet Access." So I disconnect, then auto connect and then I get internet access (Unidentified Network Internet Access). I have to do this each time my PC starts up.

Even after returning from hibernate mode, I will need to disconnect/then auto start to get Internet access to the VPN. My regular network has Internet access though.

 I reinstalled the TAP drivers but I'm still having the same problem. How can I configure it so the VPN connects to the Internet upon startup? I'm using the default settings.

Thanks for your help!


  • edited September 2017 Posts: 52
    Hello Geofmeron, Issues like this can be cause by the kill switch. I would like for you to check to see if the Kill switch is enabled, because if the kill switch is enabled when your connection timeouts, the kill switch will prevent your connection from automatically reconnecting without the protection of the PIA VPN service.

    All you will need to do is disable the kill switch. All you need to do is right click on the VPN icon select “Settings” then “Advanced” there you can disable the Kill Switch, after this it should bring back their internet connection.

    If your internet is not returning then the most likely cause of your issue is caused by DNS Leak protection. Please check your if your DNS leak protection is enabled. Then please make the following settings changes; these will re-enable your internet connection, and mimic the effects of the DNS leak protection setting while connected to the VPN:

    Post edited by PIAAustin on
  • Thank you PIAKaneesha. The kill switch isn't enabled, and DNS leak protection is enabled. Interestingly enough, I periodically checked the network after my PC came out of hibernation today, and after several minutes the VPN eventually connected to the Internet. Not sure why it takes so long but at least it connected.

    I will make the changes that you recommend in the article. Hopefully it will connect faster. Thanks again for your help!
  • Hello @Geofmeron, Your very welcome if you have any further issues or questions please let me know or contact us here: https://www.privateinternetaccess.com/pages/contact-us
Sign In or Register to comment.