Permission denied when installing [Solved]

edited September 29 in Linux VPN Setup Posts: 3
Not sure how to get around this error. if anybody would help me out with this log it would be much appreciated.

bootbands@BootBands-Ubuntu:~/Documents$ ./pia-v72-installer-linux.sh
Permission denied - /home/bootbands/.pia_manager/log/pia_install.log
/tmp/pia_install.7041/installer_linux/64/fileutils.rb:247:in `mkdir': Permission denied - /home/bootbands/.pia_manager/pia_manager (Errno::EACCES)
    from /tmp/pia_install.7041/installer_linux/64/fileutils.rb:247:in `fu_mkdir'
    from /tmp/pia_install.7041/installer_linux/64/fileutils.rb:221:in `block (2 levels) in mkdir_p'
    from /tmp/pia_install.7041/installer_linux/64/fileutils.rb:219:in `reverse_each'
    from /tmp/pia_install.7041/installer_linux/64/fileutils.rb:219:in `block in mkdir_p'
    from /tmp/pia_install.7041/installer_linux/64/fileutils.rb:205:in `each'
    from /tmp/pia_install.7041/installer_linux/64/fileutils.rb:205:in `mkdir_p'
    from ./installer_linux/run.rb:74:in `block in install'
    from ./installer_linux/run.rb:72:in `each'
    from ./installer_linux/run.rb:72:in `each_slice'
    from ./installer_linux/run.rb:72:in `install'
    from ./installer_linux/run.rb:148:in `<main>'

Post edited by PIAAustin on

Comments

  • edited September 29 Posts: 84
    Hey @BootBands

    Thanks for reaching out today!

    Are you using encrypted home directories
    Post edited by PIAAustin on
  • @PIAAustin I am not using encrypted home directories.
  • You may not have permission to the folder in your home directory. 

    I will recommend deleting it as root (sudo rm -rf ~/.pia_manager) and trying again. 
  • SOLVED

    to fix the error the commands below were used:

    cd ///home/bootbands/.pia_manager/log/
    sudo rm pia_install.log
    cd .pia_manager
    sudo rmdir log
    cd ..
    sudo rmdir .pia_manager
    cd downloads
    ./pia-v72-installer-linux.sh






  • Haha looks like we both posted at the same time. 

    Thanks for letting me (and the forum) know how you solved this issue!
Sign In or Register to comment.