Sudden DNS Leaks on Windows 10 PC

edited October 2 in Windows VPN Setup Posts: 4
I recently started having DNS leaks on one of my Windows 10 PCs (Within the last day or two).   My other Windows 10 PC works just fine with no leaks.   All settings are the same between both as far as adapter settings, PIA app settings, connected to the same router, etc..   I use dnsleak .com and see the PIA connection followed by my ISP DNS entries in red saying "DNS might be leaking".

I have tried various solutions I have found on this forum and throughout the internet such as reinstalling, manually putting in PIA DNS settings (Non-server specific), disabling IPv6, adjusting options within the PIA app, but have yet to find something that works permanently without my intervention. 

The only thing I have found that works is connecting to a server on PIA, running dnsleak. com, and then manually entering the DNS information that shows up  on the PIA "Not leaking" entry for that specific server into my adapter settings.  Once doing this and running dnsleak .com again, I only see the PIA entry that says my DNS is not leaking.  Unfortunately, this is not a permanent or acceptable solution because the PIA connection DNS settings change every time I restart/shutdown/startup my machine or connection. I have to manually do the process over again to find the new DNS and enter it manually. 

Any ideas?

Post edited by pia_user60 on

Comments

  • I've received the following from PIA support on this issue:

    "That is very strange indeed! It's probably best to permanently change your DNS servers to PIA's to avoid future leaks.

    Please try changing your DNS servers using the following steps:

    1. Disconnect the VPN
    2. Right click on the icon for our VPN client, and choose "Settings", click "Advanced", uncheck the "DNS Leak Protection" option in the client settings, and save.
    3. Press the Windows Key and the letter R together to bring up the "Run" dialog box, then type the following command into the search box and press enter: ncpa.cpl
    4. In the Network Connections window that appears, locate the Ethernet/WiFi network adapter you connect to the internet with.
    5. Select that network adapter, right click it and choose Properties.
    6. Under the Networking tab, select the TCP/IP(v4) and then click Properties.
    7. Ensure that "Obtain an IP address automatically" is enabled.
    8. Change "Obtain DNS server address automatically" to "Use the following DNS server address"
    9. Enter 209.222.18.222 for the Preferred DNS server.
    10. Enter 209.222.18.218 for the Alternate DNS server.
    11. Apply the changes by clicking OK out of all available configuration windows.

    After this, please reboot your computer for all the changes to fully take effect."

    Once doing this, the DNS leak still shows up use dnsleak .com, but leaks to the PIA DNS servers.

    Anyone else having this issue on Windows 10?

  • Posts: 23
    You might want to do an ipconfig /flushdns 
  • Ramburner said:
    You might want to do an ipconfig /flushdns 

    Yeah. I tried that.  Still no love.  

    I still just manually put in the DNS settings that show up for the server I am connected to in order to stop the "Your DNS might be leaking" warnings when using dnsleak .com pointing to my ISP DNS servers.

  • Posts: 198
    We have you reassign your DNS servers so that even if they are "leaking", all they're leaking is PIA DNS (which is what the app's DNS leak protection assigns, so you're essentially just doing it manually). You'll still see the warning on DNS leak tests, but it's nothing to worry about so long as the DNS listed is PIA's. 
Sign In or Register to comment.