Virgin Media Super Hub 3.0 - modem mode with ASUS RT-AC87U

  • I have Virgin Media 200mb Gamer fibre with Super Hub 3.0
  • I get 200mb speeds with wired Ethernet and about 180mb over wireless.
  • However, when connecting to Private Internet Access (PIA) openVPN windows client, the wired speed drops to less than 50mb, using fast.com for testing.
  • I have recently changed the Super Hub 3.0 into Modem Mode and purchased an ASUS RT-AC87U router - however this has not made a significant difference with VPN speeds, still around 50mbs.
  • I have tested all ports available on PIA and different location servers with no joy.
  • I have also tried using AirVPN Eddie client and SSL enabled over port 443 and still get around 50mb.
  • Do you have any other suggestions I could try to fix the VPN problem?
  • I would ideally like to receive the full 200mb speed but 100mb on VPN would be acceptable if I can achieve that.
  • Could I request a Super Hub 2.0 from Virgin Media instead? Would this make any difference when only using in Modem Mode?
  • Rather than windows client, I will also test by loading an openVPN profile into the ASUS RT-AC87U router and see if that works. If not, I might return the ASUS RT-AC87U router if it doesn't make a big difference in speeds with VPN enabled. 

Thanks

Comments

  • Posts: 15

    What CPU do you have in your PC / Laptop?


    Open Task manager if using windows and right click OpenVPN.exe then change priority to High.


    Test your speed after making those changes.

  • Thanks CPU is:

    Intel(R) Core(TM) i7 CPU M 620 @ 2.67GHz
  • Posts: 15
    That should be perfectly fine to run OpenVPN at full speed.

    Is the slow speeds mainly at night? VM is always suffering from congestion.
Sign In or Register to comment.