Port forwarding with VPN installed on router


ASUS RT-AC87U standard firmware with PIA as OpenVPN client installed on the router. QNAP NAS with 2 Foscam C1 V2 IP cams. Port forward setup for incoming requests for port 443 (SSL port of the NAS) to LAN static IP of the NAS. Goal is to access the IP cams from outside my network, using the QNAP VMobile app (I am open to suggestions for other tools to use).

This all works fine, if PIA is not enabled. But as soon as I enable the PIA VPN on the router, I can't access my IP cams anymore. Just to be clear, I am accessing the IP cams through the NAS, not through the camera itself.

Can't figure out why this is happening, and how to solve it. The IP address given to my router by PIA is correctly reflected in the QNAP remote access service (myQNAPcloud) but somehow the myQNAPcloud does not work anymore if PIA is switched on.

Obviously UPnP is disabled on the router.

Any suggestion are very welcome. Thanks.


  • Same problem here. Can anyone suggest? when i disconnect openVPN in router then it works. thanks in advance.
    Posts: 1
    Hmm PIA was one of the few VPNs that allow port forwarding on their VPN servers I believe? This would have to be set up on their servers for you to forward traffic directed to the VPN to reach your LAN/Router. I am not on PIA and I don't think my VPN allows for port forwarding so I know this is why I am unable to access my NAS via qnapcloud except via CloudLink.

    However, instead I have set up bypassing on my OpenVPN router to tell any traffic coming from the NAS on ports 8080 and 443 to not go though the VPN. Then you just need to make a note of your real IP address and access it that way, or alternatively I have signed up to a free DDNS service. You can also manually assign an IP address to the qnapcloud service too, which in theory should also allow the usual myqnapcloud dns to work.

    If you still want all traffic to and from the NAS to go through the VPN however, then what I said at the start should work if your VPN provider supports it.
Sign In or Register to comment.