PIA still doesn't work with Mac OS 10.13 High Sierra? Apparently this has been reported since June.

edited October 8 in Mac OS X VPN Setup Posts: 7
PIA connecting by "auto" takes me to a domestic server in my region (but it doesn't matter which server I select); then I have no Internet access. No Web, and can't even ping Google.

I see forum posts about this going back to the High Sierra betas early in the summer.

Anybody know what the story is here? That's pretty insufferable.
Post edited by PunksATawnyFill on
Tagged:

Comments

  • Seriously, WTF? This service is currently unusable.

    WHAT IS GOING ON?
  • Posts: 89
    Hey @PunksATawnyFill

    Thanks for reaching out today. 

    I'm very sorry for the trouble with this!

    I believe you're experiencing this issue because you're using an older version of the PIA app. Only v71 and higher are compatible with High Sierra. 

    To reinstall our VPN application on your Mac computer, please follow the steps outlined below:

    Click on the PIA application icon in the Menu bar, uncheck the "Start Application at Logon" option (if applicable) and choose Exit.
    Go into your Applications folder, and drag Private Internet Access.app to the Trashbin. Empty the Trashbin after doing this. If the app will not allow you to delete it, please reboot then try again.
    Open Terminal
    NOTE Please make sure this step is completed very carefully. All symbols, and spacing are VERY important. Incorrect usage of this command can lead to Data loss. (It is best to simply copy and paste the command below)

    Type: rm -rf ~/.pia_manager/

    Press enter. If the command is successful, there will be no confirmation, it will simply go to a new line in the Terminal window.

    Once you have it completely removed via the process above, power down your computer, wait 60 seconds, and power it back up, and all traces of the application should now be removed from the system. Following this, go to https://www.privateinternetaccess.com/pages/client-support/ and download a fresh copy of the Mac application and run the installer.
  • Posts: 14
    There is STILL an issue with v72 where it will connect for a while and then disconnect ALL OF THE TIME. The service does not work. Prior to High Sierra it worked. PIA this needs to be fixed! The service you are charging for does not work as advertised.
  • Why don't you INFORM US that there's an updated version?

    There's not even a "check for updates" menu item in your application. Come on!
  • edited October 11 Posts: 7
    Why can't we delete posts?
    Post edited by PunksATawnyFill on
  • Posts: 2
    I'm having this problem as well.  Just completely uninstalled per instructions, installed v.73 and cannot connect.
  • Posts: 572
    Really amazing how unresponsive PIA is to these app issues (and there have been so many).

    Let me suggest ya'll just uninstall the PIA app altogether and install either Tunnelblick or Viscosity. That's what I did a couple years ago after too many problems with the PIA app to count. No problems since then.
  • Posts: 14
    Agree - very sad how many issues there are and how unresponsive to delivering a fix PIA seems to be.
  • Posts: 14
    Quick question tomeworm - I have installed Viscosity and imported the PIA VPN details as that's the VPN service I currently have. My router is a Netgear Nighthawk and for some connections I need port forwarding so in the router I previously set up a port forward for the port used by PIA - set up for both TCP and UDP to forward external port x to internal port x to my Mac. With Viscosity, from what I can tell they use port 1198 and I have forwarded this for both TCP and UDP to my Mac's internal IP and most things are working but Safari and uTorrent seem to not see the network. I'm not sure if I have identified the port correctly as Viscosity has a number of screens with options that I'm not 100% sure of yet, having just completed the install. Any advice / links re setting up port forward?
  • edited October 20 Posts: 572
    1198 would be the listening port. It has nothing to do with port forwarding, and you don't need to forward that port on your router. Don't mess with it unless you're certain you know what you're doing.

    As far as I'm aware Viscosity has no port forwarding options. So if you absolutely need it then you may have no choice but to use the PIA app on an as-needed basis (that is if you can even identify a version of it that might sort of work for you).

    The only thing I ever used port forwarding in the PIA app (when I did use it long ago) was for downloading a non-tracker DHT-only torrent file that had run into "announce" issues. Connecting to a PIA server that supports port forwarding can get those downloads going much more quickly. But I also found that such torrents even without port forwarding usually do eventually start up on their own. It just takes patience.

    Of course I'm just guessing at this point and really don't know what you're trying to accomplish. Feel free to elaborate. Happy to help if I can.
    Post edited by tomeworm on
  • Posts: 2
    p0099894 said:
    There is STILL an issue with v72 where it will connect for a while and then disconnect ALL OF THE TIME. The service does not work. Prior to High Sierra it worked. PIA this needs to be fixed! The service you are charging for does not work as advertised.
    Yes, having this problem as well.
  • Posts: 14
    Hi tomeworm - I managed to get the PIA client working by reverting to v71 and selecting TCP port 443 as the protocol and port, turning on port forwarding and telling my router to forward that port to my Mac. If I use PIA or Viscosity with the default settings (UDP generally) then somethings work and some don't - with Viscosity both uTorrent and Transmission were fine but Mail and browsers (Safari, Firefox, Chrome) would not connect - with PIA all general apps were fine but uTorrent and Transmission not without connecting to a port forward enabled endpoint and with the port forwarded also in my router. I have several friends with PC and they just install and run PIA and it all works but on my Mac on Sierra and High Sierra I've always had to fiddle the settings and also port forward in the router. With my router (Nighhawk X6 R8000 I had to set up port forward for Plex to be visible externally and also another media server I run. With the torrent connections apparently some situations have problems with anonymous peers (eg. on VPN) but generally this seems to not be an issue - however I needed to select a port-forward option from the PIA endpoints and forward the port in my router for the torrent apps to actually connect.

    So summary of the above ramble is that for torrent related apps Viscosity seems excellent and I like what it offers but can't use Mail or browsers - so sadly not a viable solution for me. PIA with the port forward endpoint etc is now working with the reversion to v71.

    Hope that all makes sense.
  • Posts: 265
     but on my Mac on Sierra and High Sierra I've always had to fiddle the settings and also port forward in the router.
    That sounds like it would be more of the network conditions rather than Windows vs Mac. It's literally the same app on Windows, Mac and Linux. Changing the protocol and port only translates to changing those options on OpenVPN. The only two settings that could have a different outcome due to OS difference would be IPv6 leak protection and DNS leak protection, but they're rarely an issue on Mac.

    Switching to TCP and using different ports is usually to workaround router or ISP bugs. For the operating system it's all the same. Your router should have no problem with NAT'ing UDP properly, as it's about the same as TCP but usually implemented with a simple timeout instead. Changing ports is nothing but ISP throttling/blocking as it's a number all the way down to the raw packets and they shouldn't mess with it at all.


    If you do forward ports to your computer, the forwarded port is what the "Local port" field is for in the app. When blank, OpenVPN just picks a random port (as does 99% of everything else on your computer), but you can force it to use one in particular. It doesn't have to match the one you're connecting to, only the one that's forwarded to your computer so it makes use of it. But again, this shouldn't be needed as your router is supposed to learn it automagically.


    Unfortunately I don't have a Mac so I have no idea why or how it could work with some apps but not the others. What's the exact error message your browsers and Mail says?
  • Posts: 14
    Hi Max-P - the only "error" is that trying to connect takes ages and then I'm told something along the lines of "cannot connect to server" or similar. I agree that the router should enable things automagically however it doesn't seem to. For Plex to be accessible from external I had to put in a specific port-forward in the router, for Air Video media server likewise and for Transmission and uTorrent - otherwise the torrent apps behave like the net is disconnected.

    Not sure if it helps to clarify but I have the cable modem from my ISP (which can provide wifi and DHCP etc) set to bridge mode which turns off NAT so then my LAN DHCP etc is via the Nighthawk R8000. Turning on wifi (manual switch) on the cable modem (the one set to bridge mode) requires me to type the same wifi password as the R8000 uses rather than the one if the cable modem / router were the only network device, so the R8000 is managing wifi authentication. Connecting my Mac via wifi rather than the standard network cable to the network SSID on the bridged cable modem allows me to connect ok. E.g. my son has in-game comms working in Warframe if he connects to the SSID on the bridged cable modem but if he connects to my R8000, even with port forwards set up for the 2 UDP ports that Warframe stipulates the in-game comms does not work.

    So I suspect you're correct - there is some issue in the R8000 that is causing things that should work to not work. The only other "non standard" thing is that I use Parental Control on the R8000 which basically uses OpenDNS and as you know that simply changes the DNS and with my account it gives access to some basic whitelist / blacklist facilities.

    With the PIA app even since day 1 - using the pre v7x versions - I have had to "fiddle" the network settings to ensure I can access the Mail server, browser access works and the torrent apps work. The torrent apps have always only worked also when I connect to a port-forward endpoint and I have port-forwarding enabled in the PIA app and a corresponding port-forward configured in the R8000. It should be a whole lot simpler and more automatic I know. Viscosity works fine with the torrent apps but Mail and browsers don't, hence reverting to v71 PIA and the protocol settings being manually set rather than using the default "auto".
Sign In or Register to comment.