Would Like To Setup Pia on a Linksys Wrt 1900 acs Router

I'm new here so for give me if this has been ask before but I would like to setup Pia on a Linksys Wrt 1900 Acs router the videos on pia website are outdated and do not match my router interface so its difficult for me to follow as being an older person. And by doing this open vpn would all my devices be protected in my home such as , Roku, mobile phone, laptops and so on? Furthermore, would I need to make some form of adjustment when streaming videos from my crackle, Filmon, Tubi or Channel Pear? Thank you for your patients....
«1

Comments

  • Hello @dew7157,  To set up your Linksys Wrt 1900 router you will need to install our Openvpn installation for a DD-WRT router,  here is a link to the installation guide for your router: https://www.privateinternetaccess.com/pages/client-support/dd-wrt-openvpn.

    Here is also a link to a article from our support center that talkes about firmware and also links to our installer guides. https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219457267-Can-I-use-the-Private-Internet-Access-service-with-my-router-. ;

    Also to answer your question, yes installing our client on your router will protect all devices running behind it. As for your second question if you are streaming videos with a torrent client, No special settings are required in your torrent software to run torrents on the VPN. We recommend that you use our port forwarding feature, though this feature is only available on our desktop applications: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219460187-How-do-I-enable-port-forwarding-on-my-VPN-. ;


  • Posts: 25
    I will give a test run and see if I can configure it this way....thank you
  • Posts: 25
    My only problem or problem I may run into is that I don't see the interface of my router it just does not match the admin interface..
  • Posts: 25
    Yes, I have visited this page several times before but still don't understand putting in the addresses or location of pia vpn it's so confusing to me i don't want to mess things up to where it won't function again...I'm not comfortable on which addresses to use or add the page description is very simple to understand than the other one but confusing on addresses to use just not that confidant to be adding something I don't understand, sorry not that technical when it comes to this router config...
  • Posts: 265
    @Omnibus_IV ; That seems to be to set up an OpenVPN server on the router (to VPN into your home network), not to use a VPN for the internet traffic.

    @dew7157 Have you flashed DD-WRT at all on your router, or are you still on Linksys' interface? DD-WRT haven't changed their interface in years, so that leads me to think you're still on Linksys' original firmware. I don't know about this one specifically, but very few routers actually supports being OpenVPN clients by default.

    If you can share a screenshot of the interface you see it could be pretty helpful for us to guide you through it.
  • Posts: 25
    I thought the router was setup with Wrt open vpn and all I had to do is enter the addresses not flash it again? Maybe I'm wrong here but that the reason I purchase it so I would not have to flash it..
  • Posts: 25
    I guess there are two Vpn's to Internet traffic and home network? i don't no...
  • Posts: 455
    From a description of the router...

    "Out of the box, this router comes open source ready, so you can easily flash it with custom DD-WRT builds that are specially designed to make the most of its features. Or you buy one pre-flashed from FlashRouters. This is great, as it ensures you do not lose any of the router’s functionality when upgrading from the stock firmware to DD-WRT."

    If you paid around >179USD or so you probably just have the basic router. The router that is flashed with OpenVPN Client is around ~350USD. The information is sketchy at best and sounds more like marketing talk.
  • Posts: 265
    Officially supported or not, it does seem that DD-WRT supports it (unless they went as far as locking it but I think it's just marketing as Omnibus_IV said). There doesn't seem to be a direct link but just search for your router there: https://www.dd-wrt.com/site/support/router-database

    It has two revisions and both are supported, so as long as you make sure to install the right one it should be fine!


    Once you have flashed DD-WRT your interface will look exactly as on the guides. (And your router will have more features than you know what to do with.)
  • Posts: 25
    Well, when I click on file V.1 which is mine this is what I get  

    error: /var/www/firmwares/releases//r28788-01-13-2016/linksys-wrt1900acv2/factory-to-ddwrt.img does not exist
    Array
    (
        [id] => 4459
        [build] => 28788
        [generic] => 
        [filetype] => 1
        [label] => WRT1900ACS Firmware: webflash image for initial installation
        [type] => 4
        [platformId] => 7
        [path] => linksys-wrt1900acv2/
        [pathType] => 0
        [filename] => factory-to-ddwrt.img
        [created] => 2016-01-16 00:21:11
        [createdBy] => 1
        [modified] => 
        [modifiedBy] => 
        [removed] => 
        [removedBy] => 
        [routerIds] => Array
            (
                [0] => 749
            )
    
        [directory] => r28788-01-13-2016
    )
    

  • edited October 26 Posts: 455
    It is an image file which means it needs to be loaded into the router. It is not a file that one reads or opens. I flashed my WRT160N with DD-WRT. Although it is somewhat of an easy process, it can be a little frighting. One must follow the instructions that are on the DD-WRT web page.

    I would recommend that you do some research and get acquainted with the process mentally before actually flashing the router.

    Understand that I am assuming you have not flashed a router before. Not intended to speak down to you at all.

    edited for misspelling.
    Post edited by Omnibus_IV on
  • Posts: 25
    You are right I never flash a router you are assuming correctly its just when I click on the file it opens that way or may be I should left click I followed youtube video it showed click the file and save to download than open in the router ....but its not downloading its opening up and up above is what I'm getting.....
  • Posts: 455
    OK, not to discourage you but you might be biting off more than you can chew. As I mentioned before, it is an easy task, but very daunting and frightening. If you want to undertake this task you will need to do a lot of reading.

    Start here: http://www.dd-wrt.com/wiki/index.php/Installation

    You will not understand what they are talking about but the more you read and follow the links the more you will get the big picture. You can also look at youtube videos for flashing routers. The more you read, the more you watch, the more you will understand.

    If you have a friend who is knowledgeable then ask them for help. If you just bought the router maybe you can return it and purchase one from the DD-WRT site or if PIA has preinstalled routers, but here. I will leave that up to you. But you want a router that has the ability to work as a VPN Client, not a server.
  • edited October 26 Posts: 265
    I get the error too. It looks like the file is not available on DD-WRT's website for some reason. I was able to find the beta download from the weekly builds however: https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2017/10-25-2017-r33607/linksys-wrt1900acs/factory-to-ddwrt.bin
    Post edited by Max-P on
  • Posts: 455
    DD-WRT has a lot of broken links. I found that out when trying to flash my WRT160N. One has to be persistent in looking on their site for the information/files one needs. Wait until you need a file from their FTP server. Good luck. They revamped the FTP server but did not fix any of the links to that server.
  • Posts: 265
    Quite honestly I hate DD-WRT. I think it's a terrible firmware full of bugs and not all that reliable. Still a lot better than stock firmwares but I wish there was something more serious. I'm on LEDE personally and it's fantastic but it's not the easiest at all...
  • Posts: 455
    There is OpenWRT but when I was trying to figure out who to use, they seemed just as lost if not more than DD-WRT. So I went with them. Did not see any improvement over the Linksys stock firmware. Oh well...
  • Posts: 265
    LEDE is pretty solid for me. I heard they're going to merge back into OpenWRT so hopefully good things come out of it. I don't really know the debate between the two and why it forked but the other looked like it had a clearly defined goal and nicer documentation, and it happened to have a prebuilt for my router so I went with it. Came with the LuCI preinstalled and configured. Here's a bunch of screenshots: https://d.max-p.me/pia/forum/51425/

    It's also got the most comprehensive OpenVPN configuration I've ever seen in a GUI. They literally put every single option as individual fields and checkboxes, that's really nice (*cough* hardcoded options in DD-WRT *cough*)

    I think we should get back on topic tho to not confuse OP too much :) DD-WRT is a pretty good firmware too, nothing to worry.
  • Posts: 25
    Yes, I that was my first thought Max-P regarding the file wrt I thought there was something odd about it if you downloaded right click it it showed as a browser file or left click just opens up to code something was off to say the least...However as frustration build up I went a head and tried to upload to my router, well it shut it down I thought at first it bricked it I said oh no please....not me but I did reset several times and unplug it it seem to be running fine now....
  • Posts: 265
    @dew7157 Yeah, it seems the one in the search is broken. Use that link I posted earlier that seems to work: https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2017/10-25-2017-r33607/linksys-wrt1900acs/factory-to-ddwrt.bin

    I think the stock firmware is thankfully smart enough to not flash something that's not bootable/doesn't make sense to flash. Be careful with what you flash, it could have gone bad if you tried to flash the error page's code ;)
  • edited October 26 Posts: 455
    Read this

    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=287813

    Based on the information on this page

    http://www.dd-wrt.com/wiki/index.php/Supported_Devices#Linksys_.28Wireless_a.2Fb.2Fg.2Fn.2Fac.29

    the firmware for your router is located here

    ftp://ftp.dd-wrt.com/betas/2015/08-20-2015-r27700/linksys-wrt1900ac/
    If you click on the FTP link and it does not work, try removing the second ftp in the link.


    Now for a disclaimer. I cannot nor will not guarantee if these files will work. This is why I said YOU need to do the research. One more thing, it is not the IMG file that gets loaded, it is the BIN file.





    Post edited by Omnibus_IV on
  • Posts: 25
    Thanks a bunch so far I uploaded the file all went well so far still playing around with it maybe later input the the pia settings for the vpn..

  • Posts: 455
    Don't forget to set the clock. I read of issues of things not working because the clock was not set.
  • Posts: 25
    will do...thanks all for the help will be returning soon i'm sure with more questions as I read through all these documents....
  • Posts: 25
    Well, I'm back I've followed all steps outline in the page install pia settings but did not follow the video some details look different to me maybe it's just me but got to the end and saved all settings with PW and user and verified but nothing good showed up. I\ll try again see what happens double check my output and input of info....  

    https://www.privateinternetaccess.com/pages/client-support/dd-wrt-openvpn

  • Posts: 25
    Okay, all is fine mistake on my part don't use pw and user of router use your pia user and pw...dummy me....trial and error...working fine now I will tinker with it a bit....tks...
  • Posts: 25
    By the way, this is some of the out put what is the Warning?    Clientlog:
    20171027 17:51:21 W WARNING: file '/tmp/openvpncl/credentials' is group or others accessible
    20171027 17:51:21 I OpenVPN 2.4.4 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Oct 25 2017
    20171027 17:51:21 I library versions: OpenSSL 1.1.0f 25 May 2017 LZO 2.09
    20171027 17:51:21 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:16
    20171027 17:51:21 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    20171027 17:51:21 I TCP/UDP: Preserving recently used remote address: [AF_INET]104.207.136.115:1198
    20171027 17:51:21 Socket Buffers: R=[180224->180224] S=[180224->180224]
    20171027 17:51:21 I UDPv4 link local: (not bound)
    20171027 17:51:21 I UDPv4 link remote: [AF_INET]104.207.136.115:1198
    20171027 17:51:21 TLS: Initial packet from [AF_INET]104.207.136.115:1198 sid=6747aab7 059923dc
Sign In or Register to comment.