Google Fiber now actively throttles w/PIA use

edited October 25 in General VPN Support Posts: 8
I have Google Fiber and have used it with no issues to DL speed since I bought my sub of PIA at the start of January this year. I could have VPN off, check my speed, turn it on and see little to no difference regardless of where in the US I was connecting too. Today when I got home for some reason my VPN which was on when I left was turned off. I had v72 up until that point (upgraded to v74 with no change) and thought nothing of it, I turned VPN back on and saw that things were taking drastically longer to load. I turned VPN off and ran a speedtest, everything was fine 600+M down 700+ upload no issues. Went and turned VPN on and now (if using Google Fibers own speedtest) it says "you are no longer on the Google Fiber network" where before with VPN off it did not give me that message. I was seeing around 20M for both down/up which sounds good but when you have been used to much faster speeds its a big drop.

What can I give you to help diagnose the issue? Are you aware of Google Fiber being able to detect you are on a VPN and then throttling users access (this was not the case in the past)? I was under the impression after seeing people talk about VPN use on the Google Fiber forums there isnt a problem but there appears to be now. Restarting PC and with no programs running I see the same issue when I turn VPN on (slower speeds) and off (normal fast speeds).
Post edited by Rathanon on

Comments

  • Posts: 266
    That's interesting, I'm not aware of any issues with Google Fiber at the moment and I would not expect this kind of thing by Google.

    What state are you connecting from and to which PIA region are you connecting to? There's currently a bit of a speed bottleneck going on in western US that we're investigating, so if you're in the west or connect to the western servers it's possible that you are affected by that.
  • Posts: 8
    I did two tests, first was Texas origin Texas VPN, second was Texas origin Midwest VPN and Midwest was actually better around 90M down/up
  • Posts: 266
    Hmm, that's definitely odd.Texas server looks fine to me (I have a 200M connection):


    Have you updated anything recently or changed any settings on your computer?

    You may want to give a full reinstall of PIA a try as it will also uninstall and reinstall the TAP driver in the process: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219498647-How-do-I-uninstall-reinstall-the-PIA-app-on-Windows-

    If that doesn't work, it would be worth trying different protocols/ports and see if it changes anything. I doubt it will but these two settings are there precisely to workaround throttling of UDP or specific ports: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/226851548-I-have-trouble-connecting-or-the-connection-drops-frequently-changing-ports
  • Posts: 8
    So I did the first part of uninstalling PIA and reinstalling, that did not fix the issue. One thing of note I do not have the TAP....V9 #2 installed every time I install the newest PIA it always gives me Tap-Windows Adapter V9 in case that matters any.

    I went through the longer steps of trying all port variations in the video from the second link and while some didn't work at all every single other attempt resulted in the same reduced speeds. I went through the trouble of checking in between each attempt to see if my speed returned with VPN off and it did each time. Trying to be consistent I tried connecting to Texas VPN server each time as trying different servers and combinations would take too long.

    I think the obvious answer is still my first suggestion, Google Fiber is throttling PIA VPN for some reason. I have not installed anything recently, nothing had changed from the day before this happened until it stopped giving me full speeds.
  • Posts: 266
    Hmm, I guess it's possible but again that would surprise me from Google considering their pro net neutrality stance. It could also be some temporary congestion on Google Fiber's end between Google's servers and PIA's servers.

    If you have Chrome you might want to give the extension a quick try to see if that one behaves better. If it's really congestion or throttling it should be just as equally slow. If it's fast, it gets... interesting?
  • Posts: 8
    Well then prepare to get interesting because the Chrome extension worked. That helps internet surfing but I do a good amount of work from home that I would like to keep secure and the browser extension does not help me there. I am open to testing and trying anything to figure this out, any suggestions?


  • Posts: 8
    Pic above is Google Chrome browser extension connected to Texas server. In the off chance it was some hiccup when I was testing (unlikely as consistent as it has been in the throttle always up around 50M Down/Up) I turned off the extension and fired up the main app connecting to Texas again and the throttle returned. Killed VPN and full speed came back:


  • Posts: 8
    In your response you seem to know or understand what issue may be going on if browser VPN worked, what makes it interesting? What is there left to try?
  • Posts: 266
    No, I really don't know that's why I said it would become really interesting. There's no logical reason for this situation to happen. Even if it is throttling that would be some serious amateur grade throttling considering all the clues they'd have to work with. Some ISPs restrict the rate of UDP packets to limit their impact if it's a DDoS attack of some kind, but switching to TCP would have improved the speeds significantly. And even then, why would they throttle one set of servers but not the others? If they can identify OpenVPN they can identify the proxy.

    Do you have other machines you could test with? Even a phone where you could install the PIA app or OpenVPN could help: if they exhibit the same behavior then it has to be Google Fiber but if not it means it's your computer. I've seen a few odd cases of the TAP-Win32 being unexplicably slow. Just right now I have a Windows 10 install that tops around 110 Mbps while my Linux install does 200 Mbps instantly, and they're both identical VMs on the same virtual switch. This could work, but it has a fairly low success rate.


    If you don't mind toying with it, you could try downloading a Linux image (like Ubuntu) and throw it on a DVD or USB stick and install PIA on the live environment (no need to install it on your machine, just boot from it). OpenVPN on Linux usually just works so that would eliminate the possibility of being your Windows install completely.
  • Posts: 8
    I got PIA on my cell and while at home on the wifi connection I saw a slight dip in speeds when I turned VPN on which I think is to be expected but nothing showing it was capping me as it does on PC. I tested 5 times with VPN off getting around 100M up and down. With VPN on connected to Texas I was seeing around 70/20 on the first test but as it progressed it got up to the 100/30 range so phone via VPN and on home wifi does not appear to be affected like PC wired is.

    I can try Ubuntu but that will be a longer project I would have to dedicate some time too, maybe this weekend I can give it all a look.
  • Posts: 266
    Welp, at least that confirms that it's not throttling but something going on with your computer, otherwise the phone would hit the same limits.

    I forgot about it but, have you tried using the latest OpenVPN directly? If it's something to do with a recent Windows updates, it's very likely that a newer OpenVPN could help a lot (which comes with fresh TAP drivers as well).
  • Posts: 8
    I tried the OpenVPN and that did not fix the issue, each server I tried with it had drastically low DL speeds but the upload speeds were usually around 100M which was interesting (DL around 1-9M). I think with my previous test they just missed the phone aspect because today I am getting 120M+ DL/Upload on phone not connected and when I connect to VPN that goes down to 7M/20M DL/UP. I am back to everything that I try being drastically slower when using VPN connected to Texas or otherwise and full regular speeds when its off.
  • Posts: 266
    Yeah that's pretty odd. The part where the upload is much faster than the download in particular is really surprising. It really sounds like there's a local bottleneck around the TAP adapter somehow.

    Can you try with L2TP to see if that makes any difference? I know L2TP is pretty bad but that could be useful to know whether it's the TAP or something else on the computer.
Sign In or Register to comment.