UDP connection doesn't work

Windows 10. PIA had been set up using UDP connection type, auto port. I have a 10 Mbps connection (I know, not that fast, but good enough for me). With PIA disconnected I was getting between 10.4 and 10.5 Mbps (according to speedtest.net). With PIA connected I was getting between 9.0 and 9.5 Mbps.

Starting this morning, with PIA connected, I must've been getting zero Mbps. Browser would open, then nothing. No error messages, just nothing. Disconnected PIA, connection was back to normal. With PIA connected, it didn't matter what region or country I tried, I got nowhere. I tried changing the ports in PIA's settings, didn't work. I changed to TCP connection type (auto port). That worked, but the connection is slower than with UDP (6.4 Mbps to 6.6 Mbps). Changing the ports didn't affect the speed.

I have the PIA app installed on my Android tablet, but I usually leave it disconnected. Tried using the tablet with PIA on. Had the same problem as the PC. Connected with UDP, nothing. TCP worked but slower than UDP.

If it's doing the same thing on the tablet and the PC, then it can't be a Windows problem. My router has a firewall. I turned the firewall off but that didn't change anything. I had version 74 of PIA installed, today I noticed that version 75 was available, so installed that. It didn't fix the problem.

Is PIA having some kind of trouble with UDP or is there something else I can try?

Comments

  • I'm in the same boat. Tried to connect tonight and cant get a speed above 130/kb/s. What happened?
  • Posts: 273
    What ISP are you using and which PIA region are you connecting to? All good on my end with UDP.
  • Posts: 34
    My ISP is Colbanet, a Montreal based ISP. I'm getting what they call "Fiber-ADSL" service, which is Bell Fibe that they resell from Bell. I've had Colbanet for years without any problems. I've tried many different regions and countries but it doesn't make a difference.

    I didn't think it could be a Windows problem, because the same thing happens when I use the PIA Android app on my tablet, but this morning ran the Windows Network Diagnostic troubleshooter. I got "Troubleshooting couldn't identify the problem". Detailed information said "No issues detected".
  • Posts: 273
    Ha, too bad I just finally got rid of my Bell connection :/ Pulling 200 Mbps here no problem from Videotron around Côte-des-Neiges to Montreal, Toronto and US East/NYC servers, so it sounds like it's Colbanet having trouble (the line is leased from Bell but the data goes to reseller's closest datacenter at which point they're responsible for the traffic). Never had any trouble with PIA on Bell's lines either, had no problem pulling 300+ Mbps from my fiber line before I moved or 50 Mbps from their crappy VDSL.
  • Posts: 34
    What I've tried:

        Bypassed the router and connected the modem directly to the computer. No change, TCP works, UDP doesn't.

        Connected an old modem I had directly to the computer. Again, no change, TCP works, UDP doesn't.

    So it's not a problem with the router or modem (unless both modems are screwed up in the same way).
    It can't be a Windows setting, because I have the same problem with my Android tablet when I use the PIA app.
    That leaves either PIA, or my ISP. Can an ISP block UDP connections (and why would they?)? I've never had any connection problems with my ISP before.
  • Posts: 273
    I really have no idea why they would do that. Have you tried contacting them and asking about it? Sounds against CRTC's rules to me as well...

    Do you know if it's just PIA that doesn't work with UDP, or if everything UDP is broken as well? Technically DNS is over UDP but has a TCP fallback, otherwise Chrome uses UDP a lot with their new QUIC protocol (but it's optional and also falls back to normal HTTP/2 or HTTP/1.1 if needed).

    If you want to run a big test you can always run Netalyzr, it will tell you everything suspicious your ISP might be doing and that should include UDP connectivity.
  • edited October 30 Posts: 34
    I installed Netalyzr on my tablet. It runs all the tests and then I get "Gathering results for fetchakamizedicon" and it stalls there. I tried a few times. The last time I left it for 30 minutes. It never showed me the results. When I restart it, I can choose between  "New Test" and "Prior Results". Prior results is blank.
    Post edited by Stan77 on
  • edited October 30 Posts: 34
    I installed a free VPN app on my tablet. It's not very configurable, I couldn't switch between TCP and UDP. But with it on, I had the same problem I've been having with PIA's app - no Internet access. I then installed a free VPN on my PC. The default for this VPN has UDP enabled, and if you're having connection problems they have a "TCP Override" where you can switch from UDP to TCP. I couldn't connect to anything using UDP. When I used the TCP override, I was able to connect. So, it looks like my ISP is blocking UDP connections.

    I guess my next move is to contact my ISP and ask them why they're blocking UDP. Before I do I'd like to have some kind of proof that they are blocking UDP connections (they might deny it). For me, the VPN problems are enough proof, but my ISP might disagree. If I could get Netalyzr to work, I could use its' results, but it doesn't seem to work. Does anyone know of a similar program that'll check and be able to tell me whether or not my ISP is blocking UDP connections?
    Post edited by Stan77 on
  • Posts: 273
    I think this should be sufficient. The Netalyzr would help for sure but really I'd just say that you have tried multiple applications that uses UDP and they all either use their TCP fallback (which affects performance, especially in VoIP applications) and that your main use of UDP, a VPN, is also affected by this. You can say that you have confirmed with us that you have no UDP connectivity. You can also prove your computer isn't the issue as UDP likely starts working just fine once connected to PIA over TCP.

    If you really want to go all in and you're willing to download a Linux image to put on a USB stick or DVD I can set up a UDP echo server and have you run a bunch of commands to get a tcpdump from both ends. But I seriously doubt their support will understand a word of it regardless, and at this point I think you'll lose them more than anything else. If they're receptive to there being an UDP issue I don't think they'll ask for proof, they'll just report it to the engineers who will run some tests or confirm it, otherwise they'll just deny there being an issue because they won't understand it.  If it's anything like Bell, they'll ask you if you can load YouTube or Facebook and conclude everything is alright because apparently that's all there is to the Internet for them... You probably could send them to this thread if they want to see your proof. I can give you my email if you want just in case.
  • Posts: 34
    Thanks for your help, Max-P.
    I've contacted Colba's technical support using a form on their website. I explained about the UDP problem and the things I tried, and wrote that they must be blocking my UDP connections and asked why. Hopefully I'll get a reply some time tomorrow (their technical support is closed for today). If I don't hear from them tomorrow, I'll call them on Wednesday.
  • Posts: 34
    I haven't received a reply from Colba's technical support yet, but this morning everything's back to normal and I can connect using UDP. I guess someone in Colba's technical support read my complaint and fixed the problem. Of course, it could be a coincidence - maybe they'd known about the problem and were working on it, but I kind of doubt that.
Sign In or Register to comment.