Disconnect and reconnect to PIA problem

If I disconnect from PIA and then try to connect again, PIA will connect, but it's as if I have no Internet access. The Windows network Internet access icon shows I'm connected, but it's as if I'm not. I ran Windows Network Diagnostics while PIA was connected, and it says that the DNS server isn't responding. Detailed information says "Your computer is trying to use a DNS server that is incorrect or doesn’t exist". Exiting from PIA and starting it again doesn't solve the problem. While disconnected from PIA, Internet access is normal. The only way to reconnect with PIA is to restart the computer. The PIA connection will then be fine, as long as I don't disconnect and try to connect again. I uninstalled PIA and the TAP Windows adapter, and reinstalled PIA, but that didn't fix the problem. I don't know if this has anything to do with the UDP problem I had a few days ago (which has been resolved), or is something completely different.

Comments

  • Posts: 266
    Hmm, that's an interesting one again you have there!

    Can you visit http://167.114.206.88/ when the issue is happening? That will tell us whether PIA works at all or if it's just the DNS that's being weird.
  • Posts: 34
    I disconnected from PIA, reconnected, and I was able to get to http://167.114.206.88/ without any problem. But, then I couldn't go anywhere else. If I tried with Edge, I got "Can't reach this page", with Chrome I got "There is no Internet connection". I ran the network diagnostics again, and got the same DNS error result as before.
  • Posts: 266
    Alright, so it's definitely a DNS issue at least so there's no point trying anything that's not DNS related.

    Can you try setting your DNS to PIA's DNS and see if it helps? Just a heads up: this may flip the issue the other way, so if it does you can simply set it back to automatic and reboot to revert.
  • edited November 2 Posts: 34
    My DNS settings were set to "obtain DNS server address automatically" so I changed that to PIA's. That didn't fix the problem, but I think I discovered what the problem is. I had PIA's DNS leak protection on. When I shut it off, I was able to disconnect and reconnect to PIA and my Internet connection worked normally. With PIA's DNS leak protection on, if I disconnect and reconnect to PIA it's as if I have no Internet connection. That makes me think that there's something screwed up with PIA's leak protection...

    I also discovered that if I have my DNS set to "obtain DNS server address automatically", with PIA's DNS leak protection off, if I do the extended test at this website: https://www.dnsleaktest.com/ it finds my ISP. With my DNS changed to PIA's, with PIA's DNS leak protection off, it only finds PIA's servers.

    I'll leave leak protection off, and leave my DNS set to PIA's DNS server. That's fixed the problem (for now, anyway).
    Post edited by Stan77 on
  • Posts: 266
    Yeah, setting PIA's DNS is pretty much redundant with DNS leak protection, so if you have set PIA's DNS manually and you don't leak it's safe to leave DNS leak protection off. All the leak protection does is set additional firewall rules to make sure that DNS never leaks even if incorrectly configured. It should definitely disengage upon connecting however so that's the odd part. But if it works this way I don't see any issue leave DNS leak protection off as long as you have PIA's DNS set manually!
  • Posts: 34
    Maybe it's some Windows setting somewhere on my computer that's making PIA's leak protection screw up. But with the leak protection off, and using PIA's DNS settings, things are back to normal, so that's okay. Anyway, Max-P, thanks for the help.
  • Posts: 34
    Changing the DNS to PIA's DNS servers fixed the problem where I didn't have Internet access, but I've discovered something. I put on my computer and connect to PIA. I go to this website: https://www.iplocation.net/find-ip-address and it shows the PIA server. I disconnect from PIA and then reconnect to PIA. Everything looks fine, PIA's icon shows that I'm connected to one of PIA's servers. I go back to that website, and it doesn't show PIA's server, it shows my ISP. I've tried this with a few different cities ( Montreal, Toronto, New York, Texas, Ireland, Hong Kong). Each time PIA's icon shows that I'm connected to one of PIA's server for that city, but the website shows my ISP.

    I wonder if this is happening to others who believe what PIA's icon is telling them - that they're connected to PIA and they actually aren't.

    I can't see how this could be a problem with my computer, wouldn't it have to be a problem with PIA?
  • Posts: 456
    You didn't mention this but did you close your browser after disconnecting from PIA. Then when you reconnected, open a new browser session? I notice that when I engage VPN and I have my browser open it is still connected to my ISP. Not sure how that happens but it does. So when engaging your VPN, you have to restart browsers, email, and whatever apps you are running.
  • Posts: 34
    I never had to close and restart the browser before.

    I usually connect to one of PIA's Montreal servers, because they're fastest for me. Sometimes I'll be at a website with a video I'm not able to watch because of my location, so I'll disconnect from the Montreal server and connect to a New York server. I refresh the browser page with the video, and then I can watch it. That's what I did this morning, but wasn't able to watch the video, I still got the message saying the video couldn't be played because of my location. So I went to that IP location website, and that's how I found out that I wasn't connected to PIA's server, even though the PIA icon showed that I was.

    I disconnected from PIA, closed the browser, reconnected to PIA and opened the browser. My ISP showed. I closed the browser, disconnected from PIA, reconnected to PIA, opened the browser, my ISP showed. I'd been using Edge, so opened Chrome. I hadn't used Chrome at all today. It showed my ISP... I tried exiting PIA and reopening it and connecting, but same thing. PIA shows I'm connected to one of it's servers, but I'm not. The only way to get connected to one of PIA's servers is to restart the computer.
  • Posts: 266
    @Stan77 Can you submit a debug log and give us the log ID? That's definitely not normal, something must be going on with OpenVPN under the hood.
  • Posts: 34
    Before doing that I thought I'd give uninstalling  and reinstalling PIA another try, so I did. It didn't fix the problem. I've submitted a debug log. The log ID is A3813.
  • Posts: 266
    Your debug log contains the following error:
    Warning: route gateway is not reachable on any active network adapters: 10.82.10.5
    That means that OpenVPN is failing to find out which interface and gateway is the correct one on your system. Try resetting your network settings with this guide and see if it helps. If it doesn't, make another debug log so we can see what changed and what stays!
  • Posts: 34
    I reset my network settings like it said in that guide. The problem remains. I sent another debug log, ID 6BE16.
  • Posts: 34
    Last night the problem continued even after resetting my network settings as described in that guide. I didn't check earlier today, but just checked now, and everything's back to normal. I've switched around to a few different PIA servers in different cities, and each time, when I checked my IP address, it showed PIA's servers, not my ISP. I haven't changed anything on my computer since yesterday when I reset the network servers, so I don't know why it's working now and wasn't last night. Hopefully it'll stay this way.
  • Posts: 456
    Just curious, which version of Windows are you using? And which browser?
  • Posts: 34
    Windows 10, Fall Creators Update. I don't think the problems were caused by the Fall Creators Update because I've had that installed for over 2 weeks now and the problems only began a couple days ago.

    I use Edge, but when the problems began I tried using Chrome. Had the same problems with Chrome, so tried Opera. Same problems with Opera.
  • Posts: 266
    One thing I'm aware of with Windows 10 is that sometimes I need to fully restart the browser in order for it to pick up the VPN (unless the killswitch is enabled, that option seems to force the OS to refresh everything). Have you tried closing your browser after reconnecting and then use an private browsing window to check your IP? That way it will eliminate that possible issue as well as any caching that might have happened.
  • Posts: 34
    Opening the browser in a private browsing window when it happened is one thing I didn't try. So far it's been 3 days and the problem hasn't reoccurred, so I'm hoping it's gone for good. If it does happen again, I'll try closing the browser and opening it in a private window.
Sign In or Register to comment.