Changes to the kill switch/local network UPnP

edited November 4 in Windows VPN Setup Posts: 2
Apologies for the 'meh' title, I have been using PIA for over 2 years and never had much problems, but lately after updating to v75 I've been having problems with the kill switch and the connection between my computers on the same network, so maybe they are linked. Has anything changed between v72 (I think it was working fine) and the current version? It seems that after a while everything gets disconnected (for example if I mount a disk form Computer A on Computer B ), and disabling the kill switch seems to solve it partially (it gets better but it's still not as before where I could have a working connection between all my computers for weeks, even if the VPN connection went down for a while).

I have 3 computers on Windows, Mac OS and Linux, all running the PIA app, but I can also say I have no idea how networking works so the fact that I can somehow access them all when working from one or the other, even though I'm sometimes connected to different places, eg Italy, US and Japan, has always been a mystery. It's a bit annoying, nothing that would make me cancel my account or anything, but I'd like to know if that's normal before I consider downgrading everything to a previous version.
Post edited by Rt_gh3 on

Comments

  • Posts: 265
    Does it seem to affect one OS in particular more than the others? On Mac and Linux the killswitch uses the firewall and essentially blocks everything that doesn't go through the VPN. On Mac, it always blocks local networking. On Windows it shouldn't have any effect as the killswitch works by removing the default gateway from the network settings instead.

    I'm not aware of any of the above being changed in a long time, and definitely not between v72 and v75. If you downgrade back to the known working version, v72, does the issue persists? You can find the old downloads here.
  • Posts: 2
    Thanks for the answer, I reverted to v72 on Windows and it works like a charm with the killswitch, so there's something going on with the next versions.
    I'm keeping the v75 on Linux and I've discovered that with the killswitch on, pinging a local IP results in an error, as well as `mount //local_share`. It's strange because I'm pretty sure I've done that on previous versions and it worked out of the box.
    the same on MacOs works, but tis is v72 or even v71, I can't check right now. So it's strange that you say killswitch blocks everything local because I've never had any problem before, even if it was just using mount/smb to access my Windows drives.
    Anyway, I'll keep it that way for now, unless there's some critical fix that requires an update.
Sign In or Register to comment.