Mac OS Graphics Switching

I know for a fact this question has been asked and answered in the past, but that solution is obsolete. 

I have 2 Core i7 mid-2010 MacBook Pro systems that I need to administer. These models have discrete graphics (GT 330M) and integrated Intel HD Graphics. The current (v75) PIA app switches to the discrete graphics card as soon as it starts, and doesn't switch back to integrated graphics until the app is completely closed.

I use gfxcardstatus v.2.4.2i to keep an eye on what card is in use, and if discrete what program is calling on it. It says the program is "pia_nw". 

There was a solution on this forum, but it applied to v60. It is located at https://www.privateinternetaccess.com/forum/discussion/21741/v59-causes-permanent-discrete-graphics-switching-on-older-macbooks. As far as I can tell, between v60 and v75 there were major changes in the app, including how it stores files and patches (apparently a lot changes across 15 versions lol). 

I use my VPN at home a lot, but for me it is a necessity when travelling, especially where there are unsecured open public hotspots. These are also the times when these computers are more likely to be running on battery power.

When PIA starts, discrete graphics start, and the laptops become power hungry fire breathing monsters with very little stamina. My battery lasts half as long using PIA, compared to if I decided to forego my privacy and use an open hotspot.

Is there a way to "patch" v75 in the way that v60 had a "patch" made up in the forum I posted above?

MacBook Pro mid-2010
Mac OS Sierra 10.12.6
PIA v75

Thank you very much...

OR

Or if this has been answered and it turns out I am just another idiot who doesn't know how to use a search box on the forums, I am very sorry.
Tagged:

Comments

  • Posts: 266
    Hmm, that's odd. Something else must be triggering the switch to the discrete graphics because the solution in the linked thread has been included in the app for quite a while now. I just checked with v75 and it still includes the --disable-gpu --disable-transparency flags.

    I have sent this to QA to see if we can reproduce and come up with a new fix for this, but in the meantime you can try using Tunnelblick while on battery to avoid draining your battery.
Sign In or Register to comment.