Can't get PIA program to work on Windows PCs after restarting computer

I have the latest version of PIA's program for Windows installed on two PCs: one is running Windows 10 and the other Windows 8.

After installing the program "as administrator" on both, the program will work fine until I restart the computer.

On the Windows 8 PC, I can't get PIA to run again after restarting the PC (it won't show up in the tray, and when I try to run it manually, nothing happens when I click on the program to run it).

On the Windows 10 PC, PIA won't show up in the tray after restarting the computer, but when I click on the program manually, then it will start running properly and show up in the system tray ... until I restart the computer again.

How can I get these to work properly so they always run when my PCs start up and why won't PIA work at all on my Win 8 PC after 1 restart?

Comments

  • Do you by chance have these devices running in a language other than English?

    Also, please be advised that unless you meant Windows 8.1, we have very limited support for Windows 8, but we'll try to help as much as we can!
  • Posts: 8
    Do you by chance have these devices running in a language other than English?

    Also, please be advised that unless you meant Windows 8.1, we have very limited support for Windows 8, but we'll try to help as much as we can!
    No, the devices are only running in English. Also, yes, you're right, the one PC is running Win 8.1 not 8.0.
  • Posts: 453
    I would check SERVICES on both computers. On the Win8.1 machine,
    1. press the Windows key + the R key. That will open  the RUN command.
    2. In the space provided, enter services.msc and press enter.
    3. When the services window opens, scroll down until you see PIA. It should be RUNNING and also set to AUTOMATIC.
    4. If it is set to MANUAL, then double click on the service and change to AUTOMATIC.
    You can do the same for the Win10 machine. If they are both already set to RUNNING and AUTOMATIC then we will have to look elsewhere.


  • Posts: 8
    I would check SERVICES on both computers. On the Win8.1 machine,
    1. press the Windows key + the R key. That will open  the RUN command.
    2. In the space provided, enter services.msc and press enter.
    3. When the services window opens, scroll down until you see PIA. It should be RUNNING and also set to AUTOMATIC.
    4. If it is set to MANUAL, then double click on the service and change to AUTOMATIC.
    You can do the same for the Win10 machine. If they are both already set to RUNNING and AUTOMATIC then we will have to look elsewhere.
    On the Win 8.1 PC, I went into services, and PIA was not listed. And even after I clicked on PIA in my programs menu, it was still not listed in the services window. I will check the Win 10 PC later.
  • Posts: 453
    OK... it would appear that old age has set in officially. LOL

    It is not SERVICES but TASK SCHEDULER that we should be looking. So sorry about that. I guess one reason is because I use OpenVPN and not the PIA App. I have uninstalled the OpenVPN application and went back to the PIA Manager. So I should be able to "see" what is where.

    You want to open your TASK SCHEDULER. It is basically the same process as above.
    1. In the RUN command just type taskschd.msc and hit enter.
    2. When the Scheduler window opens, you may not initially see the available tasks.
    3. Double-click on the Task Scheduler Library and all the current tasks should be displayed.
    4. Look for the Private Internet Access Startup. It will probably be on the very bottom.
    5. Mine says Run whenever user is logged on or not, and Run with highest privileges.
    Again, sorry for sending you on a wild goose chase.

  • Posts: 8
    Ok, did that on the Win 8.1 computer and the PIA entry shows up.

    In the top window it says: "Run at log on of any user"

    In the bottom window, it is checked (and grayed out so can't be changed) and says "Run only when user is logged on" and it is checked for "Run with highest privileges."

    When the computer starts up, we have it set so we don't log on at all (no password). Could that be the problem and how do I change the entries in the task scheduler. It's not letting me change it to "Run whenever user is logged on or not" like yours does?

    -------------------------

    For the Win 10 PC it is working now on startup most of the time, and if not, I can click on the PIA app and it starts up properly.


  • Posts: 453
    In the Scheduler it can be either way for running when login, so I would leave it. My PC is also set to run without me entering my password so I do not see that as an issue. If on the Win8.1 machine you are still having an issue, I would reinstall the PIA Manager. I have done this several times but not for the reason you outline. I do it to see if I can break it. :)

    To uninstall, follow these steps here: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219498647-How-do-I-uninstall-reinstall-the-PIA-app-on-Windows-

    Then when you go to reinstall, right-click on the installer and then Run as Administrator.

  • Posts: 8
    In the Scheduler it can be either way for running when login, so I would leave it. My PC is also set to run without me entering my password so I do not see that as an issue. If on the Win8.1 machine you are still having an issue, I would reinstall the PIA Manager. I have done this several times but not for the reason you outline. I do it to see if I can break it. :)

    To uninstall, follow these steps here: https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219498647-How-do-I-uninstall-reinstall-the-PIA-app-on-Windows-

    Then when you go to reinstall, right-click on the installer and then Run as Administrator.

    I tried all that, uninstalling and reinstalling, followed the instructions to a T, and still upon restart, the PIA app doesn't show up in the tray and when I click on it in the programs folder, nothing happens.

    Any other ideas? Is there any chance Avast, which I have on both PCs, could be blocking it?
  • Posts: 453
    Yes, there is always a chance that Avast might look at the application as a PUP (Potential Unwanted Program). Also your firewall could be treating the application as a PUP.

    If this were me, I would turn off my Wifi so there is no connection to the internet. Then I would turn off my AV and Firewall. Reboot the system so neither AV or Firewall start and see if the PIA app opens.

    Other than that, I am at a lost. I use an HP machine, Comodo Firewall, MalewareBytes AV, Win8.1 and have no issues. There must be something in your system that is stopping the app from opening.
  • Posts: 8
    Yes, there is always a chance that Avast might look at the application as a PUP (Potential Unwanted Program). Also your firewall could be treating the application as a PUP.

    If this were me, I would turn off my Wifi so there is no connection to the internet. Then I would turn off my AV and Firewall. Reboot the system so neither AV or Firewall start and see if the PIA app opens.

    Other than that, I am at a lost. I use an HP machine, Comodo Firewall, MalewareBytes AV, Win8.1 and have no issues. There must be something in your system that is stopping the app from opening.
    Tried all that and still no luck getting the PIA program to run on my Windows 8.1 PC. Anything else you can think of that would keep it from running when the PC is restarted? And it still won't run when I try to manually start it by clicking on it.
Sign In or Register to comment.