Sometimes recently I find that PIA is suddenly just gone from a system. (Win10 Fall Creators update)

I think it began after the computer updated to the latest Windows 10 Fall Creators Patch, but I'm not entirely sure. It's a quite recent thing anyhow. The system is running Kaspersky Free but there's no note in any log about a problem and it has never notified me of one. The VPN runs fine when used on the system, but sometimes it just disappears like if it had uninstalled itself. It can be running one day and just be gone the other. The foder "pia_manager" is gone.

Installing the PIA client again works just fine, and the system can be rebooted without the issue ocurring. Other programs I'm using have not been affected. The client is not set to start automatically at boot.

In case it might matter, the system TEMP folder resides on a RAMdisk and is thus emptied on every reboot. But as said, just rebooting the system does not trigger it when i try that.

I tend to solve my own software/system problems but this one has me bewildered.

Comments

  • Is your OS in English? There's a known bug that can cause similar symptoms.
  • KazKaz
    Posts: 4
    Yes it's in English and I don't have any trouble starting the program as long as it hasn't disappeared from the drive. Thanks for the tip anyway.
  • Ah, yes, I see now that your temp directory is on a RAMdisk. If it's anywhere but C:/, there's a good chance Ruby cannot find it. I'd suggest relocating the temp folder to C:/ to see if the issue persists. 
  • edited November 2017 Posts: 1
    HI, Having a similar issue, since Windows 10 Fall Creators Update rolled-out I could not run PIA. I unsinstalled, and downloaded the latest version v75, rebooted and tried to reinstall (Admin) to no avail, the install starts open a CMD window (I only had time to see <complete> or <completed> Tried with v74, v73, v72 & v71 same result.
    My OS is English.
    Found this workaround in another thread: https://www.privateinternetaccess.com/pages/client-support/windows-openvpn
    That works. How can I get PIA to operate properly?
    Ticket #482437 Openned
    Any ideas?
    Thx, Z
    Post edited by Zenkis on
  • KazKaz
    Posts: 4
    Just adding that I have not had that happen again. One thing I did that could possibly have helped is to run the Task Scheduler and add a small 15 seconds delay to the trigger of the task Private Internet Access Startup that normally executes at the login of the user. In the case that anyone might encounter the problem in the original post then this might be worth trying out.
Sign In or Register to comment.