PIA setup ruined XP Internet connection

My wife ordered PIA vpn from her XP desktop. I copied the PIA download to my W7 machine and installed PIA. I only want the W7 computer to use the vpn. PIA vpn seems to work fine one  my W7 box.

The XP computer internet connection is now screwed up. To my amazement I found PIA vpn "software support" had been installed on the XP computer! How is that possible? It seems to be trying to connect to the internet through my W7 computer but ICS is not running (not even listed) under XP services. In the XP  Network connections' window there is a new connection called "Internet Connection" along with my regular connection that is supposed to connect to the Internet (as well as other computers on my Home network). My LAN works fine but the new 'Internet connection' seems to be the one trying to connect through my W7 computer. My W7 computer shows ICS set to "Manual" start but not running. I uninstalled the 'support' software and tried every combination of repairing and disabling.

Can someone help me restore My XP computer connection?

Comments

  • Does anyone know if PIA automatically searches for LAN computers to install software? Or what changes it makes?
    Thanks
  • Posts: 453
    Not that I am aware of. All PIA does is interface to OpenVPN. The app give access to configuring the OpenVPN connection but other than that, no.

    From the PIA website: "Private Internet Access cannot offer technical support for Windows Server 2003, Windows XP, Windows Vista or Mac OS 10.4 through 10.7. This is due to potential security issues that could be present in these un-maintained operating systems which will no longer be addressed by the respective manufacturer."
    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219332588-What-operating-systems-are-supported-

    Might I suggest that you install OpenVPN on your XP machine. This from OpenVPN. "OpenVPN runs on:

    OpenVPN runs on Linux, Windows XP/Vista/7 and higher, OpenBSD, FreeBSD, NetBSD, Mac OS X, and Solaris."
    https://openvpn.net/index.php/open-source/341-openvpn-compatibility.html

    With OpenVPN you still have PIA access but not all the options in the PIA Manager. You will have to do some configuring. If you are interested, PIA has a webpage on how to configure OpenVPN.
    https://www.privateinternetaccess.com/pages/client-support/windows-openvpn

    You shoud read the procedures before starting.




  • Thanks for the tip, Omnibus_IV

    I never intended to use PIA on the XP machine and I uninstalled the PIA files that were mistakenly(?) put there. What I want to do now is get my XP computer up and connecting to the Internet again. (without PIA)
    I couldn't find OpenVPN to uninstall on the XP machine .

    Do you know if the PIA installation opens Internet Connection Sharing for branch computers on a home network? Or how to delete (remove) the new Internet Connection that PIA installed?

    Thanks Again
  • Posts: 453
    Unfortunately I do not. The last stable OpenVPN for Windows XP was 2.3.16.

    I would think that maybe if you reload the drivers for your NIC card that might restore its operation. If you do not have your disc with the drivers you will have to go the manufacture's website and download them. Be careful when doing a search for the drivers. You may end up on some third party site that will also load a ton of crap on your machine.
  • I'll check into that, thanks
Sign In or Register to comment.