PIA is interfering with AMD Settings at boot

ELFELF
edited November 17 in Windows VPN Setup Posts: 2
Hi and like the title sais. PIA is somehow interfering with the AMD Settings application at boot.
I'm getting the following error (RadeonSettings.exe - Application Error 0xc0000142).
It works perfectly fine though if I start it manually. So it's only when it autostarts at boot that it fails to start.

I made a fresh install of Windows 10 on a bigger SSD but kept getting an error message about that AMD Settings could not start no matter what I did. I reinstalled Windows to be sure it wasn't anything faulty with the Windows installation. The problem came back. So I did another reinstall of Windows. This time I restarted the pc more times than I have hairs on my head just to be sure that it wasn't a setting or something in Windows that caused the problem and it all went fine. I started installing application after application while also restarting the pc between EVERY installed application. When I finally had installed PIA (v72) and restarted my pc, the error popped up again. I uninstalled PIA and AMD Settings were able to start at boot. I downloaded the latest version of PIA (v75) just now and installed that. Same thing here, error message. Uninstalled it and the error message was gone and AMD Settings could start at boot.
I've tried a couple of AMD GPU driver versions with the same result.

I've never been good at writing stories, so sorry if your brain hurts after reading this...... :D

Anyway, wether PIA or AMD is the problem, I gotta start asking and reporting the problem somewhere.

Post edited by ELF on
Tagged:

Comments

  • ELFELF
    Posts: 2
    Never mind. Seems it's all on AMD. It's random if I'm getting this error message or not upon boot. I don't have PIA installed at the moment.
Sign In or Register to comment.