Kill Switch does not work if PIA client is closed or crashes - not a problem with older versions

I'm running Windows 10. When I boot up, the computer is able to connect to the internet while it waits for the PIA client to start. Once the client starts, the internet connection is disabled until the client connects, at which point the internet connection is restored. In previous versions (maybe around the low 60s), this would not be the case. The computer would not connect until the PIA client connected. I did see discussion of this and possible work-arounds (though they are a bit outside my skill level) here - https://www.privateinternetaccess.com/forum/discussion/comment/52581

However, this problem is worse. If the PIA client is closed, the computer can again connect to the internet without going through the VPN. What makes this disastrous to me is that when the PIA client crashes (and it does crash every few weeks), the kill switch stops working and I'm again connecting directly through my ISP, exposing my IP address.

I've been using older versions hoping that this will be corrected with each new release, but it's been a while now. Any suggestions?
Tagged:

Comments

  • Hello @Max87624987467

    I am sorry to hear that you are having issues with our application and the kill switch not properly working when your application is closed. 

    First I want to know if when your application is closed are you fully connected to the VPN? if you are connected then here is a way to create a rule in Windows that will prevent your system from allowing any internet traffic when a PIA VPN connection has not been established. 


    Change the Main Network Adapter to Private and Lock the Setting:

    1. Press Windows Key + R.
    2. Type control.exe /name Microsoft.NetworkAndSharingCenter.
    3. Use this window to determine the name of your network.
    4. Press Windows Key + R.
    5. Type secpol.msc(Please note, this is only present on Pro versions of Windows and attempting to add secpol.msc to an operating system is not advised.)
    6. Click on Network List Manager Policies in the left pane.
    7. Double click on the name of your network in the right pane.
    8. In the Network Location tab change the Location type to Private.
    9. Also in the Network Location tab, change User permissions to User cannot change location.
    10. Click Apply.


    Open Windows Firewall with Advanced Security - This is where most of the changes are performed:

    1. Press Windows Key + R.
    2. Type wf.msc.


    Backup Current Firewall Policy:

    1. Click Action on the menu bar.
    2. Click on Export policy....
    3. Choose a save location.


    Create an Outbound Firewall Rule:

    1. Select Outbound Rules on the left.
    2. Click New Rule... on the right.
    3. In the center window, select the Program radio button.
    4. Click Next >.
    5. Type or browse to the program path %ProgramFiles%/pia_manager/openvpn.exe.
    6. Click Next >.
    7. Select Allow the connection.
    8. Click Next >.
    9. Select all check boxes, DomainPrivate, and Public.
    10. Click Next >.
    11. Name the rule, PIA_Outbound_All.
    12. Click Finish.


    Block all Connections for Private and Domain:

    1. Select Windows Firewall with Advanced Security on Local Computer on the left.
    2. Select Windows Firewall Properties.
    3. In the Domain Profile tab, set Outbound connections: to Block.
    4. In the Private Profile tab, set Outbound connections: to Block.
    5. Click Apply.
    6. Click OK.


    If this does not work, or you need to step back to the beginning of editing firewall policies, you can either:

    Use Action > Import Policy... to restore from the backup file you created.

    or

    Use Action > Restore Default Policy to restore the default firewall settings for Windows.


    Please let me know if there is anything else I can assist you with.


Sign In or Register to comment.