ISP speed upgrade made no difference in VPN speeds - PIA Speed Cap?

I recently upgraded my service with my ISP to the fastest they offer. So I tested the speed to see what difference the upgrade made.
The rated speeds pre- and post-upgrade are 300Mbps and 1Gpbs respectively.

Speedtesting at without PIA, pre-upgrade - 220 to 330Mbps
Speedtesting at without PIA post-upgrade - 650 to 890Mbps

Speedtesting at with PIA, pre-upgrade - 130 to 190Mbps
Speedtesting at with PIA, post-upgrade - 130 to 200Mbps

It definitely made a difference when I'm not using PIA, (though I've never actually seen it hit 1Gbps) but with the VPN on the speed is almost no different from my old connection. Does PIA cap speeds at 200Mbps? Is that all the servers can handle?


  • Posts: 848
    The servers are definitely capable of handling that much! I've personally seen 600-700 no problem on the VPN, but that requires to have a really good ISP. There's unfortunately a lot of ISPs offering very fast speeds but those speeds drop a lot when going outside of their network/outside of the country.

    But before going for that conclusion, it would be wise to check if the issue is not on your computer first! Do you happen to use Windows? There seems to be a bottleneck with VPNs on Windows somewhere I haven't been able to identify yet that seems to affect every protocols. All my Linux boxes and VMs have absolutely no problem saturating my connection but none of my Windows machines nor VMs can, usually only getting 50-75%.
  • edited December 2017 Posts: 4
    I live within the same city as a PIA server (US West). Though, any server in North America seems to get roughly the same results - only trying a server across the world actually seems to slow it down.
    At any rate, I do happen to use Windows (you have very little choice if your main reason for using a computer is video games), though I'm getting less than 33% of my non-VPN connection at the best of times.
    Post edited by Toad_004 on
  • Posts: 848
    Would booting into a Live Ubuntu environment from a USB stick or DVD (no need to install anything) be out of reach for you? You could simply try installing the app in the live environment and see if the speeds are any better.

    Not that it would be a permanent solution but would confirm whether or not you're hitting the Windows bottleneck I'm researching. At least you'd know.

    The problem seems to be with OpenVPN itself, if not Windows. None of the VPN options including PPTP and L2TP which are Microsoft technologies yield any more than 150-ish Mbps. About in line with your 130-200 range. I have a 200 Mbps line and get 200 Mbps on practically anything except Windows.

    I still need to do a lot of research on my end and set up a local OpenVPN server with real hardware to fully understand what's the problem.
  • edited December 2017 Posts: 4
    Well, that was quite an adventure, I must say.

    Made a USB drive for Ubuntu, and it wouldn't boot. I thought it was the drive, so I tried with 3 more. Turns out Ubuntu doesn't like my GPU and I needed to use nomodeset or something... ugh. Finally got Ubuntu to boot and now it doesn't like my mouse. Gotta find my backup mouse, which hasn't been used in months so it needs a new battery. UGH. Edit: I later found out that I'd knocked a usbhub lose while switching all those USB drives, which was causing the mouse issue. It's still 100% true that Ubuntu has a grudge against 1080tis (and/or vice versa). Then I found out that I don't know how to install programs in Ubuntu. Gotta learn to use that terminal until I manage to get it to install PIA. UGH.

    : :s

    Well at first it seemed much of the same - I was hitting 900+Mbps without PIA, but then again it's after 2 am here, so that's not surprising that it's faster than normal. with PIA however hit 200 Mbps over and over again, like some kind of wall (it would sometimes show 210 or 220 for a brief moment before slowing down, which it never did on windows). Just to see if there is something specific with, I try to compare. No difference without PIA... but with PIA it hits 650Mbps?! WHAAAAAAAT? And yes, I have tested on in Windows with PIA, and it never makes it much past the low 170s.


    So, its possible that either my ISP or Netflix (more likely the latter...) might be throttling VPNs to but getting a 650Mbps on speedtest in Ubuntu (when that's outright impossible on Windows) means there might indeed be something in windows capping VPNs.
    Post edited by Toad_004 on
  • Posts: 848
    Thanks for your adventure! Sorry for the trouble: I use desktops so my hardware has always been fairly Linux-friendly. Didn't expect you'd end up needing nomodeset on Ubuntu, that one usually just works :/

    It's the only way I can think of that really undeniably shows there's something specific to Windows. It sounds like a hard to believe excuse until you have it in front of you. It's "known" but I can't find any real documentation as to what exactly causes that.

    I'm very busy lately but I plan on digging into the code and see if I can do anything with it for PIA. The only suggest fix (large MTU) is kind of a band aid and can't work over the Internet so it's not any use for public VPNs like us.
  • From my experience using the dutch hub some PIA IPs are limited to around 200 mb/s but if you shop around (reconnect to get on another IP) you will eventually get a connection in the 600-800 mb/s range. (Talking upload here,I have an odd 200 mb down/1000mb up connection)

    On that note a question to Max, I'm not sure 200 mb/s can be called slow so I haven't ever reported it as a slow server. Should I?
  • Posts: 1
    Since this is something that I have been having issues with also I will post here instead of starting another one and hopefully this will be the best place.
    I am happy that I have fiber up and down of 1G and my speed test have been wonderful as I usually get 950Mbps down and have topped speeds of 1.07Gbps up.
    I am running a windows machine that you can see will handle these speeds.

    I decided I needed to get a vpn and in testing I have done about 20% of my overall speed. I have tried booting Ubuntu and some others where testing was very common for normal and using PIA, this was also with different servers.
    I have tried other settings I have found that people said helped them and had no luck
    I have turned off data encryption and authentication and tried every handshake and all my results have been pretty close
    (you would think with those off there should be no reason for slow down, is it still using the TAP driver when turned off?)
    I have done the speed test from three different sites to have a better average, again I get common results
    I even reformatted and reinstalled everything fresh and still the same
    PIA is run from my computer and not from my hardware as I read where doing this through my router could be slower.

    In last from talking with support it would seem that the TAP driver is not written to handle the higher bandwidth and info has been submitted to the developers but there is no more info from there.
    Support has been a big help in trying to keep me informed and other things to try so Kudo's to them.

    I did get some increase when I enabled "use small packets" but still very slow compared to PIA disabled.
  • Posts: 4
    @MeFirst Heh. My upload is between 33 and 37 no matter what PIA server I connect do, or don't connect to.
    Then again, It's only supposed to be 30Mbps up. Don't know why it's always a little more?

    @gator81 ; the TAP adapter is the cupurt, you say? Well let's take a look...

    Sorry about the 4k Picture with tiny text(tm), but if you'll look at "link speed" it says it only has 100 Mbps, meaning that the tab adapter isn't a gigabit connection, hence the speed limit with PIA. Not sure why the speed limit is 200 rather than 100 Mbps, but the signs seem to point to the adapter being the problem.

    Uh, the one that says ignore isn't actually plugged into anything at all - my motherboard has two gigabit Ethernet ports for... some reason, and that's the one not being used.
  • Posts: 848
    @Toad_004 The link speed (100 Mbps) is only ever used for display. It has no meaning whatsoever as to what speed you will actually get. The TAP is a virtual adapter, it doesn't have a physical link speed underneath it. It just needs to report something to make Windows happy. I have a custom build of the TAP that's set to 10G and it didn't make any difference as expected.

    The limit is purely a bottleneck due to the way the code is written. There is no arbitrary limit or settings to change that would make it faster. It is directly dependant of your CPU's performance. My suspicion of the problem so far is that packets are passed individually between the TAP driver and OpenVPN, which results in lots of syscalls which are inherently slow. The fix is theoretically to exchange larger chunks of data between kernel mode and userspace.

    On a VM with a localhost server I got it close to 300 Mbps. I'm still way too early digging into the driver's code to conclude anything though. Still need to set up proper instrumentation to measure timings and all.
Sign In or Register to comment.