Advice for DNS leak

I got my first warning from my ISP yesterday while downloading.  It was puzzling since i had my vpn engaged, but after troubleshooting, I determined that my dns is leaking.  Tested it both before and after engaging vpn and both were positive for a leak.  IPv6 is working and not a problem.  I'm not very tech savvy so i could use some help in determining what I need to do from here. 

A few months ago I reinstalled my laptop with Linux 16.04.  Since then, I haven't been able to connect my vpn directly to the little robot icon at the top of the page.  Instead, Ive been engaging my vpn through the wifi icon at the top of my page (I don't know if this is considered OPENVPN).  Could the source of the dns leak be because I haven't been connecting directly to the robot icon?  If so, could someone please tell me how to fix my connection?  When I try to engage, the robot goes grey but ultimately turns back red, unable to make the connection.  Suggestions?  Advice?  I welcome it all.

Comments

  • Update:  Seems like my dns leak is a little more glitchy than I expected.  Ive been testing it all day (with vpn engaged) and some results claim the dns is leaking while other results claim everything is secure.  And there was one baffling result that said both.  if this has happened to anyone else, I'd love to know what you did to fix the problem.
  • Posts: 233
    Since OpenVPN is working and the PIA application is not, it is likely that you have an encrypted home directory. If you'd prefer to use the PIA application, you should be able to do so by moving PIA to /opt/.

    As for your DNS leak — the easiest solution is simply to use PIA DNS system-wide. DNS leak protection just forces your system to use PIA DNS, so using our DNS provides another layer of protection should something go awry. 

    You can change your DNS settings through Network Manager by doing the following:
    1. Go to "System Settings"
    2. Click on "Network" 
    3. Select the NON-VPN connection 
    4. Click "Configure" 
    5. Click on "Method" and set it to "Automatic (DHCP) addresses only" 
    6. Enter our DNS servers ( 209.222.18.222 and 209.222.18.218 ) 
    7. Click Save
  • My robot icon goes green now, so thank you so much.  I'm moving on to the dns issue.  In step #6, i just have to enter the number sequence, correct?  did that and hit Apply System Wide.  Thanks for the help.  I'll be in touch if I am still encountering problems.  thanks again!
  • Posts: 233
    Awesome, glad to hear you're now able to connect!
Sign In or Register to comment.