Versions newer than v71 can't start

Hi!
I tried intalling PIA v72, v73, v75 and v77. When installer finishes, it automatically opens PIA client, I can connect and works perfectly, until I close the client. Later, if I start (or automatically in the settings) the client, 2 pia_manager.exe task opens in the task manager and some moments later they closes and nothing happens (with v77 one time I could close and open again succesfully the client, but after I restarted the computer it couldn't load again). I tried to switch off all modules of Bitdefender Internet Sec., but nothing happened.
When I install v71, it works perfectly everytime.
This is a long-lasting problem, since then, I completely reinstalled Win10 2 times, but this problem always comes with the newer pia apps.
Did anyone had this problem?

Comments

  • Posts: 1,018
    That's rather strange.  I've never heard of that apart from a language issue that should be fixed in v77, so it must be something else.

    Can you email me the contents of the "C:\Program Files\pia_manager\log" folder after PIA failing to start at maxime+ft30607@londontrustmedia.com so we can have a look?
  • Posts: 1,018
    @p11p11p ; Got the logs, thank you!

    This is strange, it seems to be very similar to a bug that should be fixed already in this version.

    Can you try deleting C:\Program Files\pia_manager\log\pia_manager.pid and try starting it again? If it's what I think, this should allow PIA to start once more, until you reboot again.

    There is also a v78 beta that should go live today or tomorrow that fixes more language issues, so yours might be fixed in this one as well. Here are the instructions for the beta program: https://www.privateinternetaccess.com/forum/discussion/30113/announcing-the-new-beta-program-for-the-desktop-application#latest


  • Posts: 6
    It seems, deleting pia_manager.pid solved the problem. I can wait the stable v78, till that I will delete the .pid every boot.
    Thanks.
  • Posts: 1,018
    Hi again @p11p11p,

    I'm trying to reproduce the issue here so we can verify our fixes, but it seems to be working just fine for me.

    Which version of Windows 10 are you using exactly, in which language and region? This is definitely some kind of region issue but I just installed a Russian (CP1251) and Polish (CP1250) version of Windows and neither of them shows the issue.

    Can you also send us a debug log now that you can open the app so we can have a bit of a deeper look? The last thing your log shows is generating a crash log, which the debug log should include for us.

    Can you also please give the v78 beta a try even if temporary just to verify whether it fixes it or not? Trying v78 on my foreign language VM shows all the encoding errors are gone so that's progress at least. It would really help us to know if your issue is already fixed by the other language changes we have done. Feel free to reinstall v77 afterwards, although v78 is a minor update and should be just as reliable as v77 despite its "beta" label.

    Thank you for your help!
  • Posts: 1
    Hi,

    I had the same issue as the OP since v72 (Windows 10 v1709 Hungarian).

    v72-v75: deleting the PID files before starting PIA solved the problem.
    v77: disabling "Debug mode" worked too.

    I use v78 now and haven't noticed any problem yet.

  • Posts: 1,018
    Thank you @ph004 for your input!

    I just tried with a Hungarian Windows 10 install and immediately reproduced the issue, at last!

    I can also independently confirm this is indeed working fine on v78 with the other language fixes we included.
  • Posts: 6
    Hi!

    ph004 was faster than me, but my language is Hungarian also.
  • Posts: 1
    I just wanted to say, I've been having the same issue with not being able to launch pia-77 or pia-78 after installation since 3/24/2018. Previously, no issues.

    Trying pia-v71 did work for me, so that is a viable workaround in the meantime. Only installed using English, if that helps at all on an English Windows 10. This did happen after a Windows update, currently on Version 1709 (OS Build 16299.15).

    I hope this helps.  Thanks everybody.
  • Posts: 1,018
    @p1a1187 Can you send me your logs as per my post above so I can see what's happening to yours? Thanks
  • Posts: 2
    Anything past v76 doesn't seem to want to install properly or run on my windows 8.1. Been reading and waiting for updates and keep trying on each release but still, nothing works. Log folder isn't created on fresh install either. Ran in compatibility mode, admin, everything off including bitdefender. Nothing comes up in task manager, no nothing. Everything else is as up to date on updates as they can be.

    I did get v78 to run on my win 10 laptop over an old install, instead of having to completely uninstall and the tap drivers, though doesn't help me on my other machine. 
  • Posts: 1,018
    @p0435408 Can you please check in %TEMP% (you can press Windows+R to open the Run window and type that in) if you can see an ocrXXXX.tmp or nwNNNN_NNNNN folder being created when you launch PIA (where the X are letters/numbers, N just numbers)? One possible reason I see for it to not launch far enough to even create a log folder would be if it can't start Ruby at all.

    Are you able to create files and folders in that %TEMP% directory as well?
  • edited April 16 Posts: 2
    @Max-P
    Thanks for the response. Trying v79 this afternoon. Still the same problem. But with the temp folder open on the side while trying to run the program I can see the folders being created and then instantly deleted. Haven't been able to find any solutions. Tried permissions. Disabled firewall/AV. 
    Post edited by p0435408 on
  • Posts: 1,018
    Hi @p0435408,

    I have just discussed with the devs, and v79 apparently added early logging to help catch issues like this. Once you have installed v79, can you post your "C:\Program Files\pia_manager\log" folder here or email it to me at maxime+ft30607@londontrustmedia.com?

    There might also be a file in "C:\Users\YourUser\.pia_manager_crash.log", if it exists it will help us a lot so please post that as well.
  • Posts: 1,018
    Hi @p0435408,

    I received the log and talked to the development team. They are looking into it, there's a few possible fixes queued for v80. I'll update you as needed. In the meantime, I think you'll have to stay on v75 for a bit. Thank you for your help resolving that one!
Sign In or Register to comment.