VPN Constantly Dropping Internet Connection

edited October 2014 in VPN Setup Support Posts: 1
Hi,

After abit of info on how to set up a few things and if ive done the right thing..

Ive bought this product around 6 months ago for a few months trial. I was pretty impressed but i dont use it all the time.. Working away from home and no internet connection. So i get months here and there.

Using the standard PIA app for win 7 since buying it a few weeks ago, im forever dropping internet connection. The VPN connection (little green man in the taskbar) stays green and connected... but my wireless drops connection.. I cannot access the internet. If i head on over to the "Network and sharing centre" it shows me that I have a hazard warning from me to multiple connections... then a huge red X to the internet.
After a few minutes, both disapear and all becomes right for abit longer then it drops the connection again. Im not dropping wireless signal to the router.. Its as though the VPN connection thats set up TAP? is interfering with my internet. I tried the older version and ive also tried the newer version of the application to no avail.  So much so.. Ive tried to set up a "VPN PPTP" on the how to guides and ive generated the username and password needed.
As far as i know its working correctly.. I use and browse the internet (as i am now) I can check my IP address which isnt the same as the IP checked on my android phone via wifi and also that IP is the same as my router..  Is this as safe as PIA doing it for me?
So far no problems.. I am using the vpn for some torrenting via utorrent but mainly for anonymous browsing. I dont seem to be finding any issues with utorrent apart from being disconnected constantly

I tried talking with an agent but got disconnected (Surprised Surprise!!!)

Any help would be great
Post edited by Support on

Comments

  • sounds exactly what ive been going through,connection blows up entire home network (have to reset adapter settings)new to pia ,,but have other vpn softwares work flawlessly just setting up one dedicated puter to pia and get connected but as soon as i test  example -- speed check--- it  disconnects everything on home network   sorry for hijack but sounds like same issues   hopefully someone can help us
  • Posts: 10
    Add me to the list. It started July 8 if I try and download anything big my whole network crashes and the router reboots itself. I've tried multiple server and even a new router and problem still happens. Just talked to my friend on a different ISP and hes having the same problem no matter what server he picks. I also tried downloading without VPN and have no problem at all. Hope this gets fixed or a solution comes up as right now pia is useless to me.

    PS: problem happens on my win 7 computer and my linux server that worked fine before for over a year.
  • edited July 2014 Posts: 1
    It's constantly disconnecting and connecting for me while I run Deluge bittorrent client in windows 7.
    Post edited by p0871188 on
  • Posts: 1
    Another one here, I've just moved house and we are now with TalkTalk (UK) and it only happens when I'm connected to this service. If I go to my parents (Sky broadband) then its all fine, the connection at home only drops when I start torrenting. I've connected up a standard netgear router and it seemed more stable but still not perfect. That Netgear also did some odd things for the other users in the house (random drops etc) so put the talktalk one back and tried connecting the netgear wireless router along with a netgear websafe router via the talktalk one and it worked ok for a day. Now I'm back to a dropping connection when I start bittorrent, if I stop bittorrent and disconnect the VPN the connection comes back immediately.
  • Posts: 10
    Just to add I did some testing to be sure the problem wasnt in my house. I was using a linksys router so I ditched it and built a pfsense router. Everything works fine until I connect to the VPN. Browsing web sites seems to work fine but if I go to download a large file VPN disconnects and pfsense shows no wan ip and I have to reset every computer on the network to get it working again. A friend gave me his login to another VPN service to try and it worked flawlessly. Getting really frustrated at this problem and may have to switch services. 
  • Posts: 1
    I got PIA a few days ago and suffer from the same problem. It is really annoying as I bought the one year service -.-
  • Posts: 73
    Do you guys use Kaspersky by any chance? For me that was the issue of dc and as soon as i switched i don't get them anymore. Maybe just luck but i am not gonna bother testing it :P
  • Posts: 42
    Use OpenVPN.  I had have the same issues with the PIA app.  Openvpn never drops. Well for it doesn't..
  • When it drops, do you get this in your OpenVPN log?

    Authenticate/Decrypt packet error: bad packet ID (may be a replay): [ #299144 ] -- see the man page entry for --no-replay and --replay-window for more info or silence this warning with --mute-replay-warnings

    Fatal decryption error (process_incoming_link), restarting

    SIGUSR1[soft,decryption-error] received, process restarting

    WARNING: --ping should normally be used with --ping-restart or --ping-exit

    NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    I'd say it's Talktalk poisoning the link somehow. If PIA want help tracking it down, I'm more than happy to Wireshark it.
  • I'm also using TalkTalk and I don't think it's poisoning the VPN connection. From a Mac I have no problem, I haven't tried from Windows, but from my Linux box it will just drop the connection after a few minutes of connecting. I'm still looking for a solution, but I think my problem is different and my log doesn't really show anything.
  • First, ensure you only have 1 firewall running.

    Second, open the PIA client and go into settings. Set the remote port to a static port.

    Third, open your firewall (be it your anti-virus or windows firewall) and see if you can add port exceptions for that port

    Finally, login to your router and either look for a setting to allow vpn connections to pass through, or open your static port.

    Try this, if this doesn't help, then go back and undo everything and try something else. If it fixes the problem then either the firewall or router was interfering with the VPN.
  • Posts: 13
    I know this is an old thread, but I have to agree with rmay1216. The PIA (rather appropriate acronym there) client has been dropping connections for a while for me. Tonight, it became intolerable, refusing to stay connected for more than five minutes, often less. I got the Viscosity OpenVPN client and PIA's configuration files. It was a bit of a chore importing all the connections from the PIA files, but Viscosity so far has been rock solid. Knock wood. The PIA software has gone into the trash.
  • Posts: 13
    24 hours later using Viscosity, I haven't noticed any disconnects at all, unlike yesterday when it was basically 5 minutes connected, lose connection then 60 seconds or so for it to auto reconnect, repeated over and over. What lousy software the PIA client was. About the only thing Viscosity doesn't have is the kill switch, but even that didn't work. The only time I enabled that, it killed my Internet connection, alright. But it stayed dead and I had to quit the PIA software completely to get it back, so I don't miss the kill switch at all.
  • Posts: 2
    i tried to disable / enable internet connections while VPN is ON and it fixed the issue.
    I used this command
    cmd /c wmic path win32_networkadapter where NetConnectionID="Local Area Connection" call disable && wmic path win32_networkadapter where NetConnectionID="Local Area Connection" call enable
Sign In or Register to comment.