Tip - Mac OSX PIA Client - Solving connection issues with UDP

dvh
Posted on in VPN Setup Support

I found the standard Mac Private Internet Access client works very well with one “glitch”.  When configured in the default UDP connection type - it has issues connecting.  The “fix” in the support forums is to turn off the OSX firewall or connect using TCP.


I didn’t really want to turn off the firewall, and the default UDP type is a bit more efficient and the recommended connection type.


Solution - add the PIA executable to the “allow incoming connection” list in the firewall.  This is a little tricky but takes a minute and my experience is that connections will be then be quick and reliable.


1) If you’ve attempted connection - proceed to the next step.  Otherwise install the VPN Mac client, and fill in the supplied username and password.  You can check the defaults in the “advanced” section.  Select the closest region and udp as the connection type.   I choose  “Start Application at Start-up” and “Auto Connect...”  Save the settings -  and attempt to connect.  If the Firewall is “on” you may not be able to.  Disconnect.  It’s important, if you’ve just installed the client, to attempt to connect before proceeding.


2) Under System Preferences - Open the “Security and Privacy” panel.  Unlock the preferences and choose the “Firewall” tab. .  Select the “Firewall Options” button.  Leave this window / list open.


3) Go to the Finder “Go” menu - and select “Go to Folder...” and enter   /private/tmp/


4) You should see the file “pia_openvpn” listed


5) From the finder window drag the “pia_openvpn” file to the list in the Firewall window.


6) You should now see “pia_openvpn” listed - make sure “allow incoming connections” is selected.  Select “OK”, lock the preference pane and close the preferences window.  Close the open finder window.


7) Attempt to connect the client.  I’ve done this on three computers running Mountain Lion 10.7 and 10.5 Snow Leopard.  UDP connection now works perfectly here.  Currently very happy with the speeds and reliability of PIA.

Posts: 4
«1

Comments

  • prettyinbleu
    Posted on Posts: 3
    will try this out.

    thanks for sharing!
  • vaughan
    Posted on Posts: 12
    Thx for this. You spared me from banging my head against the wall.  
  • Sherwood507
    Posted on Posts: 1
    Worked for me too, thanks!
  • maroon
    Posted on Posts: 1
    Glad I found this! Thanks, dvh!
  • hoham
    Posted on Posts: 1
    Thanks for the solution!
  • grigsby
    Posted on Posts: 6
    This doesn't work for me.  Even if I allow incoming connections to the PIA app in the firewall configuration, I still can't connect over UDP.

    Is PIA aware of the issue?  Are they working on a fix?


  • VPN
    Posted on Posts: 795
    @grigsby: But it does work when you disable the firewall completely?
  • grigsby
    Posted on Posts: 6
    Yes, if I turn the firewall off, it does connect over UDP.
  • VPN
    Posted on Posts: 795
    Then perhaps you need to fine tune your firewall settings a bit more.
    Granted, PIA could have their app automatically configure the firewall on installation, but until they do, making it work lies in your own hands.
  • grigsby
    Posted on Posts: 6
    OS X doesn't offer a simple way to fine-tune its built-in firewall.  Yes, I think I can use the terminal to create my own ruleset, or perhaps find a third-party app to allow me to configure the firewall to allow UDP on certain ports.  But by default, OS X doesn't really allow you to do this.  PIA needs to fix their client so it works with the Mac firewall.  But you're absolutely right:  until they do, it's up to me to figure out how to get it to work correctly.
  • Alexander
    Posted on Posts: 4
    Thanks. Works perfectly.
  • drosan
    Posted on Posts: 1
    excellent solution, works perfectly
  • Coach
    Posted on Posts: 5
    Works fine with OSX 10.8.4

    THX
  • GolfPro
    Posted on Posts: 1
    The OP ("dvh") put together great instructions! This info REALLY needs to be included with the set up instructions for PIA's Mac OS client (ver 31). I also added the tray application - perhaps that would resolve issues that others have had even after adding the executable pia_openvpn to the firewall connections "allowed" list.
  • jcreegan
    Posted on Posts: 1
    Thanks to the OP for the help.  This really does need to be added to the Mac OS X setup instructions.  
  • grigsby
    Posted on Posts: 6
    An alternative solution (that I'm currently using) is to use a different client.  I've been using Tunnelblick.  I figure open-source code is less likely to have NSA backdoors, right?
  • qwers
    Posted on Posts: 1
    This solution completely worked for me. 

    My results with this solution using UDP:

    image

  • lonewolf
    Posted on Posts: 1
    Awesome , worked a treat thank you :) 

  • Coach
    Posted on Posts: 5
    is also recommended for v3.3,

  • neo2504
    Posted on Posts: 1
    Great, it works.
    These info should really be included in the software somehow.
    I registered just to thank you and confirm it works with v.34 and MacOSX 10.9.
  • gdon
    Posted on Posts: 1
    Thank you for this. I just purchased the yearly service and couldn't get the client to connect on my Mac but this worked perfect. They should make an update or something to let people on Macs know how to fix this.
  • abvpnab
    Posted on Posts: 8
    This really should be pinned/stickied at top of forum.
  • Bruter88
    Posted on Posts: 1
    Works wonders with Mac Os 10.9.1
    Higly recommendable. 
    THANKS
  • xgx579
    Posted on Posts: 1
    YES, UDP works perfectly again. Mac OSX 10.9.1


    This should be added to Mac Setup Instructions. 
  • tardisonline
    Posted on Posts: 35
    YES, UDP works perfectly again. Mac OSX 10.9.1


    This should be added to Mac Setup Instructions. 
    I am going to forward this to be added to the knowledge-base. Thank you for your contribution ;)
  • jjcoolaus
    Posted on Posts: 22
    This worked great - thank you so much. PIA is now my favourite VPN again.

    This is the result I got with my ADSL2+ connection from down here in Australia: 
    image
    Maxing out the connection :D
    Post edited by jjcoolaus on
  • MiguelATF
    Posted on Posts: 2
    I've followed all the instructions for adding the pia_openvpm file to the firewall.  But still NO GO.  Then I tried turning the firewall off.  Still NO CONNECTION.  

    I continually get the following error message -

    You were disconnected by the communication device. Try reconnecting. If the problem continues, verify your settings.

    I'm running the latest version of Mavericks - OS X 10.9.2 - on a MacBook Pro.  My PIN Client worked perfectly with Snow Leopard (OS X 10.6) - but ever since upgrading (recently) to Mavericks, nothing, zip, nada.

    Please please PLEASE can someone help me out here??????
  • tardisonline
    Posted on Posts: 35
    I've followed all the instructions for adding the pia_openvpm file to the firewall.  But still NO GO.  Then I tried turning the firewall off.  Still NO CONNECTION.  

    I continually get the following error message -

    You were disconnected by the communication device. Try reconnecting. If the problem continues, verify your settings.

    I'm running the latest version of Mavericks - OS X 10.9.2 - on a MacBook Pro.  My PIN Client worked perfectly with Snow Leopard (OS X 10.6) - but ever since upgrading (recently) to Mavericks, nothing, zip, nada.

    Please please PLEASE can someone help me out here??????
    Please submit a ticket anytime for further assistance, via the following link: https://support.privateinternetaccess.com/index.php?/Tickets/Submit
  • MiguelATF
    Posted on Posts: 2
    Thanks, tardisonline  - I've just submitted a 'ticket' to the Tech Support folks....let's see if they can come up with a solution, keeping my fingers crossed.
  • Raf
    Posted on Posts: 8
    I've been reading this and I'm glad some of you got this fixed. I am on Mac OS X 10.9.2. and believe me when I say I tried everything, well except the one that cost me money. I started a new discussion but I'm glad I found this one. Here's my problem:

    - Firewall was off by default, I just checked it's been off since I got this Mac apparently. 
    - Submitted ticket, they told me to try TCP, then try different DNS, then try something through terminal, then try downloading Tunnelblick (which doesn't support Mac 10.9), then try Viscosity (which costs $9) and run these different config files after. 
    - Tried everything except Viscosity, although $9 is not a lot I fail to see how tech support cannot solve this issue.
    - My ONLY fix for this problem, is a restart. Then it'll work fine for a day, 3 tops and it'll go all grey little man in menu bar on me, and can't connect for the life of me until... you guessed it restart again. On a bad day I find myself restarting twice or more. 

    Issue has been with customer service for over a week now, and after umpteen emails back and forth from different customer service reps, nada...zilch...

    So tell me, is it worth staying with PIA if my first two weeks have been so glitchy?
Sign In or Register to comment.