How to use PIA on OpenELEC with Kodi (previously XBMC)

Hi there,

It took me the better part of a year to get VPN working on OpenELEC. I wanted to save you the time of finding it out. Here is how you do it:

1) Browse to SYSTEM > OpenELEC
2) Go to Nework and choose "Add new VPN-configuration"
3) Use the following settings:
VPN type = pptp
Network name = PIA US-EAST
VPN Server = us-east.privateinternetaccess.com
Username = [YOUR PPTP USERNAME]
Password = [YOUR PPTP PASSWORD]
VPN DNS Domain = vpn
Show advanced = on
Require MPPE (128 bit) = on
Refuse CHAP = on
Refuse MS-CHAP=on
Refuse PAP = on
Refuse EAP = on

4) Safe it
5) Go 1 step back in the menu and choose Connections (below Network you previously chose)
6) It should show PIA US-EAST (or the name you entered), select it
7) Choose connect
8) Voila!

If you want to check the generated config file do the following:
1) Connect to your openelec system over samba (make sure this is switched on in your OpenElec)
2) Open the file \\[name of your openelec system]\Configfiles\vpn-config\[PIA US-EAST.config]
3) It should look very much like this:

[global]
Name = PIA us-east

[provider_pptp]
Type = pptp
Name = PIA us-east
Host = us-east.privateinternetaccess.com
PPTP.User = [YOUR PPTP USERNAME]
PPTP.Password = [YOUR PPTP PASSWORD]
Domain = vpn
advanced = 1
PPPD.RequirMPPE128 = 1
PPPD.RefuseCHAP = 1
PPPD.RefuseMSCHAP = 1
PPPD.RefusePAP = 1
PPPD.RefuseEAP = 1

Comments

  • edited March 2015 Posts: 1
    Just to add, in the Client Control Panel of PrivateInternetAccess website, you need to generate a PPTP username/password.

    This is the username password that you need to enter in the configuration.

    Thanks a lot for the help NaN!
    Post edited by microcontroleur on
  • edited March 2015 Posts: 342
    @microcontroleur

    Note that your PPTP username password is not the same as the username and password that you use for the PIA app or for OpenVPN:

    You have to visit this page and Generate a PPTP Username and Password:  https://www.privateinternetaccess.com/pages/client-support/
    Post edited by Khariz on
  • edited May 2015 Posts: 1
    When I try this I get 'user passphrase'

    I appreciate your effort, just hope I can get it to work for me. The whole reason I bought a Chromebox was to use OpenELEC/Kodi/PIA for my HTPC
    Post edited by sleepydupree on
  • Posts: 1
    Hi there,
    It took me the better part of a year to get VPN working on OpenELEC. I wanted to save you the time of finding it out. Here is how you do it:
    Worked great for me and 15 of my customers until Openelec  6.0 Beta 1. Tried it on two different installs on two different systems, in both cases had to revert back to 5.0.8  Any suggestions?
  • openELEC 6.0 Beta 2 and still not working.  Copied the vpn-config folder from 5.0.8 stable release which works to 6.0.  Got success message when I ran the Setup Private Internet Access menu item, but when I went to Connections in openELEC, the VPN connections do not appear.

    Additionally, if you click Remove VPN, it causes the VPN removed screen to appear every time thereafter that you open Programs tab.   I had to go to user_data |  addon_data | plugin.program.oepla and edit the settings.xml and put in my username and password in order to restore functionality.

    My advice is to stay away from 6.0 Beta if you want to run VPN.

    I am testing on a Raspberry Pi 2.
  • Running openelec 5.0.8, signed up and followed this guide. I did generate the pptp user and pass from client control panel. Problem is i'm still not connecting to their servers. I have the app/repo as well. Here's what's happening...
    openelec settings-network-add new vpn config, i go and add info as stated above in this post, save it etc and then go to connections to us-east, click on that and says state:association and does nothing. I go back out to network and all the settings are gone like i never set it up. So i tried putting those same settings in under connections-us-east-edit, etc and that doesn't work either.
    So i asked pia chat person and they said to use openvpn as it was more stable for linux? Do you guys have any suggestions to try besides the openvpn?

  • Anybody cracked this yet.  I've been trying for the last 3 months and i've been going round in circles.  I have tried DNS which was patchy and have completely failed to get a vpn to run.  Any help PLEASE.
  • Posts: 1
    The easy way to get PIA working on a device running OpenElec such as a Raspberry Pi or a Wetek box, is to setup this addon as detailed on the website: http://www.kodipiguide.com/guides/setup-vpn-openelec-addon/
  • Here are 5 steps for getting a proper understanding that how you can configure PIA vpn with kodi

    Step 1: Register for an account of Private internet Access through your website. You will receive a letter from them with your data entry once payment is complete.

     Step 2: Go to Web site technical assistance of their website and download your application on a specific device. PIA VPN has versions for Mac, Windows, Android, IOS, the Ubuntu platform and more!

    Step 3: Once your VPN software is installed, you must enter it using data that has been received via email after registration.

    Step 4: You need to run the software application "Private internet access" when you want to surf the web through a virtual private network (or watch blocked content via XBMC), you can also configure the software to automatically load at the start of software preferences.

    Step 5: Launch of "Kodi" and use it as usual, or surf the web, or do what you want, anonymously with maximum security. You not even notice the difference!

    However for here is a PIA support: https://www.privateinternetaccess.com/pages/client-support/

    And here is another detail guide to setup VPN on kodi: https://www.vpnranks.com/kodi-vpn/

  • edited January 28 Posts: 38
    Follow these steps:
    1. Copy both Open VPN Manager & OpenVPN zip files to your OpenElec Box
    2. Now, Go to System >Add-Ons> Install from Zip File > Select VPN Manager for OpenVPN zip file and install
    3. Once again, Go to System >Add-Ons > Install from Zip File > Select OpenVPN zip file and install
    4. When both Add-ons are enabled , go back to the home screen
    5. Go to , Home Screen > Programs> VPN Manager for OpenVPN > Add-on Settings> Wizard
    6. A list of VPN providers will come up, choose your provider from the list
    7. Enter VPN username and password in respective fields then click done
    8. VPN Manager will now start
    9. You can choose a VPN profile that can auto-connect and you can choose to change auto connect too
    10. 4 VPN servers or locations can be added to VPN Manager for Open VPN, otherwise you have to manually configure it on the OpenVPN app when you use the service.
    Sources: 
    http://openelec.tv/forum/12-guides-tips-and-tricks/80577-private-internet-access-pia-vpn-configuration
    Post edited by willieaames on
  • Steps to setup VPN within Kodi

    Now you might want to use a VPN from within Kodi. It’ll save the time to install VPN on all the devices where you access Kodi. Just select your best VPN for streaming Kodi media and follow the steps below:

    1. First of all, download and install the software called OpenVPN GUI. 
    2. Next, download Zomboided Repository from Github.
    3. Now launch Kodi>Add-Ons>Add-On Browser.
    4. Select Install from zip file option.
    5. Download the Zomboided Repository.
    6. Once done, click on Install from Repository
    7. Navigate your way to Zomboided Add-on Repository> Services> VPN Manager for OpenVPN.
    8. Once the add-on is enabled, open it and click on add-on settings.
    9. Select VPN Configuration> VPN Provider. 
    10. Enter the username and password. 
    11. Now go to VPN Connection tab and click on First VPN Connection.
    12. Select the server you want to connect with. 
    13. Click Ok and you’re done.
    Hope these will help you.

    Source: 
    http://openelec.tv/forum/12-guides-tips-and-tricks/80577-private-internet-access-pia-vpn-configuration
    https://freaksense.com/best-kodi-vpn/

Sign In or Register to comment.