PIA VPN App - Linux Beta

1356719

Comments

  • Although.... after I disconnect from the client I have to delete the entries in /etc/resolv.conf manually. Only after that can I browse again.

    I have to do this on the eduroam network of the university library - to able to access the e-database.

    Am I missing something, or doing something wrong?
  • edited December 2013 Posts: 61
    Although.... after I disconnect from the client I have to delete the entries in /etc/resolv.conf manually. Only after that can I browse again.
    ....
    I hadn't noticed that issue but was able to duplicate in lm16 MATE 64-bit.  I think the problem is that the 'resolver' isn't configure properly?

    In a _terminal_window_, try running:
     'dpkg-reconfigure resolvconf'  --or-- 'sudo dpkg-reconfigure resolvconf'
    depending on your login.  Answer 'Yes' to the first prompt.  There are more pompts an explainations as well but just move on!  You may have to reboot?

    If all goes well when NOT connected to PIA VPN, you resolv.conf should read as:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.1.1
    After I did what I have described above, the behavior of '/etc/resolv.conf' worked as expected when disconnected form the PIA VPN Linux Beta client.  I.e., NetworkManager reverts back to using the DNS server(s) supplied by the default DHCP server and not the PIA DNS entries configured by the PIA VPN beta client.
    .




    Post edited by martywd on
  • Thank you for looking into this. 

    I have to add though, that since yesterday the nameservers weren't kept anymore in resolv.conf. However I was experiencing the same problems after disconnecting from the client. Usually what helped was restarting the network-manager, or sometimes a simple disable/enable of networking would do it.

    I tried you sollution, then rebooted, and rechecked twice, however it still keeps the nameservers (and indeed, before this reconfiguration the file was just empty, now it gives me the following output). But I am able to keep browsing after disconnecting from the client, so it seems to be working okay for now.

    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    nameserver 209.222.18.222
    nameserver 209.222.18.218


  • edited December 2013 Posts: 61
    Thank you for looking into this. 

    I have to add though, that since yesterday the nameservers weren't kept anymore in resolv.conf. However I was experiencing the same problems after disconnecting from the client. Usually what helped was restarting the network-manager, or sometimes a simple disable/enable of networking would do it.

    I tried you sollution, then rebooted, and rechecked twice, however it still keeps the nameservers (and indeed, before this reconfiguration the file was just empty, now it gives me the following output). But I am able to keep browsing after disconnecting from the client, so it seems to be working okay for now.

    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    nameserver 209.222.18.222
    nameserver 209.222.18.218

    >> Thank you for looking into this.

    FWIW, I'm just a lowly user like you!

    With that typed...
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    nameserver 209.222.18.222
    nameserver 209.222.18.218
    Hmmm?  Ok, look here in the following directory path:  '/etc/resolvconf/resolv.conf.d/' .

    Once in that directory open the 'tail' file (if it exists?).  If it does exist, it most likely has PIA's DNS servers listed on two lines.  And 'resolver' is appending them to the '/etc/resolv.conf' when networking without the PIA VPN linux client?

    If 'tail' does exist, and if PIA's nameserver config are there(?), use a text editor (you'll need to 'sudo' or 'gksu' depending on which editor you use) to comment out ('#' beginning of each line) or delete lines (be careful!) those entries from the 'tail' file.

    Once done AND depending on which way you edit 'tail and networking is restarted, resolver should write out the '/etc/resolv.conf' like this:

    If the extra 'namesever' entries were completely deleted from the 'tail' file:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    If the 'nameserver' entries were commented out:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    #nameserver 209.222.18.222
    #nameserver 209.222.18.218
    with the PIA DNS server entries still present, but disabled.

    BTW, I believe an explanation (saving the existing 'resolv.conf' servers entries before reconfiguring, was provided for all this in the various screens presented by 'dpkg-reconfigure resolvconf' ?  <wink>

    Good luck!
    ..

    Final edit (I hope?)
    More info in the 'man'...
    command in a terminal window:  $ man 8 resolvconf

    The detail for 'tail'...
           /etc/resolvconf/resolv.conf.d/tail
                  File  to  be  appended to the dynamically generated resolver configuration file.
                  To append nothing, make this an empty file.  This file is a good place to put  a
                  resolver options line if one is needed, e.g.,

                      options inet6
    .
    Post edited by martywd on
  • Posts: 49
    I bet the Linux client is broken probably PIA decide to stop the beta testing due to increase in it server bandwidth and hardware load to handle. Probably PIA shall consider what i have recommended during the initial alpha state
  • llllll
    Posts: 5
    It doesn't work on Debian wheezy, assuming that applies to LMDE and other debian distros since they use an older glibc. Also totally off-topic  I noticed a few people in the thread using mint, as default on mint when it checks up updates (every 15 minutes) it pings the google servers which is no good for privacy more info can be found here and a fix is it the bottom of the page http://forums.linuxmint.com/viewtopic.php?f=90&t=145176
  • edited December 2013 Posts: 7
    I'm still new to linux, but I found this app very handy. I tried the VPN kill switch in VMWare fusion 6 with bridged networking. Everything worked fine except when I want to access the machine from outside the VM. If I turn off kill switch, I can access the machine again (ping, http, etc).

    On my OSX machines, with VPN kill switch enabled, I am still able to ping that local machine IP address. Wondering if anyone has thoughts if this is a Virtual Machine or PIA App thing.

    Edit: Using Linux Mint 16 Xfce 64-bit

    Thanks and keep up the good work.
    Post edited by iusepia on
  • Thanks for supporting Linux.

    The install script doesn't work with Manjaro however as Manjaro is arch-based and uses Pamac etc.

    Would be great if you could get this to work on Manjaro.

    Thanks for the Linux support either way.
  • edited January 2014 Posts: 1
    On my OSX machines, with VPN kill switch enabled, I am still able to ping that local machine IP address. Wondering if anyone has thoughts if this is a Virtual Machine or PIA App thing.Edit: Using Linux Mint 16 Xfce 64-bit
    I just wanted to say that I have a similar problem with Mint x64 - I'm unable to access any resources on my LAN (or be accessed) unless I uncheck the VPN "kill switch". The kill switch works properly on my Win7x64 box, of course. 

    Thanks!
    Post edited by darren on
  • i have a strange one with this. the app works but with just 1 problem.

    i have shares set up on my network to my nas drive, when i use this app my pc cannot connect to the nas drive as soon as its stopped i can connect to the nas drive ok.

    the nas drive is a linkstation 1tb, im running ubuntu 12.04 LTS not a fresh install.

    any ideas?

    thanks
  • Posts: 61
    @psychocydd -- "i have shares set up on my network to my nas drive, when i use this app my pc cannot connect to the nas drive as soon as its stopped i can connect to the nas drive ok."

    A possible solution?  The Linux Beta PIA VPN client changes the DNS config which hoses your/my client machine's ability to resolve other machine names on the LAN.  So....

    Try adding your NAS server's numbered IP address and name to your 12.04 LTS' '/etc/hosts' file with whatever text editor you are familiar with using.  As you probably already know you will have to 'gksu' or 'sudo' to amend that file if working from the commandline in a terminal window?
    .
  • @martywd - A possible solution?  The Linux Beta PIA VPN client changes the DNS
    config which hoses your/my client machine's ability to resolve other
    machine names on the LAN.  So....

    Try adding your NAS server's
    numbered IP address and name to your 12.04 LTS' '/etc/hosts' file with
    whatever text editor you are familiar with using.  As you probably
    already know you will have to 'gksu' or 'sudo' to amend that file if
    working from the commandline in a terminal window?

    i have tried all that and it all works until i start the vpn client then connection is lost to the shares.. strange i have the win 7 version and that works perfect with no changes needed.

    i have gone back to manual connection until this is sorted out.
  • Posts: 61
    @psychocydd typed: 'i have tried all that and it all works until i start the vpn client then connection is lost to the shares.. strange i have the win 7 version and that works perfect with no changes needed.

    i have gone back to manual connection until this is sorted out.'

    Dang!  I thought that would solve this issue for you?

    FWIW, I'm serving on multiple machines both samba and nfs shares to clients (1 - Win7 client, the rest *nix clients) on my LAN.  Manually adding the server's IP# address and name to the '/etc/hosts' on BOTH *nix servers and clients solved the issue for me on client machines using PIA's VPN *nix client app.
    .



  • Has anyone been able to install and use the app in Fedora ? I installed it but when I click on the launcher nothing happens.

    It would be nice to have rpm packages.

    Thanks
  • Posts: 11
    I got this working in Manjaro Linux an arch based derivative, I had to link a few libraries and manually install them through aur as well as the Manjaro repo's, after that everything works fine, BUT, internet killswitch prevents local network connections like plexmediaserver
  • Posts: 61
    @defcon typed:  BUT, internet killswitch prevents local network connections like plexmediaserver

    @darren on Jan 6 posted about this issue (...unable to access any resources on my LAN (or be accessed...), too.

    And, I'm seeing the same thing as well on my LAN with the Kill Switch enabled.  Something to do with routing, I think?  Hopefully support will figure out how to fix this in an update?

    Nice work getting the Beta PIA VPN client working in Manjaro.  The workaround sounds complicated.  And painful.
    .
  • I am interested in installing on my headless ubuntu server 12.04. Will this require a gui to interface with, or can i set up autoconnect via CLI?
  • @Bunkmil asked: Has anyone been able to install and use the app in Fedora ? I installed it but when I click on the launcher nothing happens.

    To get it to work in your Gnome Shell notification area you have to add an extension.  Go to https://extensions.gnome.org/ then the extension for AppIndicator Support then PIA  will then show in your notification area of Gnome Shell when launched.
  • Posts: 49
    I have tested it as below.

    OS : Linux mint 16 cinnamon 64 bits
    Result : Failed to start

    OS : Linux mint 16 cinnamon 32 bits
    Result : Failed to start

    OS :Ubuntu 13.10 Gnome 32 bits
    Result : Work. Some time it failure to start to NTP date & time on the OS is causing the issue. Just need to adjust the date and time, it working fine.
  • Posts: 4,013
    Use Mint 15 and it should work fine.
  • edited January 2014 Posts: 5
    UserOne : Thanks for your reply. However, I'm using the KDE edition of Fedora so the Gnome shell extension doesn't apply...

    I noticed that if I run the /home/xyz/.pia_manager/pia_tray.64/pia_tray script in a terminal I get the following error :

    "Couldn't load file:/home/xyz/.pia_manager/pia_tray.64/runtime/1.3.2-beta/libtide.so, error: libgnutls.so.26: cannot open shared object file: No such file or directory"

    There is probably a package that I need to install for it to work, but which one ?
    Post edited by Bunkmil on
  • Posts: 4
    I got this working in Manjaro Linux an arch based derivative, I had to link a few libraries and manually install them through aur as well as the Manjaro repo's, after that everything works fine, BUT, internet killswitch prevents local network connections like plexmediaserver
    If you could post a tutorial, that'd be legit.  I just switched from Ubuntu to Manjaro today... That's the only thing I can't seem to get running, because I can't find the equivalent packages :P
  • edited January 2014 Posts: 7
    having just installed a ssd i have installed a fresh copy of ubuntu 12.04 LTS and installed this app.

    before i connected the app i made sure i could connect to my network shares which i could.
    i started the app and with kill switch active i could not connect to my shares, i then turned off the kill switch and could again connect to my shares.

    to test again i turned on the killswitch and then i could connect to my shares again with kill switch on.

    maybe those having problems should try what i did above with the kill switch and see if it works for you.

    note: rebooting or switching off the app will mean next time you open the shares again as below.

    start app, when connected untick killswitch and save, open each of your shares to make sure you are connecting to them then tick killswitch and save.

    now your shares should work with the app running.
    Post edited by psychocydd on
  • Posts: 61
    @psychocydd typed:  i started the app and with kill switch active i could not connect to my shares, i then turned off the kill switch and could again connect to my shares.

    to test again i turned on the killswitch and then i could connect to my shares again with kill switch on.


    Good catch.  I'm seeing exactly the same behavior.  In fact, I see this with the 'VPN Kill Switch' ticked and save, 'VPN Kill Switch' un-ticked and save, for accessing shares in BOTH the 'Connect' and 'Disconnect' conditions!

    Furthermore.  I find that with the 'Kill Switch' enabled and then disconnecting from PIA once again causes network shares on my LAN, both nfs and smb (cifs), to be inaccessible.  Opening 'Settings', un-ticking 'VPN Kill Switch' and then clicking 'Save', reopening 'Settings', ticking the 'VPN Kill Switch' option again and then clicking 'Save' brings back shares accesiblity on my LAN, but also ALLOWS Internet connectivity, which means the 'VPN Kill Switch' functionality has been disabled.  To re-enable this functionality one must again 'Connect' the PIA VPN client, which of course then DISABLES accessibility to shares on the LAN.  Rinse and Repeat...

    I guess typing that there is something seriously whacked with the 'Kill Switch' option would be an understatement?  But then again, the 'VPN Kill Switch' option doesn't work all that well in the Windows PIA VPN Client either from my very limited experience with that platform.

    I know, I know.  Setting the 'VPN Kill Switch' always gives the dire warning that something may break:
     
    Please only enable VPN Kill Switch if you really need it.  The Kill Switch requires modifying the Operating System's network settings and can in rare cases cause connectivity issues.  This feature WILL NOT work if you use MORE THAN ONE network interface on your computer simultaneously.

    Are you sure you wish to enable VPN Kill Switch?


     But still...  A fix would be nice.
    .


  • Successfully installed under Linux Mint 16 32bit (running as VM) Hasn't shown any dns leaks. Connection is solid with no issues so far.
    Any news on when this might get moved out of beta?
  • Posts: 186
    How can I completely remove this?  I would like to reinstall it from scratch...
  • Posts: 186
    I'm sorry if it's a dumb question, but I really want to remove this.  I've tried

    sh installer.sh --uninstall
    and
    apt-get remove installer.sh

    to no avail.  little help?
  • @pyro12 : How can I completely remove this? I would like to reinstall it from scratch...

    If you are NOT comfortable with running commands in a terminal window.  THEN DON'T read further !!!

    With that warning typed.  From my experience, the PIA installer only installs the Linux PIA VPN client in your $HOME directory.  So.  To remove all installed directories and files created by the Linux PIA 'installer.sh' in your $HOME directory.  Run this command in a terminal for clues:

      ls -ld .pia* pia* $HOME/.local/share/applications/pia*

    Then still in a terminal window use the 'rm -R' command (carefully) in place of the 'ls -ld' command to remove directories and files you see from running the 'ls' command listed above.

    After that.  Do the install again if you want to do a fresh install.
    .

  • Posts: 186
    @martywd

    Thank you!

    Reinstalling this, along with cleaning out /etc/Network Manager/ has allowed me to max out my connection speed again.  I had been concerned about simply deleting everything because of the kill switch and its warnings about modifying network settings.  I had thought maybe there was an 'uninstall' to revert back to how things were set up beforehand.
  • edited February 2014 Posts: 186
    (duplicate post)
    Post edited by pyro12 on
Sign In or Register to comment.