Skip to main content

Are You Seeing The Message "Client Update Needed?" - News / Announcements - PIA Support Portal

Nov 11 2020

Are You Seeing The Message "Client Update Needed?"

Authors list

If you are attempting to connect to a server or servers, but seeing the message “Client Update Needed” in the server list, this likely indicates that you currently have an older version of the application installed or that you are connecting to our “Legacy Network.”

As mentioned in our blog post, we are happy to announce that we have begun the process of retiring our legacy infrastructure in favor of a significantly improved and upgraded infrastructure, meant to enhance and improve your VPN experience. 

As a result of this change, beginning with v2.3.0 of the desktop application, the new infrastructure (or Next Generation Network), is the default setting within the application. If you are not currently using v2.3.0 or above, please visit our download page, here, and install the latest version of the application for your operating system.

In some circumstances, you may not be able to download the most recent version of the application. Such would be the case for older versions of Windows or macOS. In that case, the following table will offer options that are currently available to you based on your situation (or the latest version of your OS available for install).

As always, should you experience further issues, please don’t hesitate to reach out via our 24/7 chat or by submitting a ticket, here.

Operating System
Alternatives to the Latest Version
Windows 7
macOS 10.11 (El Capitan)
macOS 10.12 (Sierra)


As always, should you experience further issues, please don’t hesitate to reach out via our 24/7 chat or by submitting a ticket, here.